Bug 70756 - FORMATTING: Heading 1, Insert page, following paragraph has Outline-Level 1
Summary: FORMATTING: Heading 1, Insert page, following paragraph has Outline-Level 1
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: lowest minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Bullet-Number-Outline-Lists Writer-Styles-Paragraph
  Show dependency treegraph
 
Reported: 2013-10-22 11:41 UTC by Laurent BP
Modified: 2021-05-01 12:33 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample text showing wrong outline level in navigator (8.29 KB, application/vnd.oasis.opendocument.text)
2013-10-22 11:41 UTC, Laurent BP
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent BP 2013-10-22 11:41:54 UTC
Created attachment 87979 [details]
Sample text showing wrong outline level in navigator

Problem description:
All text is "Level 1" and appear in TOC or navigator 

Steps to reproduce:
1. Create new document
2. Set style to Heading 1
3. Insert page break (Ctrl+Enter)
4. Go back to first paragraph (Heading 1)
5. Type Enter
=> A new empty paragraph is created with style Text body. However:
6. Format > Paragraph > Outline & Numbering

Current behavior:
Outline level is "Level 1"

Expected behavior:
Outline level should be "Body text"

Reproduced with: 
- Version 3.6.7.1 (Build ID: 9418c72)
- Version 4.0.5.2 (Build ID: 5464147a081647a250913f19c0715bca595af2f)
- Version 4.0.6.1 (Build ID: 7168152d13aa529ba3718c9ae3700216a574137)
- Version: 4.1.3.1
Build ID: b42498da0e3f91b17e51b55c8295ec4f8f22087
              
Operating System: Windows 7
Version: 3.6.7.2 release
Comment 1 sophie 2013-10-22 12:04:32 UTC
Reproduced on linux using Version: 4.2.0.0.alpha0+
Build ID: 051731bbcaa79b6428c8ebee6c114c9b28220cc8
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2013-10-21_01:09:11 and a new document. Set as New, changed plateform to All - Sophie
Comment 2 Laurent BP 2013-10-22 12:15:12 UTC
Reproduce with LibreOffice 3.5.0rc3 
Version ID : 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Change version
Comment 3 pierre-yves samyn 2013-10-22 12:29:49 UTC Comment hidden (obsolete)
Comment 4 pierre-yves samyn 2013-10-22 12:33:45 UTC
In addition I precise that only the paragraph after the title has level 1

Pierre-Yves
Comment 5 samuel.vannay 2013-10-22 17:59:03 UTC
Reproduce on Linux, Version: 4.1.2.3 Build ID: 410m0(Build:3)
Reproduce on Mac, Version 4.0.2.2
Reproduce on Windows 7, Version 4.0.?.?

Reproduce on those OS with OpenOffice.org

In fact, this is a very old bug. I've just checked my logs, I have it since 2006.

From 2006, I've teached the basics of formatting with OpenOffice.org, then NeoOffice, and now LibreOffice and I've always had this bug. Sorry not to have mentioned it earlier...

Usually I request the students to apply all the paragraphe styles in a document, then they have to create the Table of Content. If they insert a page break directly in front of the first paragraphe, which is in heading 1, the bug occurs.

It also occurs if the page break is inserted in front of any other heading style.

Regards

Samuel
Comment 6 Laurent BP 2013-10-22 20:07:05 UTC Comment hidden (obsolete)
Comment 7 samuel.vannay 2013-10-23 07:21:46 UTC
(In reply to comment #6)
> @Samuel: I DO reproduce with first versions of LibO
> - LibreOffice 3.3.0 OOO330m19 (Build:6) tag libreoffice-3.3.0.4
> - LibreOffice 3.3.4 OOO330m19 (Build:401) tag libreoffice-3.3.4.1
> - LibreOffice 3.4.0 RC1 OOO340m1 (Build:11)
> 
> but I do NOT reproduce the procedure described above with OOo or AOO:
> - AOO 4.0.0
> - AOO 3.4.0
> - OOo 3.3.0
> - OOo 3.2.1
> So the bug was may be different in OOo. Could you give a procedure to
> reproduce on OOo?

You're right: I just have a quick test on AOO 4.0.1 on MacOS and the bug cannot be reproduced.

I'll we try another check this afternoon on a Windows machine with a portable version.
Comment 8 QA Administrators 2015-04-01 14:40:25 UTC Comment hidden (obsolete)
Comment 9 Laurent BP 2015-04-01 20:30:24 UTC Comment hidden (obsolete)
Comment 10 tommy27 2016-04-16 07:26:36 UTC Comment hidden (obsolete)
Comment 11 Laurent BP 2016-04-16 12:19:44 UTC Comment hidden (obsolete)
Comment 12 QA Administrators 2017-05-22 13:22:40 UTC Comment hidden (obsolete)
Comment 13 Laurent BP 2017-05-22 20:16:39 UTC Comment hidden (obsolete)
Comment 14 Timur 2017-12-25 17:32:10 UTC Comment hidden (obsolete)
Comment 15 Laurent BP 2017-12-25 21:47:08 UTC Comment hidden (obsolete)
Comment 16 QA Administrators 2018-12-26 03:41:07 UTC Comment hidden (obsolete)
Comment 17 Thomas Lendo 2019-01-05 18:57:11 UTC
Still repro.
Version: 6.3.0.0.alpha0+
Build-ID: be8897d9c63a77b223a9c0aed1d2eb689e0e0082
CPU-Threads: 4; BS: Linux 4.15; UI-Render: Standard; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-01-02_04:49:04
Comment 18 QA Administrators 2021-01-05 03:47:53 UTC Comment hidden (obsolete)
Comment 19 sdc.blanco 2021-03-25 11:52:12 UTC
(imo) this is a WF or "low trivial" bug.

1. Repro STR in comment 0 with 7.2.0.0.alpha0+ 

2. Modified STR:  Before (or after step 2) in STR, insert one character.

   Result: Do not reproduce (i.e., new paragraph after heading has outline level "Text Body")

Additional information.
1. With an empty Heading and Enter, the text body paragraph has the expected outline level.
2. The text body on the second page (after Ctrl-Enter) has the expected outline level.

In short, this "bug" appears in the highly specialized case of:
1. an empty heading ps (can also be H2, etc.), without a new paragraph
2. followed by a page break, then
3. return to the empty heading, now the new text body paragraph from return has the same level as the heading.

Hard to imagine that this sequence is a typical (or even "rare") use case.