Download it now!
Bug 70925 - Advanced filter: case sensitive criterium produces no result
Summary: Advanced filter: case sensitive criterium produces no result
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-27 17:14 UTC by Jean-Baptiste Faure
Modified: 2015-04-12 09:16 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
bugdoc with data test (25.16 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-10-27 17:14 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2013-10-27 17:14:33 UTC
Created attachment 88186 [details]
bugdoc with data test

Steps to reproduce:
1/ open the attached file
2/ sheet 1 : select all
3/ sheet 2 : Data > Filter > Advanced Filter ; select the range $Feuille2.A1:F2
4/ button More... and check the checkbox "Case Sensitive"
5/ check the checkbox "Copy result to" and choose $Feuille3.A1
6/ OK button

Current behavior: no result in sheet 3
Expected result: the sheet 3 is filled with data.

Works as expected if the checkbox "Case Sensitive" is not checked.

Best regards. JBF
Comment 1 GerardF 2013-10-27 21:07:06 UTC
MIME type corrected.

I confirm this bug with 4.0.5.2

Works as expected with Version: 4.2.0.0.alpha0+
Build ID: b7e5ab6f65eb682bfa200459d745d3bc4056e42a
TinderBox: Win-x86@42, Branch:master, Time: 2013-10-24_22:59:23

bug corrected by collateral effect or deliberately?

Can not test with 4.1.x...
Comment 2 Dominique Boutry 2013-10-28 08:23:18 UTC
Reproduced with LibO 4.1.2.3 on Win7
Comment 3 Jean-Baptiste Faure 2013-10-28 08:51:25 UTC
(In reply to comment #2)
> Reproduced with LibO 4.1.2.3 on Win7

Ok, so set status to NEW.
Comment 4 QA Administrators 2015-04-01 14:41:34 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-01
Comment 5 Jean-Baptiste Faure 2015-04-12 09:16:26 UTC
Works as expected with LibreOffice 4.4.3.0.0+ built at home under Ubuntu 14.10.

Closing as WorksForMe.

Best regards. JBF