Bug 70937 - Libreoffice crashes with segfault in soffice.bin "error 4 in libmergedlo.so"
Summary: Libreoffice crashes with segfault in soffice.bin "error 4 in libmergedlo.so"
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-28 00:06 UTC by arjmage
Modified: 2015-02-21 11:10 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description arjmage 2013-10-28 00:06:28 UTC
This bug is similar to #70703. I find that Libreoffice crashes suddenly while editing a document in Writer. It is not a very large document (~30 pages) but includes tracked changes from a few authors. I have the feeling that the crashes occur when the cursor switches from a "recorded change" section to a free editing part of the document, but this is not always reproducible.

As noted further down in #70703, the crash has nothing to do with the content of the file (mySQL or just text in my case). The crash seems to register a segfault in soffice.bin with a message similar to:

soffice.bin[12507]: segfault at 40 ip b68372ee sp bf9cfa10 error 4 in libmergedlo.so[b40a8000+3566000]

This frequent crashing causes loss of data/work and is a real deal-breaker for productivity. I hope this can be resolved upstream sooner rather than later.

The specs of my system:
Ubuntu 12.04, kernel 3.5.0-42, Libreoffice PPA 4.1.1.2
Comment 1 arjmage 2013-10-28 00:08:21 UTC
I forgot to note above: the bug occurs both when the option use Java runtime environment is selected and deselected in the options.
Comment 2 Jean-Baptiste Faure 2013-10-28 12:03:50 UTC
You should try with the build provided by LibreOffice website which, AFAIK, does not use the build option that produces the libmerged.so library.

Best regards. JBF
Comment 3 arjmage 2013-10-28 22:24:23 UTC
Which build on the website do you mean? I use the official PPA to get the latest 'stable' builds, and I assume a frequent bug such as this cannot be the normal operation of things.

Since placing the bug report, I have tried to toggle the "Use Java Runtime environment" option on and off and this seems to now not cause frequent crashes in Writer. I still had it once or twice, but not nearly as often as before.
Comment 4 Björn Michaelsen 2013-10-28 22:52:46 UTC
(In reply to comment #2)
> You should try with the build provided by LibreOffice website which, AFAIK,
> does not use the build option that produces the libmerged.so library.

Please dont tell people to evade bugs instead of triaging. That said, helping people evade bugs in addition is fine, of course (although ask.libreoffice.org is a better place for that.

(In reply to comment #3)
> ...
Please provide the exact and full package version of libreoffice-core you are using and the exact Ubuntu version you are using. And please refrain from assumptions on "frequent bugs" -- they are usually misled.
Comment 5 Björn Michaelsen 2013-10-28 23:04:21 UTC
Also please create a stacktrace:
 https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace
Comment 6 arjmage 2013-10-29 00:52:10 UTC
Thanks for the info Björn. I didn't mean "frequent bug", but I meant frequent crashes. My error, sorry.

I am currently enjoying a stable Writer. I will try to reproduce the problem with backtrace.
Comment 7 Jean-Baptiste Faure 2013-10-29 05:18:15 UTC
(In reply to comment #4)
> (In reply to comment #2)
> > You should try with the build provided by LibreOffice website which, AFAIK,
> > does not use the build option that produces the libmerged.so library.
> 
> Please dont tell people to evade bugs instead of triaging. 

I should have been more explicit in my suggestion. My purpose was only to try to determine if the crash comes from upstream or only from the build options chosen by the PPA.

Best regards. JBF
Comment 8 Joel Madero 2014-06-18 20:05:50 UTC
@arjmage - any update on your side about this one? Still having a crash?
Comment 9 arjmage 2014-06-20 00:36:58 UTC
(In reply to comment #8)
> @arjmage - any update on your side about this one? Still having a crash?

I'm afraid so Joel, although I have lately been using Libreofice Impress more than writer. I'm almost sure that I know how to reproduce the crash on my computer. If I choose "Insert image" and then add an image file to a slide, and then I choose "Insert image" again, then Libreoffice crashes jsut when the file chooser dialog comes up.

I'm not sure if this is connected, but is a certain way to crash it on my computer, which runs debian and kde.
Comment 10 Joel Madero 2014-06-20 01:34:10 UTC
Can we get a test document then? Without one - or very clear reproducible steps from a blank document - we'll have to close this as INVALID.

That being said - you could do a find and replace for all letters so to hide confidential info.
Comment 11 Joel Madero 2014-06-20 21:01:46 UTC
NEEDINFO - once document is attached please put the bug in UNCONFIRMED.
Comment 12 arjmage 2014-06-30 12:20:30 UTC
Hi Joel,

Sorry for the delay, I was away. So I have tried to narrow down the minimum number of steps to get a segfault from libreoffice.

1. Start Writer/Impress/Calc
2. Try to save file (ctrl+s)
3. In the file save dialog that opens, click on the up-one-level button to go to parent directory.
4. Move moue back into dialog for selecting folder
5. Segfaults with errors alternately (on repeated trials of steps above) in libkio.so and libQtGui:

[153242.048023] soffice.bin[6961]: segfault at 740083 ip 00007f5a983876f9 sp 00007ffff02ee9c0 error 4 in libkio.so.5.12.4[7f5a9823e000+29f000]
Jun 30 14:12:07 hyperpod kernel: [153332.326511] soffice.bin[7066]: segfault at 118 ip 00007f51804ee690 sp 00007fffdcbf4ef8 error 4 in libQtGui.so.4.8.6[7f5180188000+a5e000]
Jun 30 14:12:59 hyperpod kernel: [153383.621268] soffice.bin[7123]: segfault at 540068 ip 00007f3117cff6f9 sp 00007fff58c7de90 error 4 in libkio.so.5.12.4[7f3117bb6000+29f000]
Jun 30 14:13:37 hyperpod kernel: [153421.803694] soffice.bin[7166]: segfault at 118 ip 00007fae8d7c7690 sp 00007fffd204deb8 error 4 in libQtGui.so.4.8.6[7fae8d461000+a5e000]

The behavior is the same as before, although now I am using libreoffice on a debian system with kernel 3.14-1-amd64 and KDE version:

kde4-config --version
Qt: 4.8.6
KDE Development Platform: 4.12.4
kde4-config: 1.0

Does this help Joel?
Comment 13 Joel Madero 2014-07-01 01:52:13 UTC
One more question - have you tried with LibreOffice 4.2.5?
Comment 14 arjmage 2014-07-01 09:31:03 UTC
No, I'm using Libreoffice 4.1.5.3 from the debian repos.
Comment 15 arjmage 2014-07-01 09:33:10 UTC
Strangely, I can't reproduce the segfault crash now, although yesterday it happened consistently.
Comment 16 QA Administrators 2015-02-19 04:42:00 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team

Message generated on: 2015-02-18
Comment 17 Jean-Baptiste Faure 2015-02-21 11:10:42 UTC
Closing as WorksForMe due to comment #15.
Please, feel free to reopen if the same crash comes back.

Best regards. JBF