Bug 70970 - Links to cell in separate spreadsheet break on save with doubled PATH to file - only OSX only xls format
Summary: Links to cell in separate spreadsheet break on save with doubled PATH to file...
Status: RESOLVED DUPLICATE of bug 48463
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-28 21:35 UTC by Brian McKee
Modified: 2014-04-08 19:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian McKee 2013-10-28 21:35:59 UTC
Cell references are broken on save in xls format


New Spreadsheet
Put just 'Hi Mom' in A1
Save in home folder as file.ods

New Spreadsheet
Type in A1  
='file:///Users/me/file.ods'#$Sheet1.A1
Replace {me} with your actual user name.
Works as expected up to this point

Save as file2.xls

Close file2.xls, reopen, say yes to update links, and voila... busted
cell A1 now shows a doubled up path.
='file:///Users/me/Users/me/file.ods'#$Sheet1.A1


Note that if you save file2 as .ods it works fine
Note also if you do this using LO 4.1 on Windows it works fine

Pretty sure bug exists in multiple versions of LO as it was about a year ago I first noticed without pinning down exactly what's happening...
Comment 1 m.a.riosv 2014-04-07 22:18:39 UTC
Hi Brian, seems a duplicate of:
https://bugs.freedesktop.org/show_bug.cgi?id=48463
Comment 2 Brian McKee 2014-04-08 13:40:03 UTC
How can this be "Not A Bug" when it worked before, and doesn't now?

Where is this "clearly explained"?


On 04/07/14 6:18 PM, bugzilla-daemon@freedesktop.org wrote:
> m.a.riosv <mailto:mariosv@miguelangel.mobi> changed bug 70970 
> <https://bugs.freedesktop.org/show_bug.cgi?id=70970>
> What 	Removed 	Added
> CC 		mariosv@miguelangel.mobi
>
> *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=70970#c1> 
> on bug 70970 <https://bugs.freedesktop.org/show_bug.cgi?id=70970> from 
> m.a.riosv <mailto:mariosv@miguelangel.mobi> *
> Hi Brian, seems a duplicate of:
> https://bugs.freedesktop.org/show_bug.cgi?id=48463  <show_bug.cgi?id=48463>
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You are on the CC list for the bug.
>   * You reported the bug.
>
Comment 3 m.a.riosv 2014-04-08 16:24:18 UTC
Hi Brian, first please if you can comment here in the bugzilla, and if you reply from your email, please don't reproduce the email except something relevant is needed for the answer.

As this is a duplicate, please answer in the duplicated bug not here, several with the same issue doesn't help too much.

And please read the comment #17+#18 from Kohei, https://bugs.freedesktop.org/show_bug.cgi?id=48463#c17, seems that "Technically this is a platform-dependent limitation, not a regression"

*** This bug has been marked as a duplicate of bug 48463 ***
Comment 4 m.a.riosv 2014-04-08 19:58:55 UTC
As workaround you can put the path in a cell and use the INDIRECT() function (or put directly as text in the function) to compose the address properly, in this way nothing is changed when saving the file.

e.g.

B10: ="'file:///Users/me/Users/me/file.ods'#Sheet1."
c10: =INDIRECT(B10&cell("address";A1))