Bug Hunting Session
Bug 70987 - PRESENTATION: main screen not shown. Cairo compiled with enable-xlib-xcb
Summary: PRESENTATION: main screen not shown. Cairo compiled with enable-xlib-xcb
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-29 08:57 UTC by Fabio Coatti
Modified: 2016-01-24 08:44 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabio Coatti 2013-10-29 08:57:49 UTC
I'm trying use libreoffice to view a presentation (odp) but hitting F5 causes openoffice to show only the speaker screen while the main screen is freezed (on a dual monitor setup). On a single monitor setup the result is similar: screen freezed with previous windows shown, but clicking on that windows lead to no result, as it is only leftover images on screen and not actual live application windows. Hitting ESC leads to the expected behaviour: screen unfreezes and all start to work again, like it happens when the presentation is closed.
Basically it seems that libreoffice starts the presentation but is unable to draw the main screen that keeps showing the previous content, freezed. speaker works just fine and all buttons are working, even "switch screen" one.

Happens with 4.1.2.3 and 4.1.2.2 (built from sources/gentoo)

Linux 3.11.6 X86_64
kde 4.11.2
qt 4.8.5
gcc 4.8.2
Comment 1 Fabio Coatti 2013-11-02 18:19:24 UTC
Possibly related to https://bugs.freedesktop.org/show_bug.cgi?id=49165
(version of installed software are quite different, tough).

cairo: 1.12.16

Still present in libreoffice 4.1.3.2
Comment 2 ign_christian 2014-07-04 05:36:43 UTC
Hi Fabio. Is it still reproduce in LO 4.2.5.2 ?

If problem solved please change status to RESOLVED WORKSFORME, else UNCONFIRMED & additional info if any.
Comment 3 Fabio Coatti 2014-07-04 07:18:31 UTC
Same behaviour also in 4.2.5.2; No additional info unfortunetely.
Some updates to gcc and kernel, but nothing really relevant.
Comment 4 tommy27 2014-11-16 06:46:48 UTC
4.3.4.1 release is out. please give it a try and give feedback
Comment 5 Buovjaga 2014-11-16 14:10:49 UTC
Yep, if it happens with any presentation, all we can do is wait for someone to come forward with similar experiences. Could you try with a live USB of some other distro that comes with LibO 4.3.x?

Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 6 Fabio Coatti 2014-11-18 12:58:41 UTC
Just compiled 4.3.4.1, same problem, same workaround: disable hardware accel.

I'll try with some live distro, do you have a suggestion on which one to try?

libs&versions:

cairo 1.12.16-r3
qt 4.8.5
gcc (Gentoo 4.8.3 p1.1, pie-0.5.9) 4.8.3
kde 4.14.3
Comment 7 Buovjaga 2014-11-19 06:27:26 UTC
(In reply to Fabio Coatti from comment #6)
> I'll try with some live distro, do you have a suggestion on which one to try?

Ubuntu 14.10 comes with LibO 4.3: http://releases.ubuntu.com/14.10/
Comment 8 Fabio Coatti 2014-11-22 11:36:53 UTC
Just tried with ubuntu 14.10 (live) and the problem is not present. Considering that, looking at the bug history and related bugs, the problem seems related to cairo, i checked ubuntu cairo version, and it uses 13.0, my installation (gentoo) uses 1.12.16. The original problem should have been fixed also in 1.12, however I tried to install 1.13, only to discover that this version is not available (tagged) upstream. I then installed 1.14.0 from source, but the problem is still present.

This bug puzzles me a lot, because the behaviour is exactly as described earlier (cairo changes), but it seems that fixes are in also in version that I'm using..and the bug is present.

Any suggestion about to have a deeper look into this?
(tracing, whatever?)

Many thanks.
Comment 9 Robinson Tryon (qubit) 2015-02-08 13:12:08 UTC
(In reply to Fabio Coatti from comment #8)
> Just tried with ubuntu 14.10 (live) and the problem is not present.
> Considering that, looking at the bug history and related bugs, the problem
> seems related to cairo, i checked ubuntu cairo version, and it uses 13.0, my
> installation (gentoo) uses 1.12.16. The original problem should have been
> fixed also in 1.12, however I tried to install 1.13, only to discover that
> this version is not available (tagged) upstream. I then installed 1.14.0
> from source, but the problem is still present.

Hi Fabio,
Just checking in on this bug report. Can you still reproduce it with the latest cairo in gentoo?

Status -> NEEDINFO

> This bug puzzles me a lot, because the behaviour is exactly as described
> earlier (cairo changes), but it seems that fixes are in also in version that
> I'm using..and the bug is present.
> 
> Any suggestion about to have a deeper look into this?
> (tracing, whatever?)

Have you ever used bibisect? It would be helpful to know how long this problem has existed in the codebase (or if it's purely a problem with cairo).
Comment 10 Fabio Coatti 2015-02-08 17:36:03 UTC
Hi Robinson, just tried with this setup:

app-office/libreoffice-4.3.5.2
x11-libs/cairo-1.14.0 

No changes, behaviour is the same.

If you want, I can try again with 1.12.18 from portage (1.14.0 is from overlay).

Never used bibisect, I will give it a try.

Keep in mind that I done my tries on sources packages compiled on the machine, non on binary packages.

However, I will see what happens with bibisect
Comment 11 Buovjaga 2015-02-09 06:06:35 UTC
(In reply to Fabio Coatti from comment #10)
> Never used bibisect, I will give it a try.
> 
> Keep in mind that I done my tries on sources packages compiled on the
> machine, non on binary packages.
> 
> However, I will see what happens with bibisect

https://wiki.documentfoundation.org/QA/HowToBibisect

You can get help on the QA IRC channel:
http://webchat.freenode.net/?channels=libreoffice-qa
Comment 12 Robinson Tryon (qubit) 2015-02-09 15:01:03 UTC
(In reply to Fabio Coatti from comment #10)
> 
> Keep in mind that I done my tries on sources packages compiled on the
> machine, non on binary packages.

Hmm, so as you're building from source, your best bet might be the Dev list:
https://wiki.documentfoundation.org/Development/Mailing_List

It seems possible that current LO might not work with a particular version of Cairo (e.g. 1.12), however our build baseline is a pretty old version of RHEL/Fedora/CentOS/etc.., so I'd imagine that the problem wouldn't necessarily lie with needing a modern Cairo.
Comment 13 tommy27 2015-05-24 15:57:53 UTC
@Fabio Coatti  
any news about the bug status with latest 4.3.7 or 4.4.3 releases?
Comment 14 Fabio Coatti 2015-05-25 07:47:24 UTC
(In reply to tommy27 from comment #13)
> @Fabio Coatti  
> any news about the bug status with latest 4.3.7 or 4.4.3 releases?

Same behaviour, 4.4.3.2 , cairo 1.14.2

I will try to look better at the issue in next weeks if I find the time, however the behaviour has been pretty consistent for several versions.
Comment 15 tommy27 2015-08-12 12:47:37 UTC
LibO 5.0.0.5 is out.
please retest and tell if something changed or not.
Comment 16 Fabio Coatti 2015-08-22 08:37:00 UTC
Will do that, however it seems that the problem lies in cairo compilation options.

In gentoo there is the option to compile cairo with xlib-xcb use flag (Use XCB renderer backend for acceleration over xlib) and I activated it for some reason thatI can't recall right now. With this flag turned on, libreoffice shows the bug reported here (and, btw, this breaks virtmanager also). Turning off this flag, as is standard for other distros, the bug disappear.

I don't know if this is an issue completely on cairo side or some wrong interaction with libreoffice, however compiling cairo without --enable-xlib-xcb solves this issue.

I have no information about lo 5.0.0.5 about this behaviour yet.
Comment 17 Jean-Baptiste Faure 2016-01-24 08:44:55 UTC
As this issue is only reproducible with only the Gentoo Linux distribution and using a non default compilation flag for Cairo, I think we can close this bug report as NotOurBug.
Feel free to reopen if you disagree. If so please explain what could be done on the LibreOffice side to fix that.

Best regards. JBF