Bug 71097 - FILESAVE: export to Excel 2003 XML crash on Mac OSX 10.9
Summary: FILESAVE: export to Excel 2003 XML crash on Mac OSX 10.9
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: highest major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-31 16:24 UTC by peter
Modified: 2015-06-25 14:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
TestSheet3.ods: an apparently empty sheet that causes the crash (7.90 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-10-31 17:00 UTC, peter
Details
console logs (7.16 KB, text/plain)
2013-11-01 09:37 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description peter 2013-10-31 16:24:40 UTC
Recently upgraded to Mac OSX Mavericks, and now saving spreadsheet from LO in Excel 2003 XML format crashes (application quit unexpectedly).

It doesn't happen with an empty sheet.

The traceback from the crashed thread looks like this:

Thread 12 Crashed:
0   libsystem_malloc.dylib     0x90512f6b tiny_malloc_from_free_list + 1246
1   libsystem_malloc.dylib     0x905130c8 szone_malloc_should_clear + 283
2   libsystem_malloc.dylib     0x90508b6a szone_malloc + 24
3   libsystem_malloc.dylib     0x9051555b malloc_zone_malloc + 75
4   libsystem_malloc.dylib     0x90515f44 malloc + 52
5   libxml2.2.dylib            0x9a3a803c xmlXPathNodeSetCreate + 30
6   libxml2.2.dylib            0x9a3accd3 xmlXPathCacheNewNodeSet + 154
7   libxml2.2.dylib            0x9a3b05a4 xmlXPathRunStreamEval + 121
8   libxml2.2.dylib            0x9a3afdaf xmlXPathRunEval + 210
9   libxml2.2.dylib            0x9a3afb3b xmlXPathCompiledEvalInternal + 417
10  libxml2.2.dylib            0x9a3af992 xmlXPathCompiledEval + 38
11  libxslt.1.dylib            0x9b28f191 xsltCopyOf + 214
12  libxslt.1.dylib            0x9b28ca9d xsltApplySequenceConstructor + 1129
13  libxslt.1.dylib            0x9b29050a xsltChoose + 846
14  libxslt.1.dylib            0x9b28ca9d xsltApplySequenceConstructor + 1129
15  libxslt.1.dylib            0x9b28c350 xsltApplyXSLTTemplate + 1336

... lots of repeats of the following calls ...

507 libxslt.1.dylib            0x9b28ca9d xsltApplySequenceConstructor + 1129
508 libxslt.1.dylib            0x9b29050a xsltChoose + 846
509 libxslt.1.dylib            0x9b28ca9d xsltApplySequenceConstructor + 1129
510 libxslt.1.dylib            0x9b28c350 xsltApplyXSLTTemplate + 1336
511 libxslt.1.dylib            0x9b28f933 xsltCallTemplate + 426

Something seems to be getting it into an infinite recursive loop. I haven't got a minimal test case yet.
Comment 1 peter 2013-10-31 17:00:12 UTC
Created attachment 88417 [details]
TestSheet3.ods: an apparently empty sheet that causes the crash

This .ods file was obtained by deleting all content and borders from the sheet that caused a crash when saving as Excel 2003 XML format.

Saving this sheet still crashes, saving a brand new spreadsheet from File > New does not.
Comment 2 retired 2013-11-01 00:48:13 UTC
Can confirm a crash on OS X 10.9, LO 4.1.3.2.

Setting to NEW.
Comment 3 Julien Nabet 2013-11-01 09:37:46 UTC
Created attachment 88465 [details]
console logs

On pc Debian x86-64 with master sources updated yesterday, I don't reproduce the crash but had a popup showing Write error.
I attached console logs.
Comment 4 retired 2014-05-04 13:08:04 UTC
Still crashing in 4.2.3.3 and latest nightly Version: 4.3.0.0.alpha1+
Build ID: f76026a43acc65465882924796d93e635c35fd90
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2014-05-04_06:32:55

in OSX 10.9.2
Comment 5 QA Administrators 2015-06-08 14:41:41 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.3 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results;
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-06-08
Comment 6 Robinson Tryon (qubit) 2015-06-25 14:20:39 UTC
(In reply to peter from comment #1)
> Created attachment 88417 [details]
> TestSheet3.ods: an apparently empty sheet that causes the crash
> 
> This .ods file was obtained by deleting all content and borders from the
> sheet that caused a crash when saving as Excel 2003 XML format.
> 
> Saving this sheet still crashes, saving a brand new spreadsheet from File >
> New does not.

NO REPRO with Version: 4.5.0.0.alpha0+ on OSX 10.9.5
Build ID: 4d3b725000e537ce6199f0abd1c80580c9bf95c8
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2015-01-02_10:08:47
Locale: en_

Document saves fine; no crash detected.

Status -> RESOLVED WORKSFORME

(feel free to reopen this bug if a modern build is experiencing the same crash)