Bug 71158 - Writer Search+Replace cannot find and replace strings spanning multiple paragraphs
Summary: Writer Search+Replace cannot find and replace strings spanning multiple parag...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-02 05:28 UTC by Leo H
Modified: 2013-11-02 08:25 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leo H 2013-11-02 05:28:53 UTC
LibreOffice Package: libreoffice 1:4.1.2~rc3-0ubuntu1
Libre Office Version: 4.1.2.3
Build ID: 410m0(Build:3)
System: Xubuntu 13.10, 32 bit, fully patched
--

LibreOffice Writer Search and Search+Replace:

1/ Cannot locate the pilcrow sign (¶, U+00B6, also used in LibreOffice as the end-of-paragraph marker), neither within a paragraph nor at the end of a paragraph.

2/ Cannot find and replace continuous strings that span over multiple paragraphs.

These are serious deficiencies, especially when editing long documents.


Note: As to the pilcrow sign, it is a standard Unicode character, and it has been in Unicode since 1.1. It can be (and has long been) legitimately used for any number of good reasons in text documents other than merely acting as the LibreOffice end-of-paragraph marker.

There can be no reason why it is excluded from LibreOffice Search and Search+Replace.

Note: Issue 2/ might well be a direct consequence of issue 1/. If so, then making the pilcrow sign findable and replaceable may perhaps also address and resolve issue 2/. If not, then issue 2/ must be filed separately in the LibreOffice Bugzilla.
Comment 1 Leo H 2013-11-02 06:02:43 UTC
I have been very sloppy indeed, apologies for that. LibreOffice Search and Search+Replace can, of course, find the pilcrow sign within paragraphs, but – and that is the usability issue here – not where used as an end-of-paragraph marker. Thus, in effect only issue 2/ remains.

Once more apologies for my mistake.
Comment 2 Jean-Baptiste Faure 2013-11-02 08:25:40 UTC
There is no end-of-paragraph character in OpenDocument files in which paragraphs are defined by xml tags.
To find/remplace end-of-paragraph marks you need to use regular expressions in the search/replace dialog. Please read the help and, if needed, ask for help on users mailing-list or on http://ask.libreoffice.org

Closing as NotABug.

Best regards. JBF