Bug 71289 - External dependencies fail to build due to outdated libtool version
Summary: External dependencies fail to build due to outdated libtool version
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other FreeBSD
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-06 05:42 UTC by Brennan Vincent
Modified: 2014-11-20 06:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brennan Vincent 2013-11-06 05:42:11 UTC
Some external packages (for example, lcms2) come bundled with libtool version 2.4 (in the form of ltmain.sh). However, libtool 2.4 does not work in FreeBSD 10.0, as you can see from this thread: http://lists.gnu.org/archive/html/libtool-patches/2011-01/msg00035.html (issue is that rules written for FreeBSD 1 (!!!) are being run in FreeBSD 10.0).

This causes .so files not to be built in the external packages, and the build to fail.

The tarballs would need to be bundled with at least libtool 2.4.2, which fixes this bug.
Comment 1 Joel Madero 2014-11-20 06:12:56 UTC
As far as I can tell....we don't bundle libtool. This could be wrong but for now I'm closing it as NOTOURBUG - users just have to build libtool themselves.

Apologies if I'm incorrect, I'm not a developer, so if you still see this issue with latest version 4.3.+ set the bug back to UNCONFIRMED and I'll get a second opinion from a developer if you think we do in fact package it. Thanks!