Bug 71586 - CONFIGURATION: "sdk.bin.dir"
Summary: CONFIGURATION: "sdk.bin.dir"
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: sdk (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2013-11-13 20:44 UTC by olithim
Modified: 2015-12-15 10:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description olithim 2013-11-13 20:44:17 UTC
Problem description: 
The wrong definition of property "sdk.bin.dir" prevents some modules compilation's (LibO Addon in Netbeans)

Current behavior:
"sdk.bin.dir" is defined as "${oo.sdk.home}${file.separator}${sdk.os.dir}${file.separator}bin"

Expected behavior:
"sdk.bin.dir" should be defined as "${oo.sdk.home}${file.separator}bin"

              
Operating System: All
Version: 4.1.3.2 release
Last worked in: 3.5 all versions
Comment 1 Stephan Bergmann 2013-11-14 11:16:49 UTC
What "LibO Addon in Netbeans" (obtained from where?) is this about?
Comment 2 olithim 2013-11-14 12:08:26 UTC
(In reply to comment #1)
> What "LibO Addon in Netbeans" (obtained from where?) is this about?

https://wiki.openoffice.org/wiki/OpenOffice_NetBeans_Integration
The property named "sdk.bin.dir" is used in the file "build-uno-impl.xml", automatically generated by "org-openoffice-extensions.jar"

The probleme came after upgrading from LibO 3.4 (ubuntu) and LibO 3.5 (win7).
Because I couldn't find the definition of this property, I supposed it was in LibO.
Comment 3 Stephan Bergmann 2013-11-14 12:34:59 UTC
...so we unfortunately can't do much to improve the interoperability between that AOO-specific tool and LO.
Comment 4 Robinson Tryon (qubit) 2015-12-15 10:53:47 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]