Bug 71599 - FORMATTING: Table inserted from Libre Office Calc is changes alignment
Summary: FORMATTING: Table inserted from Libre Office Calc is changes alignment
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2013-11-14 10:19 UTC by felixw83
Modified: 2015-12-15 10:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test table (32.70 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-11-14 10:19 UTC, felixw83
Details

Note You need to log in before you can comment on or make changes to this bug.
Description felixw83 2013-11-14 10:19:20 UTC
Created attachment 89179 [details]
test table

Problem description: 

I have some tables that are formatted in different ways (some columns have right alignment, some have left alignment), containing numbers and text as well. In 3.6 these tables look exactly the same after copying them to a writer document (ctlr+c; ctrl+v). In 4.1 however the inserted object in writer changes the text-alignment of some columns.

Steps to reproduce:
1. open the attached table document
2. mark the table (A44:A80)
3. insert it into a new writer document

Current behavior:
- the table in writer should look the same

Expected behavior:
- the table in writer looks different.
              
Operating System: Windows XP
Version: 4.1.3.2 release
Last worked in: 3.6.7.2 release
Comment 1 Dominique Boutry 2013-11-19 13:24:35 UTC
Hi

I'm surprised, I can see only left alignments in the table/range you provide. Its copy on Writer shows the same layout. Should I introduce myself some right alignments in the range, its copy on Writer shows again the correct layout.

LibO 4.1.2.3 on Win7
Comment 2 Dominique Boutry 2013-11-19 13:52:53 UTC
Additional finding :
- with Ctrl-C/Ctrl-V, the copy in Writer is a picture, not a table ; moreover, if I copy A44-B80 to include numbers, the resulting picture is not the image of the calc display, it shows modification in numeric cells, for example B26 changed from 0,026 to 26 (misinterpretation of language dependant "," in numbers, between german and english ?), with its alignment changed from left to right (= the initial bug report).

Now this raises the question : this copy wasn't supposed to paste into a Writer table, not a picture ? I think yes. Word do so. It's rather useful for some processing.
Comment 3 sophie 2013-11-29 13:44:30 UTC
Hi, confirmed under Ubuntu 13.10 when selecting A44:E80 seems the formatting of some cells is lost after pasted using Ctrl+C/Ctrl+V, the OLE object shows some cells in text format while they are in Number format under Calc.
 
@Felixw83, if you do not need absolutely an OLE object, you can chose another format by pasting using Ctrl+Maj+V keys.
Marked as New - changed Plateform - Sophie
Comment 4 QA Administrators 2015-04-19 03:20:04 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 5 Buovjaga 2015-06-15 10:02:46 UTC
No difference observed.
B52 stayed as Number format in Writer as well.

Please advise more specifically, if there are still problems.

I will close this as WFM for now.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 01a189abcd9a4ca472a74b3b2c000c9338fc2c91
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-14_07:46:28
Locale: fi-FI (fi_FI)
Comment 6 Robinson Tryon (qubit) 2015-12-15 10:53:30 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]