Bug 71635 - Menubar incorrect text colour.
Summary: Menubar incorrect text colour.
Status: RESOLVED DUPLICATE of bug 68546
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-15 10:18 UTC by Paul
Modified: 2013-11-22 16:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
LibreOffice Menubar showing incorrect text colour. (17.23 KB, image/png)
2013-11-15 10:18 UTC, Paul
Details
LibreOffice Menubar showing incorrect text colour. (17.23 KB, image/png)
2013-11-15 10:24 UTC, Paul
Details
New screenshot - theme plus white text (39.06 KB, image/png)
2013-11-17 11:00 UTC, Paul
Details
header image (3.75 KB, image/png)
2013-11-17 11:01 UTC, Paul
Details
footer image (870 bytes, image/png)
2013-11-17 11:02 UTC, Paul
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul 2013-11-15 10:18:48 UTC
Created attachment 89257 [details]
LibreOffice Menubar showing incorrect text colour.

After updating from LibreOffice 4.0-5 to 4.1.3.2 the Menubar text colour is incorrect. Dropdown menus are correct.

As shown in the attached image.

Possibly distribution specific? 


openSUSE 12.3 x86_64 (Kernel Release 3.7.10-1.16-desktop)
Comment 1 Paul 2013-11-15 10:24:24 UTC
Created attachment 89258 [details]
LibreOffice Menubar showing incorrect text colour.

Sorry - bugzilla seems to think first attachment was text/plain.
Comment 2 Ivan Timofeev (retired) 2013-11-15 12:53:49 UTC
Thanks for the report!

Isamu, "git log" shows that the last commits in that area are yours, could you please take a look at this bug?
Comment 3 Paul 2013-11-16 17:38:47 UTC
Additional info that may help...

I have found that by toggling either (Options|LibreOffice|View), "Use system font for user interface", or "Screen font anti-aliasing", restores the Menubar text to it's correct colour -but- only until LibreOffice is closed.

Upon restarting LO the text is again white -irrespective of- the above settings.

I've also tried other (KDE) themes and colours - always white text on the Menubar. :)
Comment 4 Paul 2013-11-16 19:44:07 UTC
It's related to the use of the Personalisation feature using Firefox themes.

Using this theme:
https://addons.mozilla.org/en-US/firefox/addon/matching-green-for-libreoff/

causes the Menubar text to change to white.

Using this theme:
https://addons.mozilla.org/en-US/firefox/addon/soft-aqua/

the Menubar text respects the (KDE) global setting and is unchanged.

Apply theme - close and re-open LO to see the effect.
Comment 5 Ivan Timofeev (retired) 2013-11-17 05:50:34 UTC
(In reply to comment #4)
> It's related to the use of the Personalisation feature using Firefox themes.
> 
> Using this theme:
> https://addons.mozilla.org/en-US/firefox/addon/matching-green-for-libreoff/
> 
> causes the Menubar text to change to white.

But there was no theme applied on your screenshot. How the color was white then?
Comment 6 Paul 2013-11-17 11:00:00 UTC
Created attachment 89348 [details]
New screenshot - theme plus white text

It has a grey background that's why it's not apparent in the screenshot.

Attached new screenshot, and the theme images.
Comment 7 Paul 2013-11-17 11:01:19 UTC
Created attachment 89349 [details]
header image
Comment 8 Paul 2013-11-17 11:02:09 UTC
Created attachment 89350 [details]
footer image
Comment 9 Ivan Timofeev (retired) 2013-11-17 12:55:55 UTC
(In reply to comment #6)
> It has a grey background that's why it's not apparent in the screenshot.

Ah, ok. Then, it's not a bug, the white color is from the theme.
Comment 10 Paul 2013-11-17 13:05:07 UTC
(In reply to comment #9)

> Ah, ok. Then, it's not a bug, the white color is from the theme.

How ??  Please explain.
Comment 11 Paul 2013-11-17 14:10:06 UTC
(In reply to comment #9)
 
> Ah, ok. Then, it's not a bug, the white color is from the theme.

My bad! I must apologise Ivan. 

The text and background colour are indeed controlled by the theme. As documented here: https://addons.mozilla.org/en-US/developers/docs/themes

After editing the "PersonaSettings" in registrymodifications.xcu I have restored the black text in the Menubar.

LO V4.0.x did not exhibit this behaviour which is why I assumed this was a bug.

Thanks for your time.
Comment 12 Paul 2013-11-17 14:11:46 UTC
Marking as RESOLVED NOTABUG
Comment 13 Adolfo Jayme 2013-11-17 14:45:53 UTC

*** This bug has been marked as a duplicate of bug 68546 ***