Download it now!
Bug 71700 - UI: user style created readonly
Summary: UI: user style created readonly
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-17 14:06 UTC by miksi
Modified: 2015-04-19 04:24 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description miksi 2013-11-17 14:06:23 UTC
Problem description:
a user style (F11) created with "user style" in the "Area" dropdown menu, will be read only. rightlick only shows "new" and "delete".

Steps to reproduce:
1. Press F11
2. in the F11 window, rightclick, select NEW
3. in the first tab ("Manage"), the third dropdown ("Area"), you can chosse between "All", "User" and "Hidden"; select "User".
4. Press OK
5. rightclick on your new style: only two menuitems: "New", "Delete"

Current behavior:
the new style can only be deleted according to context menu.

Expected behavior:
context menu for this new style should have the normal four items: "New", "Modify", "Hide", "Delete".
              
Operating System: Windows 7
Version: 4.1.3.2 release
Comment 1 sophie 2013-12-04 14:08:31 UTC
Confirmed using Version: 4.1.3.2
Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a and Ubuntu 13.10. Set as new and changed plateform to all. Sophie
Comment 2 QA Administrators 2015-04-19 03:20:28 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 3 miksi 2015-04-19 04:24:47 UTC
It works now in version 4.4.2.2. Good job.