Download it now!
Bug 72009 - VIEWING: some elements misplaced of a shrunk OLE Draw
Summary: VIEWING: some elements misplaced of a shrunk OLE Draw
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-25 22:04 UTC by Brett Wuth
Modified: 2015-08-02 11:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example Text document with embedded Draw document (34.02 KB, application/vnd.oasis.opendocument.text)
2013-11-25 22:04 UTC, Brett Wuth
Details
Example Draw document that triggers the bug (7.77 KB, application/vnd.oasis.opendocument.graphics)
2013-11-25 22:07 UTC, Brett Wuth
Details
Example of incorrect screen rendering (76.95 KB, image/png)
2013-11-25 22:07 UTC, Brett Wuth
Details
Examle of correct print rendering; should be what screen rendering looks like (23.27 KB, application/pdf)
2013-11-25 22:08 UTC, Brett Wuth
Details
Document with drawing resized (37.55 KB, application/vnd.oasis.opendocument.text)
2014-05-19 11:11 UTC, Jose Gómez
Details
Document with drawing resized exported to pdf (24.27 KB, application/pdf)
2014-05-19 11:12 UTC, Jose Gómez
Details
File Looking Good Resized (36.27 KB, application/vnd.oasis.opendocument.text)
2014-05-20 15:06 UTC, Joel Madero
Details
Screenshot of 3.5.4.2 incorrect rendering of File Looking Good Resized (67.42 KB, image/png)
2014-05-26 00:26 UTC, Brett Wuth
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brett Wuth 2013-11-25 22:04:55 UTC
Created attachment 89790 [details]
Example Text document with embedded Draw document

Problem description: 

Embedding a Draw document in a Text Document as an OLE object, and then reducing the scale on the OLE object causes some but not all elements of the Draw document to be misplaced when displayed on the screen.  Printing and exporting to PDF work correctly.


Steps to reproduce:
1. Create a Draw document containing boxed text and connecting lines
2. Insert the Draw document in an Text Document: menu:Insert>Object>OLE Object
3. reduce the scale of the object

Current behavior:
* Some elements (lines and open boxes) appear not to be scaled, while other elements (filled boxes, text) are scaled.  As a result elements are misplaced relative to each other.

Expected behavior:
* The embedded Draw document should appear properly scaled with all elements in their correct relative position.

Tested with
* LibreOffice 4.1.3 for MS-Windows -- bug found
* LibreOffice 3.5.4.2 for Debian Linux 7.0 -- bug found
* OpenOffice 4.0.1 for MS-Windows -- bug not found
Operating System: All
Version: 3.5 all versions
Comment 1 Brett Wuth 2013-11-25 22:07:03 UTC
Created attachment 89791 [details]
Example Draw document that triggers the bug
Comment 2 Brett Wuth 2013-11-25 22:07:57 UTC
Created attachment 89792 [details]
Example of incorrect screen rendering
Comment 3 Brett Wuth 2013-11-25 22:08:54 UTC
Created attachment 89793 [details]
Examle of correct print rendering; should be what screen rendering looks like
Comment 4 Jose Gómez 2014-05-19 11:11:38 UTC
Created attachment 99320 [details]
Document with drawing resized
Comment 5 Jose Gómez 2014-05-19 11:12:17 UTC
Created attachment 99322 [details]
Document with drawing resized exported to pdf
Comment 6 Jose Gómez 2014-05-19 11:12:51 UTC
I can confirm the issue with LibreOffice 4.2.4.2.

Note that the resized diagrams do not appear correctly when the export to pdf option is used.
Comment 7 Joel Madero 2014-05-20 15:03:38 UTC
Updating version - our version field is the oldest version we see the problem, not the last version. We just put comments for that
Comment 8 Joel Madero 2014-05-20 15:06:01 UTC
How did you resize - I just did it two ways and the file came out fine. 

Steps:

1. Downloaded your file "Example Text document with embedded Draw document"
2. Grabbed the corner and resized down
3. Undid the resize
4. Right clicked and went into ole properties
5. Set scale to 50%/45% for height and width

Both show fine - attaching document to show
Comment 9 Joel Madero 2014-05-20 15:06:22 UTC
Created attachment 99422 [details]
File Looking Good Resized
Comment 10 Brett Wuth 2014-05-26 00:26:25 UTC
Created attachment 99815 [details]
Screenshot of 3.5.4.2 incorrect rendering of File Looking Good Resized

(In reply to comment #9)
> Created attachment 99422 [details]
> File Looking Good Resized

The file you provided (99422:File Looking Good Resized) doesn't render
correctly to the screen with LibreOffice 3.5.4.2 on Debian Linux 7.0.
See the attached screenshot.  Note for example how the
orange/yellow/blue/gray filled boxes are place higher than the lines
that connect to them, thus making them disconnected from the
non-filled boxes below them.

Does this file render correctly in your version of LibreOffice?  If so,
which version of LibreOffice are you using and on what platform?

P.S.: file  89790: "Example Text document with embedded Draw document"
is also an example document with incorrect rendering.  The resizing is
just not as dramatic as your example.  The incorrect rendering can be
seen when comparing  89792: "Example of incorrect screen rendering" with
 89793: "Examle of correct print rendering"
Comment 11 Brett Wuth 2014-05-26 00:28:19 UTC
Marked as confirmed, per comment 6.
Comment 12 QA Administrators 2015-06-08 14:43:06 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.3 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results;
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-06-08
Comment 13 Buovjaga 2015-08-02 11:37:28 UTC
Now it works ok. Embedded it, scaled down, saved & reloaded and compared with Draw document. WFM.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 902255645328efde34ddf62227c8278e8dd61ff0
TinderBox: Win-x86@39, Branch:master, Time: 2015-07-30_03:52:07
Locale: en-US (fi_FI)