Bug Hunting Session
Bug 72047 - Cross-References do not update in Writer
Summary: Cross-References do not update in Writer
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-26 19:14 UTC by publicface
Modified: 2015-12-27 02:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample demonstrating bug. Includes answers to questions asked. (10.50 KB, application/msword)
2013-11-27 00:43 UTC, publicface
Details
Sample file to test (10.50 KB, application/xml)
2014-06-01 23:34 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description publicface 2013-11-26 19:14:29 UTC
Version: 4.1.3.2
Build ID: 410m0(Build:2)
KUbuntu 12.04


After setting a cross reference, then inserting a reference to that set reference, it doesn't update the reference with the value in the cross reference field.

For clarity, lets call the set reference a "setpoint".  I create the setpoint, which is a field.  I insert a reference to it elsewhere in my document - lets call it the "reference point".  The reference point does not get updated with the setpoint field value.


To recreate:
1) 

Graphically:

setpoint[field value X]


reference point [<should get field value X, but is blank>] 


This mostly worked in 3.5, just not perfectly but better than now.

If needed, to fix this... I would be happy to provide an account on my machine to examine this problem and/or share my desktop through a VNC viewer.
Comment 1 m.a.riosv 2013-11-26 20:08:31 UTC
Hi publicface, thanks for reporting.

Please can you attach a sample file, where to see the issue.

Have you tried trough Menu/Tools/Update.

Verify Menu/Tools/Options/LibreOffice writer/General - Update Automatically - Fields.
Comment 2 publicface 2013-11-27 00:43:21 UTC
Created attachment 89877 [details]
Sample demonstrating bug.  Includes answers to questions asked.

Sample attached.  Includes answers to questions asked.
Comment 3 m.a.riosv 2013-11-27 01:50:36 UTC
I am not used to work with it. And I don't know if you are properly set up the cross reference.

You can find detailed information in documentation:
https://wiki.documentfoundation.org/Documentation/Publications#LibreOffice_Writer_Guide
Chapter 14 Working with Fields

Please if you can solve the issue, change the status to resolved notabug
Comment 4 QA Administrators 2014-06-01 21:30:39 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 5 publicface 2014-06-01 23:02:24 UTC
Ugh.  This information was provided 6 months ago and the developer stated "I am not used to work with it."
Comment 6 m.a.riosv 2014-06-01 23:34:30 UTC
Created attachment 100257 [details]
Sample file to test

(In reply to comment #5)
> Ugh.  This information was provided 6 months ago and the developer stated "I
> am not used to work with it."

I did this comment, but I am not a developer, an user helping on the bug's triage.

I any case, the proper way is someone different of the reported sets up the bug as new if he can reproduce it.

Seems as you have set up a bookmark not a cross reference, modifying on the first paragraph, [F9] updates the value in the second one.
Comment 7 publicface 2014-06-11 16:04:14 UTC
No.

As you stated "I am not used to work with it".  And that is very clear.

In any event, I've lost interest.  Congratulations.
Comment 8 m.a.riosv 2014-06-11 17:18:06 UTC
Don't seems too much friendly with who is expending their free time trying to help. Better I forget this matter.
Comment 9 QA Administrators 2015-07-18 17:44:35 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-07-18
Comment 10 Buovjaga 2015-10-23 17:03:30 UTC
This was never confirmed.

Is this still a problem?

I don't know, how to insert a cross-reference referencing a user field. I tried, but failed.

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists and provide step by step instructions for reproducing. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 11 m.a.riosv 2015-12-27 02:12:59 UTC
Four month without notice.

Resolved.

Please if you have the issue, reopen it again.