Bug 72113 - FORMATTING: Impress/Presentation table default font size (18pt) and (?) font name (Arial) not editable
Summary: FORMATTING: Impress/Presentation table default font size (18pt) and (?) font ...
Status: RESOLVED DUPLICATE of bug 33743
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ImpressDraw-Tables
  Show dependency treegraph
 
Reported: 2013-11-28 10:12 UTC by Jérôme Borme
Modified: 2019-11-24 15:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jérôme Borme 2013-11-28 10:12:16 UTC
As far as I could find, there is no way to change default font in tables in Impress/Presentation. Table text is not assigned any style name to edit. I edited ALL styles and did not let any place for Arial 18 to hide. Still new tables come with Arial 18.

When text is removed from a cell, cell is reset to Arial 18. When text is pasted before the first caracter of a cell, the whole cell is changed to Arial 18. When a text is pasted before the first character of one line of a cell, the text from that point to the end of the cell is changed to Arial 18.

Bug report in Apache OpenOffice : https://issues.apache.org/ooo/show_bug.cgi?id=121618
Forum posts several years ago about this bug in OOo https://forum.openoffice.org/en/forum/viewtopic.php?t=22540&p=102781

People tend to say it is linux-specific but I can't check what happens in OSes other than linux.
Comment 1 Cor Nouws 2013-11-28 10:57:14 UTC
Hi Jérôme,

Thanks - set this one to new.
Definitely an area in which some progress can be made...

Ciao,
Cor
Comment 2 Pierre C 2013-12-20 20:12:42 UTC
You just have to select a part of the table

right-clic on the selected part and choose "edit object style"

here, you should be able to choose the font style that you need
Comment 3 Jérôme Borme 2013-12-21 18:07:31 UTC
Thanks for the tip, however I'm not sure how to use it correctly and tere are still some buggy behaviours around.

I create a table with the toolbar icon for tables. The newly created table is immediately selected, and I can do right-click -> Edit Style. Then I would expect a window to open to let me change some parameters. It's not the case, nothing opens. Still I can see that something happens, as the table remains selected even if I click somewhere else on the screen. It's somehow in Edit style mode and does not let me unselect the table, but it's not very visible. Anyway since I'm using the experimental sidebar, I can change some properties there, and indeed it changes the properties of all cells including the empty cells. BUT, there's still one bug. let's summarise:

1. Create a table using the icon in the toolbar
2. right-click on the (selected) table, do Edit style
3. Change some properties, for example the font name in the sidebar if you have it (I don't know what would happen if I never activated the sidebar though).
4. Select a drawing element, say a circle, and click on the page (it's not required to actually draw the circle). It's the only way that I could find to exit the Edit Style mode.
5. Confirm that all cells now default to the new selected font, including the empty cells.

Now the buggy part.

6. Select some text inside a cell, copy it.
7. Go to some other cell. Write one line in the cell, press enter, write a second line.
8. Press the Home key to go to the beginning of your second line. Press Enter. This create an empty line just above.
9. Press the up arrow key to move to the empty line above.
10. Paste the text you copied at step 6.

Result: text is pasted in Arial 18. The cell has now 3 lines, the second of those written in Arial 18.
Comment 4 Pierre C 2013-12-21 18:19:10 UTC
@Jérome

Sorry, it was a joke.

I had the same problem as you searching a way to configure a default font for tables in impress. And I tried to edit a table style. And as you write, it doesn't work.

I linked the bug of this impress freeze yesterday

https://www.libreoffice.org/bugzilla/show_bug.cgi?id=72178

what version of LO are you with ?

With mine (4.0.6 or 4.1.3+) Impress frequently crash when working with tables
Comment 5 Jérôme Borme 2013-12-21 18:42:29 UTC
Oh, I see :-) I'm using 4.1.3.2 and fortunately I did not have a crash in a long time (I believe the 4.x series is much better at this respect than the 3.6). I'm using gentoo so I compile libreoffice on my system (gcc 4.6.4) instead of using an official binary. Maybe some bugs involving crashes are not exposed the same way depending on how the binary was built.
Comment 6 QA Administrators 2015-04-19 03:20:51 UTC Comment hidden (obsolete)
Comment 7 Pierre C 2015-04-19 14:41:26 UTC
Still noway to define default font size and name for impress tables

LO 4.3.7.1 and Master LO x64
Comment 8 QA Administrators 2016-09-20 09:33:15 UTC Comment hidden (obsolete)
Comment 9 Timur 2019-11-24 15:39:16 UTC
To change font in Tables, right-click Table Properties. 
It seems to work without crash. No more Edit styles.

General issue is in Bug 33743, to add Basic fonts like in Writer.
I'll mark this bug as a duplicate.

*** This bug has been marked as a duplicate of bug 33743 ***