Bug 72123 - TABLE: Embedded spreadsheet table corrupted upon click or PDF generation
Summary: TABLE: Embedded spreadsheet table corrupted upon click or PDF generation
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: Other macOS (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-28 14:43 UTC by bz.libreoffice.org
Modified: 2017-11-05 20:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Document which loses data upon click in table / PDF generation without notice. (15.70 KB, application/vnd.oasis.opendocument.text)
2013-11-28 14:43 UTC, bz.libreoffice.org
Details
Short screencast showing how the cell is corrupted by clicking in the table. (65 bytes, text/plain)
2013-11-29 19:37 UTC, bz.libreoffice.org
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bz.libreoffice.org 2013-11-28 14:43:00 UTC
Created attachment 89957 [details]
Document which loses data upon click in table / PDF generation without notice.

LibreOffice Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a

Problem description: 

The embedded spreadsheet table in the attached document is corrupted upon click or PDF generation.

Steps to reproduce:

1. Load document
2. Hover over cell D2 and it will show a proper formula "= <B2>*<C2>"
3. Generate PDF or click anywhere in the table
4. See the sum in D2 evaporate to 0. Total sum also reduced.
5. Close the file -> No change reported

Current behavior:
Document which I had created for quotes to my clients loses crucial data.

Expected behavior:
Loss free treatment of the data.

==============================
PS: I had to open https://www.libreoffice.org/get-help/bug/ in Firefox, because the page wouldn't display right in Chrome... :/
Operating System: Mac OS X
Version: 4.1.3.2 release
Comment 1 sophie 2013-11-29 15:34:01 UTC
Can't reproduce, export to PDF is correct and shows the same as in Writer
using Version: 4.1.3.2 Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a - Sophie
Comment 2 bz.libreoffice.org 2013-11-29 19:37:46 UTC
Created attachment 90002 [details]
Short screencast showing how the cell is corrupted by clicking in the table.

https://dl.dropboxusercontent.com/u/76285475/Cell%20corrupted.mov
Comment 3 bz.libreoffice.org 2013-11-29 19:53:23 UTC
Comment on attachment 90002 [details]
Short screencast showing how the cell is corrupted by clicking in the table.

What OSX are you on? I'm on 10.7.5 11G63B
Comment 4 bz.libreoffice.org 2013-11-29 19:54:02 UTC Comment hidden (obsolete)
Comment 5 Thomas van der Meulen 2013-12-02 20:17:39 UTC
Thank you for your bug report, I can reproduce this bug running 
Version: 4.2.0.0.beta1, Also in 3.6.7.2(Build ID: e183d5b) and 4.0.6.2
Build ID: f4ca7b35f580827ad2c69ea6d29f7c9b48ebbac7
OS: Mac osx 10.9.
Comment 6 QA Administrators 2015-04-19 03:22:50 UTC Comment hidden (obsolete)
Comment 7 bz.libreoffice.org 2015-05-04 08:21:34 UTC
Reproduced on Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
Locale: de_

Took me almost an hour to confirm that the bug persists and post here. Please streamline the process, guys...who else would take their precious time to check!?
Comment 8 QA Administrators 2016-09-20 09:37:39 UTC Comment hidden (obsolete)
Comment 9 bz.libreoffice.org 2016-09-21 07:30:47 UTC
Reproduced on OSX 10.11.6
LibreOffice Version: 5.2.1.2
Build ID: 31dd62db80d4e60af04904455ec9c9219178d620

as well as

LibreOffice Version: 5.1.4.2
Build ID: f99d75f39f1c57ebdd7ffc5f42867c12031db97a
Comment 10 Xisco Faulí 2017-06-12 11:26:36 UTC
Changing version back to the earliest affected version.
Comment 11 eisa01 2017-11-05 20:28:02 UTC
I had a look at the test case, and cell C2 is text, not a number. C3 and C4 are numbers and hence their formulas are not broken.

As such this is not a bug per se. It could be that LO somehow have mangled the data at one point, but as of now this is a format error in the input.

Version: 6.0.0.0.alpha1+
Build ID: 7e03c4eed72452fdfb87341214a21956c08ba969
CPU threads: 2; OS: Mac OS X 10.12.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2017-10-25_23:45:02
Locale: en-US (en_US.UTF-8); Calc: group