Bug Hunting Session
Bug 72124 - "Enter Password" dialog box to open protected file, hidden under file manager window (if you open more than 1 protected file)
Summary: "Enter Password" dialog box to open protected file, hidden under file manager...
Status: RESOLVED DUPLICATE of bug 49134
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-28 14:47 UTC by Sebastiano
Modified: 2018-02-04 17:40 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastiano 2013-11-28 14:47:37 UTC
Problem description: 

Steps to reproduce:
1. Open an ODT document
2. Go back to Windows File Manager maximized
3. Double click on another password protected ODT document

Current behavior:
3. The Insert password dialog box opens under the file manager windows. The user can't understand why the document is not opening.

Expected behavior:
3. The Insert password dialog box should open on top

              
Operating System: Windows XP
Version: 4.1.3.2 release
Comment 1 Cor Nouws 2013-12-27 23:10:04 UTC
Hi Sebastiano,

Was this annoying behaviour there in older versions too, that you can tell?
thanks,
Cor
Comment 2 retired 2013-12-28 01:43:59 UTC
Sebastiano, also could you please check, if this bug is still valid / reproducible with the latest pre-release 4.2.0.1: http://www.libreoffice.org/download/pre-releases/

After providing the requested info, please reset this bug to UNCONFIRMED. Thanks :)
Comment 3 Sebastiano 2014-01-07 13:32:13 UTC
(In reply to comment #2)
> Sebastiano, also could you please check, if this bug is still valid /
> reproducible with the latest pre-release 4.2.0.1:
> http://www.libreoffice.org/download/pre-releases/
> 
> After providing the requested info, please reset this bug to UNCONFIRMED.
> Thanks :)

Yes, the bug is is still there (installed on a clean Windows XP Pro).
Comment 4 tommy27 2014-06-22 08:22:23 UTC
issue confirmed with LibO 4.2.4.2 using Win7x64
set status to NEW and edited summary notes
Comment 5 QA Administrators 2015-07-18 17:42:44 UTC Comment hidden (obsolete)
Comment 6 tommy27 2015-07-19 05:53:11 UTC
still present in LibO 4.4.5.1 under Win8.1 x64
Comment 7 QA Administrators 2016-09-20 10:18:01 UTC Comment hidden (obsolete)
Comment 8 Sebastiano 2017-01-10 13:40:42 UTC
The problem is still there.
Regards
Comment 9 Cor Nouws 2017-01-10 14:55:05 UTC
thanks for checking and reporting, Sebastiano.

No need to adjust version number, pls leave it to the oldest known version :)
Comment 10 QA Administrators 2018-01-11 03:34:19 UTC Comment hidden (obsolete)
Comment 11 tommy27 2018-01-11 06:10:06 UTC
still present in 5.3.7.2 under Win8.1 x64
Comment 12 Cor Nouws 2018-02-04 16:12:06 UTC
(In reply to tommy27 from comment #11)
> still present in 5.3.7.2 under Win8.1 x64

We live with 6.0.3 Tommy :)
5.3.7 is not a version to check the current state of development.
Is it possible for you to test in 6.0.3 too, please?
Comment 13 Aron Budea 2018-02-04 17:40:33 UTC
(In reply to Cor Nouws from comment #12)
> Is it possible for you to test in 6.0.3 too, please?
Actually, please test with a master daily build, because there are relevant commits that were pushed a week ago (they will be backported to 6.0 as well, but the changes aren't yet committed there).

*** This bug has been marked as a duplicate of bug 49134 ***