Bug 72188 - FILEOPEN: DOCX Document Makes Writer CRASH on Open
Summary: FILEOPEN: DOCX Document Makes Writer CRASH on Open
Status: RESOLVED DUPLICATE of bug 70812
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2013-11-30 23:36 UTC by Henrik
Modified: 2013-12-01 16:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
The document that makes Writer crash (6.47 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-11-30 23:36 UTC, Henrik
Details
Backtrace (46.03 KB, text/plain)
2013-12-01 16:11 UTC, Henrik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Henrik 2013-11-30 23:36:37 UTC
Created attachment 90047 [details]
The document that makes Writer crash

Problem description: 

Steps to reproduce:
1. Open attached document
2. Watch Writer crash

Current behavior:
Writer crashes instantly at open.

Expected behavior:
Should open the document.

Further info:
I'm running Xubuntu 13.10 64-bit.
The document opens perfectly in Abiword and Google Docs.

              
Operating System: Ubuntu
Version: 4.1.2.3 release
Comment 1 m.a.riosv 2013-12-01 00:49:02 UTC
Win7x64Ultimate
Version: 4.1.4.0.0+ Build ID: d6ee64b75581cbeb92534271ee6f4e87f07aa5c

General error
General input/output error

But no crash.
Comment 2 Jorendc 2013-12-01 10:34:03 UTC
Can't reproduce a crash

Tested using Mac OSX 10.9 with LibreOffice 4.1.4.1 rc and LibreOffice ersion: 4.3.0.0.alpha0+
Build ID: b32651febdaad5939250fb04f721d88952f54732
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2013-11-26_00:09:49

The document opens, but every paragraph (= return) is transformed to a page-break. But that looks related to bug 69913.
Comment 3 Henrik 2013-12-01 16:11:48 UTC
Created attachment 90055 [details]
Backtrace
Comment 4 Henrik 2013-12-01 16:29:56 UTC
The bug may be related to bug 72046 since the document in this bug report was created by Pages on IOS.
Comment 5 Maxim Monastirsky 2013-12-01 16:51:14 UTC
(In reply to comment #4)
> The bug may be related to bug 72046 since the document in this bug report
> was created by Pages on IOS.
Indeed.

*** This bug has been marked as a duplicate of bug 70812 ***