Download it now!
Bug 72300 - CreateUnoDialog - action ont supported
Summary: CreateUnoDialog - action ont supported
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
4.0.6.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-04 09:37 UTC by Piotr
Modified: 2015-04-01 14:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr 2013-12-04 09:37:40 UTC
After upgrading to LO 4.0.6.2 yesterday an error appeared when trying to call dialog box. The error is "Akcja nie jest obsługiwana. Nieprawidłowe wywołanie procedury" (Translation: Action not supported. Incorrect procedure call). None of the buttons works.
It used to work fine till yesterday's upgrade (LO 4.0.5 -> LO 4.0.6). 

Please help as soon as You can - my whole application doesn't work!


The example code is:

Sub OtworzDialogWysylania 
	DialogLibraries.LoadLibrary("Standard")
    oDialog1 = CreateUnoDialog( DialogLibraries.Standard.Dialog1 )


(...)
end sub

It is assigned to the button in form.
Comment 1 Kevin Suo 2014-07-09 04:25:25 UTC
Hi Piotr,
I do not reproduce with libreoffice 4.3.0.2, windows XP SP3.

When created "Dialog1" within "Standard" and run the following macro:

Sub OtworzDialogWysylania 
	DialogLibraries.LoadLibrary("Standard")
	oDialog1 = CreateUnoDialog( DialogLibraries.Standard.Dialog1 )
	oDialog1.Execute()
end sub

Dialog1 appears as expected.

Would you please test with the newer versions? thanks.
Comment 2 QA Administrators 2015-02-19 04:39:58 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team

Message generated on: 2015-02-18
Comment 3 QA Administrators 2015-04-01 14:52:16 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

-- The LibreOffice QA Team This NEEDINFO Message was generated on: 2015-04-01

Warm Regards,
QA Team