Bug Hunting Session
Bug 72330 - Upgrade from LibreOffice 3.5 to 4.x breaks iBus Input
Summary: Upgrade from LibreOffice 3.5 to 4.x breaks iBus Input
Status: RESOLVED DUPLICATE of bug 91375
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-05 00:26 UTC by Charles Lipton
Modified: 2016-05-14 19:46 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Charles Lipton 2013-12-05 00:26:29 UTC
PROBLEM:  

When LibreOffice is upgraded to v.4.x in Debian Wheezy, iBus shows a number of different problems.  

- In the most recent case, the icon does not switch to indicate a change in language input, althought input becomes possible.  However, the keyboard switching back to English usually fails and it becomes necessary to manually switch between language inputs using a mouse instead of the keyboard. But, manual switching is also blocked after switching back and forth several times.

- In Kubuntu 13.04 and 13.10, switching is completely blocked and it becomes impossible to input a foreign language, entirely.

- Within my (Tokyo)LUG, other members are reporting that they cannot input Japanese or other languages at all.  The issue is common to LibreOffice v.4.x, independent of OS but has also appeared to be affected by KDE version.  This last may be a false lead given what I have disconvered in Wheezy.

My work requires me to produce reports in English with terms, formal names, descriptions, and titles given in Japanese, along with other annotations and notes in Japanese and English.  In some documents, I am required to switch languages several times per line of text, inserting as many as 100+ characters per page, among the English.  I can't be taking my hands off the keyboard every couple of words to click a mouse, when clicking a mouse works at all.

OTHER DETAILS:

Current OS is Debian 7.02 Wheezy + KDE but the same issue was observed in Kubuntu 13.04 and 13.10.  

iBus is v.1.4.2 and input method is confined to Japanese with ibus-mosc, but the same issues were seen and confirmed with ibus-anthy.

All desktops' system location have been set to US English.  I have found that installing additional languages (I work in Japanese, Traditional Chinese, Simplified Chinese, German, Khmer) causes a number of other issues that I don't need and which go away when they're not there.

Other programs in which iBus input works and is immdeiately switchable are: Claws Mail 3.9.2, IceDove 17.0.10, IceWeasel 25.0, Skype and Dolphin.  The problem is confined exclusively to LibreOffice.  

TEMPORARY SOLUTION:

I switched from wheezy-backports (originally done to upgrade Claws Mail to a newer version that was more compatible with my OS) to stable "installed" versions, rolled back my Linux Kernel to 3.2 (from 3.11) and downgraded from LibreOffice 4.1 to 3.5.4.2 (Build ID: 350m1) to solve this problem.  I have returned to Linux kernel 3.11 and have blocked upgrades to newer versions.  I now upgrade selectively but would like to keep my system at latest versions.
Comment 1 efelthauser 2014-02-15 16:51:06 UTC
I have this problem too.

LibreOffice 4.1.3.2 410m0(Build:2)
IBus 1.5.3
KDE Development Platform: 4.11.5
kernel 3.11.0-15-generic
on Kubuntu recommended updates and important security updates

I cannot belive that tyring to use input methods fails on a modern linux OS, on the main word processing suite...  Really lame!!!!

Please fix ASAP.
Comment 2 Joel Madero 2015-05-02 15:40:58 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02
Comment 3 Buovjaga 2015-06-20 10:38:02 UTC
Apparently it worked in 4.3, but is again broken in 4.4, bug 91375
Comment 4 Buovjaga 2016-05-14 19:46:06 UTC

*** This bug has been marked as a duplicate of bug 91375 ***