Bug 72365 - FILESAVE: blank cell in exported jpg and bmp if cell is selected during export
Summary: FILESAVE: blank cell in exported jpg and bmp if cell is selected during export
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA Confirmed:4.2.0.0.beta2:Ubuntu
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-05 17:06 UTC by sharuzzaman@gmail.com
Modified: 2017-09-29 13:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test case and exported example for the bug (43.70 KB, application/zip)
2013-12-05 17:06 UTC, sharuzzaman@gmail.com
Details
exported JPG showing the artifact (8.98 KB, image/jpeg)
2015-04-20 13:51 UTC, sharuzzaman@gmail.com
Details
table cell export to jpg (22.05 KB, image/jpeg)
2016-09-20 21:38 UTC, sharuzzaman@gmail.com
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sharuzzaman@gmail.com 2013-12-05 17:06:45 UTC
Created attachment 90317 [details]
test case and exported example for the bug

Problem description: 
When table is being used in Impress, selecting a cell, then exporting the slide as bmp or jpg, will render the cell empty in the resulting image. If cell or table is not selected, all content will be shown in exported image. This issue did not happen when exporting to png or pdf.

Steps to reproduce:
1. Create new Impress slide
2. Add 2x2 cell table
3. Fill in each cell with some word
4. Select any cell. Just make sure the cursor is in the cell and blinking. No need to highlight.
5. Export the slide as bmp or jpg.
6. The cell selected will be empty in the exported image

Current behavior:
Cell empty in exported image, if cell is selected in slide

Expected behavior:
Cell should not be empty. Behaviour should match like when exporting to png or pdf

Test case Impress slide attached

              
Operating System: Windows XP
Version: 4.1.3.2 release
Comment 1 sharuzzaman@gmail.com 2013-12-05 18:26:26 UTC
Additional info:

Text box is also susceptible to this bug. Found out about it just now.
Comment 2 sophie 2013-12-06 15:49:17 UTC
Confirmed with Version: 4.2.0.0.beta2
Build ID: 1a27be92e320f97c20d581a69ef1c8b99ea9885d Ubuntu 13.10 - Set to New and change Plateform to all - Sophie
Comment 3 Robinson Tryon (qubit) 2013-12-07 00:39:34 UTC
Add repro info to whiteboard.
Comment 4 QA Administrators 2015-04-19 03:19:52 UTC Comment hidden (obsolete)
Comment 5 sharuzzaman@gmail.com 2015-04-20 13:49:36 UTC
Bug still exist in Libreoffice Impress

Version: 4.3.3.2
Build ID: 430m0(Build:2)
OS: Debian Jessie 8.0

Package installed:
libreoffice-common 1:4.3.3-2
libreoffice-core 1:4.3.3-2
libreoffice-draw 1:4.3.3-2
libreoffice-impress 1:4.3.3-2
libreoffice-style-galaxy 1:4.3.3-2
uno-libs3 4.3.3-2
ure 4.3.3-2

Exported JPG is attached
Comment 6 sharuzzaman@gmail.com 2015-04-20 13:51:02 UTC
Created attachment 114959 [details]
exported JPG showing the artifact

The attached JPG is exported from Libreoffice Impress 4.3.3.2
Comment 7 QA Administrators 2016-09-20 09:31:57 UTC Comment hidden (obsolete)
Comment 8 sharuzzaman@gmail.com 2016-09-20 21:37:05 UTC
Bug still exist in Libreoffice Impress

OS: Debian Stretch/Testing 9.0
Version: 5.2.1.2
Build ID: 1:5.2.1-1
CPU Threads: 1; OS Version: Linux 4.6; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: group

Package installed:
libreoffice 1:5.2.1-1
libreoffice-avmedia-backend-gstreamer 1:5.2.1-1
libreoffice-base 1:5.2.1-1
libreoffice-base-core 1:5.2.1-1
libreoffice-base-drivers 1:5.2.1-1
libreoffice-calc 1:5.2.1-1
libreoffice-common 1:5.2.1-1
libreoffice-core 1:5.2.1-1
libreoffice-draw 1:5.2.1-1
libreoffice-gtk2 1:5.2.1-1
libreoffice-impress 1:5.2.1-1
libreoffice-java-common 1:5.2.1-1
libreoffice-math 1:5.2.1-1
libreoffice-pdfimport 1:5.2.1-1
libreoffice-report-builder-bin 1:5.2.1-1
libreoffice-style-galaxy 1:5.2.1-1
libreoffice-writer 1:5.2.1-1
uno-libs3 5.2.1-1
ure 5.2.1-1


Exported JPG is attached. In the blank cell, there should be word "alpha"
Comment 9 sharuzzaman@gmail.com 2016-09-20 21:38:23 UTC
Created attachment 127487 [details]
table cell export to jpg
Comment 10 Xisco Faulí 2017-09-29 08:48:23 UTC Comment hidden (obsolete)
Comment 11 sharuzzaman@gmail.com 2017-09-29 13:44:42 UTC
No issue in latest Libreoffice 5.4.1 64 bit on Windows 10

Version: 5.4.1.2 (x64)
Build ID: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527
CPU threads: 4; OS: Windows 6.19; UI render: default; 
Locale: en-MY (en_MY); Calc: group