Bug 72383 - FORMATTING: date and time
Summary: FORMATTING: date and time
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-06 06:03 UTC by Lu
Modified: 2015-04-01 14:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of cell, input window & cell format (111.22 KB, image/jpeg)
2013-12-06 06:03 UTC, Lu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lu 2013-12-06 06:03:22 UTC
Created attachment 90338 [details]
screenshot of cell, input window & cell format

Version: 4.1.2.3
Build ID: 40b2d7fde7e8d2d7bc5a449dc65df4d08a7dd38

Not sure which version it started.  All spreadsheets I've tried have problems - mostly because time is linked to time of day cf stopwatch for science and sport.

Problem description: 
Enter date as DD/MM/YY, say 21/11/13, cell formatted to this, in input window after <return> appears as 13/11/21 with input window showing 11/13/2021 .  To get the right appearance in the cell in graph, I have to edit cell content to MM/DD/20YY

Steps to reproduce:
1. format cell DD/MM/YY....
2. type in e.g. 21/11/13....
3. ....

Current behavior:
Appears as 13/11/21

Expected behavior:
Expect 21/11/13
              
Operating System: Windows 7
Version: unspecified
Comment 1 m.a.riosv 2013-12-06 14:36:31 UTC
The language for cell format is English-US with a non US format code, so to me is fine to see the date in US format in edit bar.
Comment 2 Lu 2014-03-21 10:59:07 UTC
I've had the same problem but it was not consistent.  Now I make notes on the sheet saying what the numbers actually mean.

It is perhaps fine to see, however, I would expect to see whatever format I set not some default US format not matter how fine it is.  I sometimes wonder whether US natives are aware that there is a world outside of US :-).
Comment 3 m.a.riosv 2014-07-15 00:20:49 UTC
Have you tried changing the language for the cell? [Ctrl+1], numbers tab.
Comment 4 QA Administrators 2015-02-19 04:43:27 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team

Message generated on: 2015-02-18
Comment 5 QA Administrators 2015-04-01 14:52:34 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

-- The LibreOffice QA Team This NEEDINFO Message was generated on: 2015-04-01

Warm Regards,
QA Team