Bug 72524 - Can't handle correctly FTP URLs received from nautilus
Summary: Can't handle correctly FTP URLs received from nautilus
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-09 15:30 UTC by Maxim Monastirsky
Modified: 2014-03-18 06:23 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maxim Monastirsky 2013-12-09 15:30:07 UTC
Pre-requisites:

1. Install vsftpd.
2. Ensure that you have 'local_enable=YES' and 'seccomp_sandbox=NO' in config file.
(3. Under Fedora disable SELinux using 'sudo setenforce 0'.)
4. Create a file ('test.odt') in your Documents dir.
5. Ensure that you can open this file from the command line using
   'libreoffice ftp://username@localhost/Documents/test.odt'
   (where 'username' is your user name).

First scenario:

1. Make sure you don't have 'chroot_local_user=YES' activated in config file.
2. Open Nautilus (so called 'Files').
3. From the menu choose 'Connect to server', and type 'ftp://localhost/'.
4. Open Documents folder and double-click on the file.
5. You'll get 'Access to ftp://localhost/home/username/Documents/test.odt was denied' message. LO gets in that case the following URL as argument, which it can't handle (compare with the above command line):
'ftp://localhost/home/username/Documents/test.odt'

Second scenario:

1. Set 'chroot_local_user=YES'.
2. Set your home folder as read-only (don't forget to change it back after confirming the bug!).
3. Connect using Nautilus to 'ftp://localhost/' (same error message as above). In that case LO gets 'ftp://localhost/Documents/test.odt', and it fails probably because it assumes that if no username specified in the command line, it should be anonymous.
4. However if you connect to the server with 'ftp://username@localhost/' it will work.