Bug 72543 - ib_util not found when creating or accessing new firebird embedded database
Summary: ib_util not found when creating or accessing new firebird embedded database
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.2.0.0.beta2
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.5.0 target:4.4.1
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-09 21:37 UTC by Alexandre Moradell
Modified: 2015-01-27 10:28 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
firebird.log in Libreofficedev 4 root directory (3.25 KB, text/plain)
2013-12-09 21:49 UTC, Alexandre Moradell
Details
Root directory after firebird embed installation (56.33 KB, image/png)
2013-12-09 22:26 UTC, Alexandre Moradell
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Moradell 2013-12-09 21:37:48 UTC
ib_util dll not found

PC-XP	Sun Dec 08 20:03:48 2013
ib_util init failed, UDFs can't be used - looks like firebird misconfigured
	
C:\Program Files\LibreOfficeDev 4\bin/ib_util.dll library has not been found
	C:\Program Files\LibreOfficeDev 4\ib_util.dll library has not been found
	ib_util.dll library has not been found

PC-XP	Sun Dec 08 20:04:52 2013
	Firebird shutdown is still in progress after the specified timeout

I have several Firebird on this PC (1.5, 2.5) so I copy ib_util.dll in C:\Program Files\LibreOfficeDev 4 and try also on a new sub-directory C:\Program Files\LibreOfficeDev 4\bin

Same problem. So I download Firebird Embed from sourceforge and unzip in :\Program Files\LibreOfficeDev 4 and no more firebird.log.
Comment 1 Alexandre Moradell 2013-12-09 21:49:10 UTC
Created attachment 90539 [details]
firebird.log in Libreofficedev 4 root directory
Comment 2 Alexandre Moradell 2013-12-09 22:26:33 UTC
Created attachment 90541 [details]
Root directory after firebird embed installation
Comment 3 Alexandre Moradell 2013-12-09 22:31:07 UTC
To be sure, I uninstalled LibreOfficeDev 4 and reinstalled in another directory.
C:\Program Files\LibreOfficeDev4

After installing I had to change RootDirectory in firebird.conf

RootDirectory = "C:\Program Files\LibreOfficeDev4"

If not, I get in firebird.log :
PC-XP	Mon Dec 09 23:20:57 2013
	Can't load INTL module 'C:\Program Files\LibreOfficeDev4\intl\fbintl.dll'
Comment 4 Robert Großkopf 2013-12-10 18:45:10 UTC
The longer I read, what you have written, I couldn't understand ...

You have started 4.2.0.0beta2. 
You have activated 
Tools → Options → Advanced → Enable experimental features
(without this the embedded Firebird doesn't work)
You have tried to open an embedded Firebird-Database?

Then you write about several other Firebird-installations, also Firebird embed from sourceforge. This installations would have nothing to do with the embedded database of LO 4.2.0.0.beta2.

Do you want to open or create an embedded Firebird database or do you want to connect to an external Firebird database?

I have tested to open an embedded Firebird-database under Linux 64bit rpm - no problem here - but it isn't your system (Win-XP).
Comment 5 Alexandre Moradell 2013-12-10 20:01:40 UTC
Sorry if I was unclear.

1 - I installed LibreOfficedev 4 on WinXP
2 - Firebird activation was ok in LibreOffice
3 - Database creation also.
4 - And I managed to create a table.

The problem was on the root directory when I saw a firebird.log file created with the ib_util error.

That's all.

My attempt to install Firebird Embed was just to see if it resolved the problem.
Comment 6 ribotb 2014-02-03 19:47:08 UTC
Effectively, in my firebird.log files (LO 4.2.0.3 under Win XP and Win 7) I find these messages:

   ib_util init failed, UDFs can't be used - looks like firebird misconfigured
   C:\Program Files\LibreOffice\4.2.0.3\bin/ib_util.dll library has not been   found
   C:\Program Files\LibreOffice\4.2.0.3\ib_util.dll library has not been found
   ib_util.dll library has not been found

   Operating system call _beginthreadex failed. Error code 5

But that does not seem a problem, I can create, open databases with embedded Firebird and it's not necessary to copy some files from a Firebird SQL Server.

Unless if the bugs currently founded in embedded firebird have a link with these messages?

Bernard Ribot
Comment 7 Alex Thurgood 2014-03-14 15:40:07 UTC
Separate confirmation from Bernard. Setting status to confirmed, adding Andrzej and Lionel to CC
Comment 8 Andrzej Hunt 2014-03-18 08:40:39 UTC
This isn't really a bug -- we don't need UDF support for embedded firebird, hence the lack of ib_util isn't an issue and can safely be ignored.

However the warning is still annoying --  maybe it's worth just patching out the warning line for our builds? (src/jrd/fun.epp:164)?
Comment 9 Julien Nabet 2014-10-12 07:23:06 UTC
I noticed this commit:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=fee691380bf6a6335c274b13865b9a7f71581331
Perhaps unrelated, I must recognize I don't know.
Lionel: if unrelated, should we disable log as Andrzej proposed? Put this one to "won't fix"? Other?
Comment 10 ribotb 2014-10-12 12:02:15 UTC
Hello,

With :
Version: 4.4.0.0.alpha0+
Build ID: 7dc6c9af4ba313f054331f5130470d83d875bc16
TinderBox: Win-x86@42, Branch:master, Time: 2014-10-11_13:41:48

the message is still present. But, it's perhaps too soon to test this commit?

Bernard
Comment 11 Julien Nabet 2014-10-12 12:21:20 UTC
Thank you Bernard for your feedback, I expected it :-( Let's wait for better news from Lionel's feedback :-)
Comment 12 Alex Thurgood 2015-01-03 17:40:28 UTC Comment hidden (no-value)
Comment 13 Lionel Elie Mamane 2015-01-22 21:29:53 UTC
(In reply to Julien Nabet from comment #9)
> should we disable log as Andrzej proposed?

Yes, we can patch out the warning.
Comment 14 Commit Notification 2015-01-24 02:19:20 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e3c0025461bdf55e62a308a76c3aa0a35109f076

Resolves fdo#72543: ib_util not found when creating or accessing new firebird

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Julien Nabet 2015-01-27 10:28:48 UTC
Fixed on 4.4 branch with https://gerrit.libreoffice.org/#/c/14149/