Bug 72578 - rtf created with Writer containing tables are saved but loaded wrong
Summary: rtf created with Writer containing tables are saved but loaded wrong
Status: RESOLVED DUPLICATE of bug 80708
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:rtf
Depends on:
Blocks: RTF-Tables
  Show dependency treegraph
 
Reported: 2013-12-10 20:50 UTC by Fabien
Modified: 2017-10-05 22:07 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
the file created with Writer with the issue (24.64 KB, application/rtf)
2013-12-10 20:50 UTC, Fabien
Details
first file with arrays save to .odt (8.45 KB, application/vnd.oasis.opendocument.text)
2013-12-13 21:55 UTC, Fabien
Details
same file saved as rtf (5.94 KB, application/rtf)
2013-12-13 21:56 UTC, Fabien
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabien 2013-12-10 20:50:06 UTC
Created attachment 90592 [details]
the file created with Writer with the issue

I created a sample document with two columns arrays. I save it in rtf, if I load it then first line of some of the arrays are on three columns.

I've tried to delete lines, recreate them again, save, same issue.
I've tried to merge cells to go from 3 to 2 columns, same issue.

file was created with writer. I've tried to load the doc on Wordpad, the doc look fine. If loading it in Writer, columns mistmatch.

Regards
Fabien
Comment 1 Jean-Baptiste Faure 2013-12-12 22:24:54 UTC
Do you experience the same problem if you create the document in OpenDocument (.odt) format and save it in RTF format using menu File > Save as... when it is finished?
If you have it, please attach the odt file to this bug report.

Best regards. JBF
Comment 2 Fabien 2013-12-13 21:55:08 UTC
Created attachment 90749 [details]
first file with arrays save to .odt
Comment 3 Fabien 2013-12-13 21:55:52 UTC
Hi,

Thank you for watching this issue, I did as you asked:
- open Writer
- create a new doc with 2 tables
- save it first as .odt
- using save as, save it as rtf
- close Writer
- open the rtf with Writer, yes same issue on the second table, hope this help!

In fact, at first, I did not use .odt at all, only rtf. The "wrong" rtf generated by Writer seems OK in other software as WordPad

Regards
Fabien
Comment 4 Fabien 2013-12-13 21:56:40 UTC
Created attachment 90750 [details]
same file saved as rtf
Comment 5 Jean-Baptiste Faure 2013-12-14 10:59:20 UTC
Reproducible with version 4.2.0.0beta2+ and 4.1.5.0+ under Ubuntu 13.10 x86-64.
The second table has 3 columns in the first row instead of 2 when exported to RTF

Hi Miklos, this one is probably in your area.

Best regards. JBF
Comment 6 Alexandr 2014-07-18 06:20:01 UTC
I reproduce the bug with LibreOffice 4.2.5 and 4.3.0.3 as it is described in comment 3.

> The "wrong" rtf generated by Writer seems OK in other software as WordPad

But the second table in the .rtf is corrupted in MS Word Viewer. The file is really wrong. It is FILESAVE issue.

I have been meeting the bug (appearing addition column in the first line of a table after rtf save) for many rtf files from different sources which I tried to edit with LibreOffice. Hence, I believe, priority of this bug should be increased.
Comment 7 Alexandr 2015-05-07 19:54:21 UTC
Reproducible with LibreOffice 5.0.0.0 alpha1, but correct in 5.0.0.0.alpha1+
Build ID: bcbf45d9f94d177c6841ccede3ff0ba69c4f22b1
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-05-04_03:51:16

I believe it is a duplicate of bug 80708 which is fixed now.

*** This bug has been marked as a duplicate of bug 80708 ***
Comment 8 Robinson Tryon (qubit) 2015-12-17 05:51:36 UTC Comment hidden (obsolete)