Bug 72794 - Start Center background with white dotted grid in the right side
Summary: Start Center background with white dotted grid in the right side
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-12-17 15:12 UTC by Carlo Strata
Modified: 2014-01-03 20:13 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
LibreOffice, 4.1.4.2, win32, dotted right Start Center background, on win64 (38.61 KB, image/png)
2013-12-17 15:12 UTC, Carlo Strata
Details
Screenshot illustrating dotted area and incorrect "shadow" gradients (22.83 KB, image/png)
2013-12-17 15:49 UTC, Pedro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carlo Strata 2013-12-17 15:12:05 UTC
Created attachment 90879 [details]
LibreOffice, 4.1.4.2, win32, dotted right Start Center background, on win64

Hi Everyone,

on December the 14th, I install LibreOffice 4.1.4.2 win32 (ITA guied and ITA local help) on my Windows 8.1 (64 bit, updated, ITA guied, AMD Catalyst 13.9, A8 CPU + AMA dual graphics).

After some LibreOffice runs and with my notebook display about 135° opened with respect to the keyboard, I see that the Start Center seems to have a dotted _right_ background (Draw, Database, ... side).

If you take a look with attention to the attached image, you will see a regular white dotted mesh/grid. Its color is only slightly clearer than the Start Center regular/correct background.

I haven't seen/noted at all it in the past time...: is it correct or there were some bug, some runout, some uncontrolled pointer position?

This is the nabble thread in the Global Users mailing list:
http://nabble.documentfoundation.org/LibreOffice-4-1-4-2-win32-seems-to-have-a-dotted-right-Start-Screen-Draw-Database-side-td4088362.html

We have noted that:
- in 4.0 branch the background seems to be ok;
- in 4.1 branch (we are unsure since when) the background seems to be ko (shows the dots);
- under Windows 8.1, x86-64, updated, AMD dual graphics and AMD CPU notebook, it_IT -> ko;
- under Windows XP Pro x86 SP3 en_US -> ko;
- under Ubuntu 12.04.3 LTS laptop running LO 4.1.3.2 -> ok (seems to be good)
- Ubuntu 12.04 also had it but we are not sure which version of LO on that machine (we provide this information in next later comments).

Have a nice day,

Carlo
Comment 1 Pedro 2013-12-17 15:46:41 UTC
Confirmed under Windows 7 x64 using LO 4.1.0.1

It is indeed a regression from branch 4.0
Comment 2 Pedro 2013-12-17 15:49:06 UTC
Created attachment 90881 [details]
Screenshot illustrating dotted area and incorrect "shadow" gradients

The dotted area only occurs on the right half of the Start Center.
Comment 3 Adolfo Jayme 2013-12-20 05:40:10 UTC
I don’t know if somebody would want to spend time on this, since the Start Center was replaced with a new version in 4.2.
Comment 4 Adolfo Jayme 2013-12-25 10:26:26 UTC
WONTFIXing per the above comment — the new start center doesn’t have this bug, as it doesn’t depend on bitmap images for drawing.
Comment 5 Carlo Strata 2014-01-02 20:28:49 UTC
(In reply to comment #4)
> WONTFIXing per the above comment — the new start center doesn’t have this
> bug, as it doesn’t depend on bitmap images for drawing.

Hi Adolfo,

let me say that your reason make me smile and a bit worry too! ;-)

I think we all can really decide not to fix the bug only after we have caught it or at least true understood the cause!

This is because you cannot ignore the effect (!!!) but only the true cause!!!

And if the cause would be in the 4.1.x code that belong to 4.2 branch too???
And more and following your words, now the Start Center doesn’t depend on bitmap images for drawing: so that, if the dotted grid will be only an iceberg top (I mean that could hide a bigger and deeper problem/error/bug)?

Are you really sure that the bug is only in the 4.1.x code and not in the 4.2.x one? If it was caused by a crazy far pointer, for example???

If?

Have a nice 2014!

Carlo
Comment 6 retired 2014-01-03 20:13:25 UTC
Carlo feel free to test 4.2.0.1 http://www.libreoffice.org/download/pre-releases/

and report back. Everybody is welcome to contribute...