Bug 72871 - Libreoffice on Linux Mint missing icons on experimental sidebar
Summary: Libreoffice on Linux Mint missing icons on experimental sidebar
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-19 08:21 UTC by fathuzzaman
Modified: 2015-10-25 18:36 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
windows (left) and linux mint (right) Libre Office sidebar (49.53 KB, image/png)
2013-12-19 08:21 UTC, fathuzzaman
Details
LO sidebar on Mint 17.1 Rebecca and Distro Astro 3.0 Juno (21.21 KB, image/png)
2014-11-29 11:50 UTC, Bamm Gabriana
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fathuzzaman 2013-12-19 08:21:59 UTC
Created attachment 90979 [details]
windows (left) and linux mint (right) Libre Office sidebar

it's missing ever since I'm using Mint 15, and still like that when I fresh installed Mint 16. The buttons and alignments are also a bit messy. I don't know if all Linux experienced that, but on the same machine, my Windows LibreOffice shows it fine.
Comment 1 fathuzzaman 2013-12-19 08:23:40 UTC
didn't know the attachment is for plain text only..
here is the pic:
http://i712.photobucket.com/albums/ww126/Vayth/librewriter_win_lin.png
Comment 2 Maxim Monastirsky 2013-12-19 09:05:12 UTC
Comment on attachment 90979 [details]
windows (left) and linux mint (right) Libre Office sidebar

MIME Type fixed.
Comment 3 Maxim Monastirsky 2013-12-19 09:07:23 UTC
Hi,

Mint icon theme in not part of LibreOffice yet, so you should contact Mint developers instead.
Comment 4 Bamm Gabriana 2014-11-29 11:35:00 UTC
Hi fathuzzaman and Maxim,

I'm the one who made the Mint-X icon theme. I submitted an updated theme to Mint's lead developer Clem and the updated theme is included in Mint 17.1 Rebecca, due to be out in a few days. To fix your issue, simply upgrade your Mint version to Rebecca.

Clem and I both agreed that we should submit the theme upstream to LibreOffice. However, I do not know how to do this.

I know that Ubuntu's theme Human is now part of LibreOffice, and I would like Mint's theme to be part of it too, since Mint is also one of the more popular distros. Aside from Mint, the Distro Astro project, a Linux distro for astronomy based on Mint, also uses this theme.

In fact, I initially developed this for Distro Astro and submitted it upstream to Mint. Therefore, at least two distros will benefit if the theme becomes part of LibreOffice.

Bamm
Comment 5 Bamm Gabriana 2014-11-29 11:50:29 UTC
Created attachment 110220 [details]
LO sidebar on Mint 17.1 Rebecca and Distro Astro 3.0 Juno

Here is how the updated Mint-X theme for LibreOffice looks like. I'll take this bug and any future bugs related to this theme if I succeed in having it added to LibreOffice.
Comment 6 Maxim Monastirsky 2014-11-29 19:00:42 UTC
Hi Bamm,

The addition of a new icon theme, just like any other contribution to LO, preferably should be done by submitting a patch to gerrit. See https://wiki.documentfoundation.org/Development/gerrit for instructions.

Here is a commit that added the breeze theme to LO:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=9ddb055641271aa33fe9f470c739eab9d146a4c6
It will help you understand what you should do. (At least you need to tweak the makefile, the options tab page, the registry entry inside officecfg/, and of course add some icons to icon-themes/.)

@kendy: Hi, I think you should be aware of this.
Comment 7 Bamm Gabriana 2014-11-30 05:45:40 UTC
Thanks Maxim!

Looks complicated, but I will try it. Looking at Breeze link you sent, it seems I need to download the source first, add my changes locally, run diff, and submit the patch, is this correct? Sorry for being a noob. My submissions to Mint have only been by email, and Clem takes care of integrating them.
Comment 8 Maxim Monastirsky 2014-11-30 21:52:18 UTC
(In reply to Bamm Gabriana from comment #7)
> it seems I need to download the source first
Right, but you should do it using git, so you'll get a local copy of the source repo:

$ git clone git://anongit.freedesktop.org/libreoffice/core libreoffice

> run diff, and submit the patch
No. You should commit the changes to your local git repo, and then push them to gerrit using:

$ ./logerrit submit master (where "master" is the branch you're pushing to.)

Then your commit will be added to the review queue, so someone could review it and accept or post comments etc. You can see the current commits pending for review at the web interface - gerrit.libreoffice.org. You can find more information at the wiki.

And just to make things clear: I can't guarantee that it will be accepted into LO, the best I can do is to show you the right way of submitting it.

(And BTW if you'll have any trouble with parts of the commit other than adding the actual icons, or any other questions, just drop me a note.)
Comment 9 Yan Pas 2015-10-25 18:36:32 UTC
I've pumped Mint-X LO icons with Kalahari icons, take a look https://github.com/linuxmint/mint-themes/pull/88