Download it now!
Bug 72875 - Chart: incorrect area of selecting of chart and unplanned cropping image after export
Summary: Chart: incorrect area of selecting of chart and unplanned cropping image afte...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Chart
  Show dependency treegraph
 
Reported: 2013-12-19 09:16 UTC by Mateusz
Modified: 2020-06-12 08:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Source file (76.89 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-12-19 09:16 UTC, Mateusz
Details
[PIC] Differences (29.54 KB, image/png)
2013-12-19 09:21 UTC, Mateusz
Details
exported image (13.32 KB, image/png)
2014-10-15 05:22 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mateusz 2013-12-19 09:16:05 UTC
Created attachment 90983 [details]
Source file

Hey

Open brix.ods file and try move any chart. You will see selecting area of object that is not fitting to real object (area is shorter than object). And if you try export chart to image, LibreOffice will export truncated picture.

Bug exist in 4.2 RC1 as well.
Comment 1 Mateusz 2013-12-19 09:21:14 UTC
Created attachment 90986 [details]
[PIC] Differences
Comment 2 Joel Madero 2014-05-05 05:33:48 UTC
Can't confirm either problems in 4.3 master.

Marking as WFM - if you want to try on master feel free to install from here: http://dev-builds.libreoffice.org/daily/master/

If you can reproduce with master - set to UNCONFIRMED and we'll see who else can test.

Thanks for reporting!
Comment 3 Michał Olber 2014-05-05 08:36:14 UTC
Hi guys
I download this daily build:
http://dev-builds.libreoffice.org/daily/master/win-x86@39/current/master~2014-05-05_06.37.16_LibreOfficeDev_4.3.0.0.alpha1_Win_x86.msi
And after open file brix.ods only last chart at left site called Temperatura is incorrect. After exporting it, it has cutted bottom with legend. I will check other files which I will create on LO 4.2.
Comment 4 Michał Olber 2014-05-05 08:40:21 UTC
Sorry guys for not adding version:
Version: 4.3.0.0.alpha1+
Build ID: 82a623fb08afc72decb78f061b751a43ae503678
TinderBox: Win-x86@39, Branch:master, Time: 2014-05-05_06:37:16
Comment 5 Joel Madero 2014-05-05 15:25:02 UTC
Thanks for the update. Please don't change the version - we look at oldest version where problem exists (therefore we can try to find out who broke it) instead of latest tested on (we just put comments saying that we tested on different versions.

Thanks!
Comment 6 raal 2014-10-14 20:31:39 UTC
I can reproduce with Version: 4.3.4.0.0+
Build ID: afd19a5ee99b1855bc2c2a48a29d2da16be883d1
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-4-3, Time: 2014-10-10_01:47:41
Chart "Temperatura" exported to image is cropped (png).
Comment 7 ign_christian 2014-10-15 03:43:39 UTC
Perhaps particular steps needed to generate the issue (on attached file)? 
I can't reproduce from scratch with 4.3.2.2
Comment 8 raal 2014-10-15 05:22:01 UTC
Created attachment 107850 [details]
exported image

steps to reproduce:
open file brix.ods
select chart "temperatura pracy". Then move the chart.
right click on chart -> export as image
save as .png

See an attachment - legend lost in png image.
Comment 9 ign_christian 2014-10-15 05:31:10 UTC
(In reply to raal from comment #8)
Sorry if I wasn't clear before. I can also reproduce with attached file :)

But tried to repro from scratch with my own sample, I can't reproduce that (only tried with 1 chart, not tried yet with many charts in same sheet).
Comment 10 raal 2014-10-15 17:11:20 UTC
(In reply to ign_christian from comment #9)
> (In reply to raal from comment #8)
> Sorry if I wasn't clear before. I can also reproduce with attached file :)
> 
> But tried to repro from scratch with my own sample, I can't reproduce that
> (only tried with 1 chart, not tried yet with many charts in same sheet).

I'm unable to reproduce the problem from scratch with the same data as in testing file brix.ods.

@Mateusz: Can you reproduce the error in another file?
Comment 11 Mateusz 2014-10-15 18:34:43 UTC
Hey guys

The answer is NO. Currently I am working on my own data set and everything is ok. Any new Calc file can not reproduce the same erroneous behavior. 

I reported this bug on behalf of @Michał Olber so I will ask him about more info.
Comment 12 QA Administrators 2015-12-20 16:13:29 UTC Comment hidden (obsolete)
Comment 13 QA Administrators 2017-01-03 19:48:42 UTC Comment hidden (obsolete)
Comment 14 QA Administrators 2019-12-03 14:13:40 UTC Comment hidden (obsolete)
Comment 15 Timur 2020-06-12 08:42:02 UTC
An oldie seems not to be there anymore from long ago.