Bug Hunting Session
Bug 72971 - Alphabetical index for documents structured with chapters and their own page numbers is incorrect
Summary: Alphabetical index for documents structured with chapters and their own page ...
Status: RESOLVED DUPLICATE of bug 60616
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: All Windows (All)
: low normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-22 14:13 UTC by Pit Zaclade
Modified: 2016-01-24 16:06 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
example for corrupt index in a document with chapter and ist own page numbers (2.00 MB, application/vnd.oasis.opendocument.text)
2013-12-23 15:05 UTC, Pit Zaclade
Details
another simplified example for the useless index (23.88 KB, application/vnd.oasis.opendocument.text)
2014-01-06 13:27 UTC, Pit Zaclade
Details
modified simplified example for the useless index (22.83 KB, application/vnd.oasis.opendocument.text)
2014-01-10 12:38 UTC, Pit Zaclade
Details
PDF export of indices using 4.4.0.0 alpha1 from Nov 02 (102.71 KB, application/pdf)
2014-11-02 15:09 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pit Zaclade 2013-12-22 14:13:22 UTC
I have a document parted in chapters. Every chapter has its own page numbers (chapter 1 with page 1, 2, 3 and so on, chapter 2 with page 1, 2, 3 and so on). So it is necessary that alphabetical index indicates all finds with chapter and page, e.g „chapter 1 – page 1, 3, 7, chapter 9 – page 3, 8“.

But this is not possible!
I have found, that the alphabetical index only lists the first found chapter combined with all found pages, but without any correct chapters, e.g. „ chapter 1.2 p 3, 4, 8, 9“ . (But chapter 1.2 has no page 9, but the chapter 7.6 has it, for example.)

If I want no pages, than the finds are not complete, only the first found chapter
is listen.

I am feeling that there is no solution for my problem?
Comment 1 Pit Zaclade 2013-12-22 16:02:32 UTC
This bug is particularly identical with the insolved <b> bug 60616 </b>
with 'Combine identical entries' is checked.

But I see there are two different bugs:
1. The output gives only the first found chapter, not the others
2. The output gives not combination of chapter and page, what is essential if chapters have its own page numbers
Comment 2 retired 2013-12-23 12:48:18 UTC
Hi Pit, could you attach an example document so this could be experimented with? If your document contains confidential info, just replace it with some random jabberjabber talk.

I'm unsure if there is a solution thus adding keyword NeedAdvice. If there indeed is no solution I guess this here would be a valid enhancement request.
Comment 3 Pit Zaclade 2013-12-23 15:05:18 UTC
Created attachment 91155 [details]
example for corrupt index in a document with chapter and ist own page numbers
Comment 4 Pit Zaclade 2013-12-23 15:17:26 UTC
(In reply to comment #3)
> Created attachment 91155 [details]
> example for corrupt index in a document with chapter and ist own page numbers

The attaches document is in german, sorry, I also.
This ist a text for kitchen.

Kap. = Kapitel = chapter
S. = p. = page

The index has an entry "Milch" = milk. This is oblige and often in the text, but the indicated chapter is not the first and not single with milk and the indicated page numbers are not correlated with any chapter number and therefore not useful, bacause every chapter has a page 1, 2, ...
Comment 5 Pit Zaclade 2014-01-06 13:27:16 UTC
Created attachment 91540 [details]
another simplified example for the useless index

This example is in English. The chapters in this document have own numerated page numbers. Why do the page numbers start in every chapter new? Only this makes it possible to complete parts (recipes) without to destroy or modify the sub chapter numbers. 
In this example some simple entries exist for alphabetical index, no concordance list is used.

The alphabetical index shows the entries, but the index is useless while the listed page numbers are without any relation to the chapters, so that nobody can see for example on which page 2 from which chapter he can found the entry.
Comment 6 Pit Zaclade 2014-01-10 12:21:27 UTC
The problem is greater as I have reported. In the example file the entry "orange" is in the chapter line itself, but it is not listed in the alphabetical index!
Comment 7 Pit Zaclade 2014-01-10 12:38:43 UTC
Created attachment 91815 [details]
modified simplified example for the useless index

This example is in English. The chapters in this document have own numerated page numbers. Why do the page numbers start in every chapter new? Only this makes it possible to complete parts (=recipes) without to destroy or modify the sub chapter numbers.
In this example file some entries exist and a alphabetical index at the bottom, no concordance list is here used.

The alphabetical index shows the entries, but the index is useless while the listed page numbers are without any relation to the chapters, so that nobody can see for example on which page 2 from which chapter he can found the entry.

Second, the entry "orange" in the sub chapter 1.3 itself is not found at chapter!?
Comment 8 Robinson Tryon (qubit) 2014-02-03 13:51:08 UTC
(In reply to comment #0)
> I have a document parted in chapters. Every chapter has its own page numbers
> (chapter 1 with page 1, 2, 3 and so on, chapter 2 with page 1, 2, 3 and so
> on). So it is necessary that alphabetical index indicates all finds with
> chapter and page, e.g „chapter 1 – page 1, 3, 7, chapter 9 – page 3, 8“.
> 
> But this is not possible!
> I have found, that the alphabetical index only lists the first found chapter
> combined with all found pages, but without any correct chapters, e.g. „
> chapter 1.2 p 3, 4, 8, 9“ . (But chapter 1.2 has no page 9, but the chapter
> 7.6 has it, for example.)

Hi Pit,

Thanks for filing a bug and providing an example document -- that makes our life much easier!

Is your alphabetical index implemented completely as a macro, or using the built-in tools?
https://help.libreoffice.org/Writer/Creating_Alphabetical_Indexes

(Please change the bug Status back from 'NEEDINFO' to 'UNCONFIRMED' when you've finished your reply)


Thanks!

Whiteboard: (remove NeedAdvice)
Comment 9 Pit Zaclade 2014-02-03 17:03:58 UTC
I am using only the built-in tools for index.
Comment 10 Joel Madero 2014-07-10 01:39:10 UTC
Not a major bug - lowering to:

Normal: Can prevent high quality/professional work
Low: Not a feature that will affect the average user, lowered from medium to low

For reference please see: 

https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 11 Buovjaga 2014-11-02 15:09:17 UTC
Created attachment 108794 [details]
PDF export of indices using 4.4.0.0 alpha1 from Nov 02

I don't know, if this is correct or not, but this is how it looks like in the latest alpha.

Win 7 64-bit Version: 4.4.0.0.alpha1+
Build ID: b167d1127e1579468a74c4414e7f4f33d9d24122
TinderBox: Win-x86@51-TDF, Branch:MASTER, Time: 2014-11-02_03:04:44
Comment 12 Hal 2015-02-24 20:11:33 UTC
Any idea when these two bugs (Bugs 7291, 60616) will be fixed in the software?  I need the Alpha Index feature to work properly for my project.  Thanks.
Comment 13 Joel Madero 2015-02-25 15:18:32 UTC
@Hal - unlikely to be any time soon. 

http://joelmadero.wordpress.com/2014/10/11/user-expectations-and-the-reality-of-our-community/

Options:
1) Submit a patch yourself;
2) Find a friend, family member, etc... to submit a patch;
3) Pay for a fix;
4) Wait patiently until a volunteer chooses to fix it.
Comment 14 Robinson Tryon (qubit) 2015-02-25 20:57:41 UTC
(In reply to Hal from comment #12)
> Any idea when these two bugs (Bugs 7291, 60616) will be fixed in the
> software?

Hal: Beluga had some insights in comment #11. Did any of that help?

Status -> NEEDINFO
Comment 15 Hal 2015-02-26 00:06:20 UTC
(In reply to Robinson Tryon (qubit) from comment #14)
> (In reply to Hal from comment #12)
> > Any idea when these two bugs (Bugs 7291, 60616) will be fixed in the
> > software?
> 
> Hal: Beluga had some insights in comment #11. Did any of that help?
> 
> Status -> NEEDINFO

Robinson - I don't think the PDF export suggestion helps my particular issue.  In my case, I have multiple instances of Alpha Index entries in multiple chapters, but they are not shown in my updated Alpha Index.  The PDF export example in Beluga's "insight" also doesn't show multiple chapter entries for a given index entry (assuming there are some).  However, I thank you for your comments.  I appreciate it.
Comment 16 Hal 2015-02-26 00:19:52 UTC
(In reply to Joel Madero from comment #13)
> @Hal - unlikely to be any time soon. 
> 
> http://joelmadero.wordpress.com/2014/10/11/user-expectations-and-the-reality-
> of-our-community/
> 
> Options:
> 1) Submit a patch yourself;
> 2) Find a friend, family member, etc... to submit a patch;
> 3) Pay for a fix;
> 4) Wait patiently until a volunteer chooses to fix it.

Joel - Thank you for your comments and link.  I appreciate your input.  I would gladly help, but I would have to learn the source code scheme (algorithms, etc.) currently used in 4.4.0.3.  I would also have to learn the programming language used.  Being an obsolete software/hardware guy I would end up spinning my wheels and likely end up with no improvement to the source code.  I guess I'll have to wait for someone with the ability and inclination to fix the bug.  However, I do suggest a cautionary note be added to the user manual informing prospective users that indexing using the [chapternumber.pagenumber] scheme does not work.  A cautionary note might save someone a lot of wasted time.
Comment 17 Hal 2015-02-26 01:00:00 UTC
See my Comment 15 in reply "for more information or data".
Comment 18 Jean-Baptiste Faure 2016-01-24 16:06:35 UTC
(In reply to Beluga from comment #11)
> Created attachment 108794 [details]
> PDF export of indices using 4.4.0.0 alpha1 from Nov 02
> 
> I don't know, if this is correct or not, but this is how it looks like in
> the latest alpha.

No, it is not correct:
- Beaujolais: there is no page 7 in chapter 5
- Orange: index gives ch 6.3 but Orange does not appear in chapter 6.3, except that this chapter contains the ToC too in which there is Orange as is in the title of chapter 1.3.

This bug report is about the erroneous build of index when the page numbering is relative to the chapter number. From this point of view, and as it is said in comment #1, it is a duplicate of bug 60616.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 60616 ***