Download it now!
Bug 73048 - UI: Thai font does not display properly
Summary: UI: Thai font does not display properly
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-26 20:07 UTC by Sombat Charnchaleo
Modified: 2015-03-15 17:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
table display from version 3.x and 4.1.x that show the problem (15.25 KB, image/png)
2013-12-26 20:07 UTC, Sombat Charnchaleo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sombat Charnchaleo 2013-12-26 20:07:56 UTC
Created attachment 91200 [details]
table display from version 3.x and 4.1.x that show the problem

Problem description: 
Thai font does not display properly in Table/Query window data display. 


Steps to reproduce:
1. use JDBC to connect to database 
2. open table

Current behavior:
The characters were displayed, but all the vowel sign disappeared.

Expected behavior:
The vowel sign display properly.

My solution:
Change display font for table/query to Thai-suitable font. I think the default is something Hindi...
              
Operating System: Ubuntu
Version: 4.1.3.2 release
Comment 1 Julien Nabet 2014-08-27 21:35:44 UTC
Any update with more recent LO version?
For your information, you may find more recent LO version here:
https://launchpad.net/~libreoffice/+archive/ubuntu/ppa
Comment 2 tommy27 2014-09-27 14:09:18 UTC
set status to NEEDINFO waiting for user feedback using a more recent LibO release like 4.2.6.2 or 4.3.2.2
Comment 3 Alex Thurgood 2015-01-03 17:41:24 UTC
Adding self to CC if not already on
Comment 4 Julien Nabet 2015-03-15 17:28:04 UTC
No feedback since more than 6 months, let's put this one to WFM.

Sombat: don't hesitate to reopen this tracker if you can reproduce this on a recent LO version (4.4.1 and 4.3.6 are last ones)