Bug 73114 - gerrit: libreoffice logo and header overlap the search box when not logged in
Summary: gerrit: libreoffice logo and header overlap the search box when not logged in
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-29 10:13 UTC by Korrawit Pruegsanusak
Modified: 2015-08-13 14:21 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screenshot (8.86 KB, image/png)
2013-12-29 10:13 UTC, Korrawit Pruegsanusak
Details
screenshot with possible related problem (173.54 KB, image/png)
2014-01-11 08:41 UTC, Winfried Donkers
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Korrawit Pruegsanusak 2013-12-29 10:13:27 UTC
Created attachment 91273 [details]
screenshot

Problem: In gerrit site https://gerrit.libreoffice.org/ when not logged in, the middle header -- libreoffice logo with the word "Code Review" -- overlaps the search box in the right.

Please see screenshot.

Assign to me because I'm working on this.
Comment 1 Korrawit Pruegsanusak 2013-12-29 10:24:37 UTC
Patch submitted to https://gerrit.libreoffice.org/7225
Comment 2 Norbert Thiebaud 2014-01-10 23:39:14 UTC
can you show an after picture... and especially an after picture _when_ one is logged in.. since that is the interesting case...

I do not mind picking the patch.. but since I do not see that problem
here, even not logged in.. it is hard to tell.

actually playing with it.. it seems that the overlap occurs regardless of the log in status.. it is just a question of how wide is the display space...
so a better solution maybe would be to make the 'logo' section be 'transparent'
or otherwise in the 'background'  (note I do not know what is possible with css, and the term I used to describe things are not necessarily the relevant concept in css)
or any other solution that would 'scale'
the propose patch seems to just to hide the problem for a specific size of window...
Comment 3 Winfried Donkers 2014-01-11 08:41:11 UTC
Created attachment 91853 [details]
screenshot with possible related problem

Attached screenshot shows missing scrollbar in code pane, as well as overlapping logo.
Changing the width of the webbrowser window makes the scrollbars appear.
If related, it would be nice to check against the patch as well.
Comment 4 Korrawit Pruegsanusak 2014-03-09 05:52:19 UTC
First, sorry for very late reply.

If we want to get the logo at the same point (topmost, in the middle), I still can't figure out how to do it properly. However, what I've found are:

1. We can make it "looks" transparent, by changing "background-color: #ffffff" to "background-color: transparent" in GerritSite.css.

BUT, this only hides the problem, because the logo is still on top, not really in the back, ie. you can't click in the search box in overlapping area.


2. We can add and run javascript in the header, by adding the code snippets into GerritSiteHeader.html. I thought that the code should check the width of class "topmenuTDglue", which has the only element between left-sided menu and right-sided search box, and then adjust the logo size as following its width.

The example code, add this to GerritSiteHeader.html:
> <script type="text/javascript">
>   e = document.getElementsByClassName("topmenuTDglue").item(0).getBoundingClientRect();
>   // More info at https://developer.mozilla.org/en-US/docs/Web/API/element.getBoundingClientRect
> </script>

BUT, all the pages are loaded in javascript manner, including "topmenuTDglue", (to prove this: view the real source of page, not from developer console). So our script might run *before* the page loaded successfully -> the script couldn't find the element and return null.

----

Or, we should move it to another place, as Bjoern suggested in https://gerrit.libreoffice.org/7225


Also, I'm sorry to say that I don't have time to fix this bug anymore. So, I put this back to NEW and un-assigned myself.

@Winfried, Yes, I also encountered that problem, but (1) I don't think that's the same problem with this bug, and (2) I didn't check if it's resolved or not. :\
Comment 5 Joel Madero 2015-05-02 15:42:36 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02
Comment 6 Winfried Donkers 2015-05-04 06:27:33 UTC
AFAICS the problems are no longer there and this bug report can be closed as resolved.