Download it now!
Bug 73143 - Java null pointer exception when loading SmartDiagram extension
Summary: Java null pointer exception when loading SmartDiagram extension
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-30 11:24 UTC by Alex Thurgood
Modified: 2017-08-23 07:40 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2013-12-30 11:24:03 UTC
On master 4.3 alpha pulled and built on 29/12/2013 with

--enable-ext-diagram

1) Start LO /instdir/program/soffice
2) Click on new Drawing
3) Click on SmartDiagram extension button.

Console output :

warn:legacy.osl:12872:1:unotools/source/config/moduleoptions.cxx:635: unknown factory
warn:legacy.osl:12872:1:toolkit/source/helper/listenermultiplexer.cxx:143: ItemListenerMultiplexer::itemStateChanged: caught an exception!
[jni_uno bridge error] UNO calling Java method callHandlerMethod: non-UNO exception occurred: java.lang.NullPointerException
java stack trace:
java.lang.NullPointerException
	at oxygenoffice.extensions.smart.Gui.setGalleryDialogText(Gui.java:323)
	at oxygenoffice.extensions.smart.Gui.setGalleryDialogText(Gui.java:287)
	at oxygenoffice.extensions.smart.Listener.callHandlerMethod(Listener.java:265)
	at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
	at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java:183)
	at com.sun.proxy.$Proxy29.selectItemPos(Unknown Source)
	at oxygenoffice.extensions.smart.Gui.createDiagramGallery2(Gui.java:231)
	at oxygenoffice.extensions.smart.Gui.executeGalleryDialog(Gui.java:191)
	at oxygenoffice.extensions.smart.Controller.executeGalleryDialog(Controller.java:175)
	at oxygenoffice.extensions.smart.SmartProtocolHandler.dispatch(SmartProtocolHandler.java:117)

warn:legacy.osl:12872:1:toolkit/source/helper/listenermultiplexer.cxx:143: ItemListenerMultiplexer::itemStateChanged: caught an exception!
[jni_uno bridge error] UNO calling Java method callHandlerMethod: non-UNO exception occurred: java.lang.NullPointerException
java stack trace:
java.lang.NullPointerException
	at oxygenoffice.extensions.smart.Gui.setGalleryDialogText(Gui.java:323)
	at oxygenoffice.extensions.smart.Gui.setGalleryDialogText(Gui.java:287)
	at oxygenoffice.extensions.smart.Listener.callHandlerMethod(Listener.java:265)
	at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
	at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java:183)
	at com.sun.proxy.$Proxy29.selectItemPos(Unknown Source)
	at oxygenoffice.extensions.smart.Gui.createDiagramGallery2(Gui.java:231)
	at oxygenoffice.extensions.smart.Gui.executeGalleryDialog(Gui.java:191)
	at oxygenoffice.extensions.smart.Controller.executeGalleryDialog(Controller.java:175)
	at oxygenoffice.extensions.smart.SmartProtocolHandler.dispatch(SmartProtocolHandler.java:117)

warn:legacy.tools:12872:1:toolkit/source/helper/unowrapper.cxx:176: UnoWrapper::SetWindowInterface: there already *is* a WindowInterface for this window!
warn:legacy.tools:12872:1:toolkit/source/awt/vclxtoolkit.cxx:1147: VCLXToolkit::createWindow: did #133706# resurge?
Comment 1 Julien Nabet 2013-12-30 17:50:51 UTC
On pc Debian x86-64 with master sources updated today, I can reproduce this.
However, SmartDiagram seems to work since the window which allows to insert diagrams appears.

Stephan: Uno/Java related, one for you?
Comment 2 Stephan Bergmann 2014-01-06 10:34:32 UTC
--enable-ext-diagram uses pre-built <http://ooo.itc.hu/oxygenoffice/download/libreoffice/8d74685d41f8bffe8c3e71fe8deac09d-SmART_0.9.5.oxt> that apparently contains a (harmless?) bug that causes that log output.  Something for KAMI to look into, I assume.
Comment 3 Julien Nabet 2014-09-02 20:02:03 UTC
I noticed 2 versions on the website:
1) http://ooo.itc.hu/oxygenoffice/download/extensions/
filename: SmART_0.9.5.0.oxt
date: 07-Aug-2012 16:01
size: 1152824
2) http://ooo.itc.hu/oxygenoffice/download/libreoffice/
filename: 8d74685d41f8bffe8c3e71fe8deac09d-SmART_0.9.5.oxt
date: 29-Nov-2011 22:19
size: 948330

Kami: any update?
Comment 4 QA Administrators 2015-04-01 14:47:24 UTC Comment hidden (obsolete)
Comment 5 Alex Thurgood 2015-04-01 17:08:59 UTC
The NEEDINFO was to Kami, the developer of the extension, not the original bug submitter (me). I don't know whether he's still part of the LO project.
Comment 6 Alex Thurgood 2015-04-01 17:15:38 UTC
In lldb, I still see this, even though the extension appears to work at least for the initial drawing of a hierarchy diagram :

warn:stoc:54720:1:stoc/source/inspect/introspection.cxx:1645: object of type "com.sun.star.uno.XInterface" lacks XTypeProvider
warn:legacy.osl:54720:1:toolkit/source/helper/listenermultiplexer.cxx:152: ItemListenerMultiplexer::itemStateChanged: caught an exception!
[jni_uno bridge error] UNO calling Java method callHandlerMethod: non-UNO exception occurred: java.lang.NullPointerException
java stack trace:
java.lang.NullPointerException
	at oxygenoffice.extensions.smart.Gui.setGalleryDialogText(Gui.java:323)
	at oxygenoffice.extensions.smart.Gui.setGalleryDialogText(Gui.java:287)
	at oxygenoffice.extensions.smart.Listener.callHandlerMethod(Listener.java:265)
	at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
	at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java:185)
	at com.sun.proxy.$Proxy29.selectItemPos(Unknown Source)
	at oxygenoffice.extensions.smart.Gui.createDiagramGallery2(Gui.java:231)
	at oxygenoffice.extensions.smart.Gui.executeGalleryDialog(Gui.java:191)
	at oxygenoffice.extensions.smart.Controller.executeGalleryDialog(Controller.java:175)
	at oxygenoffice.extensions.smart.SmartProtocolHandler.dispatch(SmartProtocolHandler.java:117)

warn:legacy.osl:54720:1:toolkit/source/helper/listenermultiplexer.cxx:152: ItemListenerMultiplexer::itemStateChanged: caught an exception!
[jni_uno bridge error] UNO calling Java method callHandlerMethod: non-UNO exception occurred: java.lang.NullPointerException
java stack trace:
java.lang.NullPointerException
	at oxygenoffice.extensions.smart.Gui.setGalleryDialogText(Gui.java:323)
	at oxygenoffice.extensions.smart.Gui.setGalleryDialogText(Gui.java:287)
	at oxygenoffice.extensions.smart.Listener.callHandlerMethod(Listener.java:265)
	at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
	at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java:185)
	at com.sun.proxy.$Proxy29.selectItemPos(Unknown Source)
	at oxygenoffice.extensions.smart.Gui.createDiagramGallery2(Gui.java:231)
	at oxygenoffice.extensions.smart.Gui.executeGalleryDialog(Gui.java:191)
	at oxygenoffice.extensions.smart.Controller.executeGalleryDialog(Controller.java:175)
	at oxygenoffice.extensions.smart.SmartProtocolHandler.dispatch(SmartProtocolHandler.java:117)

warn:stoc:54720:1:stoc/source/inspect/introspection.cxx:1645: object of type "com.sun.star.uno.XInterface" lacks XTypeProvider
Comment 7 Jean-Baptiste Faure 2016-01-24 16:11:18 UTC
The status of this bug report should have been set back to NEW instead of UNCONFIRMED. See comment #1 and history.

Best regards. JBF
Comment 8 QA Administrators 2017-03-06 14:30:17 UTC Comment hidden (obsolete)
Comment 9 Julien Nabet 2017-08-22 20:53:29 UTC
Alex: I don't see anymore --enable-ext-diagram in configure.ac.
Did I miss something or can we close this one?
Comment 10 Alex Thurgood 2017-08-23 07:40:49 UTC
Extension has been dropped from build options, closing.