Download it now!
Bug 73212 - Impress crashes when converting PPTX to PDF
Summary: Impress crashes when converting PPTX to PDF
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86-64 (AMD64) All
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: preBibisect, regression
Depends on:
Blocks:
 
Reported: 2014-01-02 06:17 UTC by Vikram
Modified: 2015-12-29 11:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
single slide test case (1.58 MB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2014-01-02 16:45 UTC, tommy27
Details
Sample PPTX crashes while converting to PDF using Libre Office Impress (2.41 MB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2014-01-03 07:35 UTC, Vikram
Details
PPTX carsing using Libre Office Img (316.19 KB, image/png)
2014-01-07 03:38 UTC, Vikram
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vikram 2014-01-02 06:17:50 UTC
Hello All

I am trying to convert some heavy PPTX file (more than 5 MB - lots of images) having more than 200 slides to PDF. But the Libre Office gets crashed.

Tried options like increasing Memory cache to 256 MB, number of objects and object removal time from memory. Tried all options, but editor crashes every time while converting PPTX to PDF.

Urgent help is required to fix this issue, is really appreciated.

Regards
Vikram Jain
Comment 1 retired 2014-01-02 10:30:12 UTC
Hi Vikram,

can you please provide a test document so this can be tested against and subsequently be confirmed. If your document contains sensitive data, please clear that or replace it with random information. (if your document is to large for this tracker just use a file upload service)

A step-by-step description of how to reproduce the issue is most helpful and will help to speed up the processing of this problem a lot.

Setting to NEEDINFO until more detail is provided.

After providing the requested info, please reset this bug to UNCONFIRMED. Thanks :)
Comment 2 Vikram 2014-01-02 13:35:10 UTC
Hello Foss

Steps to produce the issue::
1. Take a pptx document, add 4-5 images to 1 slide 
2. Then copy paste the slide 200 time
3. Save the pptx
4. Open Libre Office Impress, convert the pptx to PDF
5. office crashes around at 65% mark completion every time

Regards
Vikram Jain
Comment 3 tommy27 2014-01-02 14:05:43 UTC
@Vikram
please specify your O/S and which LibO version do you experience the bug.
Comment 4 tommy27 2014-01-02 14:07:42 UTC
moreover try reducing your file to a minimal version in which you still experience the crash... I mean, create a backup copy then erare the last 100 slides and try to export to PDF.

if it still crash, try reducing it to 50 slide and see what happens.

once you have a minimal test case, try uploading it here.
Comment 5 Vikram 2014-01-02 14:16:16 UTC
I am using Windows 64 bit machine
Libre Office Version 4.1.4

Crash observed when slides are more than 150 in number.
Comment 6 tommy27 2014-01-02 14:28:02 UTC
(In reply to comment #5)
> I am using Windows 64 bit machine
> Libre Office Version 4.1.4

OK. I put this in version field (next time you open a bug report remember to indicate the version you are using).

> Crash observed when slides are more than 150 in number.

so basically 149 doesn't crash and 150 do crash?
Comment 7 tommy27 2014-01-02 16:45:51 UTC
Created attachment 91426 [details]
single slide test case

I still do not reproduce the issue.

I created a single slide PPTX with 4 images inside it.
I replicated that slide to obtain a 201 slides PPTX and saved it (300 MB)
Export to PDF works, take a few minutes but does not crash.

I attach that single slide, try doing the same and see if you still reproduce the crash.

maybe the bug is file specific and happens just with your PPTX.
Comment 8 Vikram 2014-01-03 07:35:46 UTC
Created attachment 91450 [details]
Sample PPTX crashes while converting to PDF using Libre Office Impress

Hello All

Sample PPTX crashes while converting to PDF using Libre Office Impress attached.
Please copy the slide 200 times (as size was too large so 1 slide here). In each upload a image of 600 KB was there which was removed due to uploading capacity restriction.

Urgent help, is relayy appriciated

Regards
Vikram
Comment 9 tommy27 2014-01-03 07:51:45 UTC
your test file has something wrong... it opens in Writer showing a single line with: "<## NASCA DRM FILE - VER1.00 ##>Â(¿Áƒ%##3 #k¦Â#¢”###„ÍÞr%³útÖ<## NASCA DRM FILE - VER1.00 ##>Â(¿Áƒ%##3 #k¦Â#¢”###„ÍÞr%³útÖ"

try uploading it again, maybe it got corrupted.
Comment 10 tommy27 2014-01-03 07:52:46 UTC
by the way, did you tey my test file? does it crashes your PC?
Comment 11 Pierre C 2014-01-03 09:52:59 UTC
A workaround could be to download an install the powerpoint viewer and an PDF printer
Comment 12 Vikram 2014-01-07 03:38:39 UTC
Created attachment 91574 [details]
PPTX carsing using Libre Office Img

Hello

I have attach a png image which consist of slide show. After 6th slide, 1 sts slide is repeated from 7th to 200th slide. Libre Office crashes while converting this pptx to PDF.

While debugging pptx, it seems after 140th slide, the conversion fails. If pptx has 140th slide with above material, it works fine, above that it crashes, with error "bad alloc"

Regards
Viks
Comment 13 Vikram 2014-01-07 08:43:26 UTC
Hello Cor

I tested your file, it does not crashes, copied it 10-200 times, different combinations, it works fine.

Regards
Viks
Comment 14 tommy27 2014-01-07 13:18:36 UTC
so problem must be specific to your file.
please send that PPTX so we can test.
if it's too large, just post the first 6 slides or use some webhosting site.
Comment 15 Vikram 2014-01-14 06:16:00 UTC
Hello

Please suggest, some Server on which large file can be uploaded(to use a file upload service). 

Regards
Viks
Comment 16 tommy27 2014-01-14 06:24:42 UTC
http://www.sendspace.com/
Comment 17 Vikram 2014-01-14 06:50:43 UTC
Hello

PPTX file which cannot be converted is uploaded at following link, http://www.sendspace.com/file/rrwok3 . When converting to PDF using Libre Office, it crashes. Urgent help is appreciated.

Regards
Viks
Comment 18 Vikram 2014-01-14 06:52:23 UTC
Hello

When file has been downloaded, pls let me know, as i need to delete it.

Regards
Viks
Comment 19 tommy27 2014-01-14 09:41:59 UTC
I confirm crash with test file with 4.1.4.2 under Win7 64bit.
Comment 20 tommy27 2014-01-14 12:38:23 UTC
@Vikram
that file is very big 200 slides.
I suggest trying to reduce it to the minimal number of slides where the bug is still reproducible...

developers job will be easier if you remove redundant parts that do not cause the crash.
Comment 21 Vikram 2014-01-14 12:40:52 UTC
Hello

Crash is visisble after 140th slide, i cannot attach reduce file, as it gets encrypted, which yu wont be able to open. Since received this file from some, passed yu as it is.

Regards
Viks
Comment 22 Maxim Monastirsky 2014-01-14 13:10:06 UTC
(In reply to comment #12)
> above that it crashes, with error "bad alloc"
Sounds like too much memory to allocate for a 32-bit app (LO itself is 32-bit, even if Windows is 64-bit, see Bug 61683). That explains why it's reproducible only with a very big file.
Comment 23 tommy27 2014-01-14 20:37:00 UTC
@Maxim Monastirsky  
I'm not sure that's it's all about 32-bit.
OOo 3.3.0 on my PC doesn't crash with that file: PDF conversion is slow but successful. LibO 3.3.3 does not crash as well

LibO 3.4.3, 3.6.7 and 4.1.4 crash.
so it's a LibO bug. an early regression.
Comment 24 Maxim Monastirsky 2014-01-14 21:34:50 UTC
(In reply to comment #23)
> I'm not sure that's it's all about 32-bit.
> OOo 3.3.0 on my PC doesn't crash with that file: PDF conversion is slow but
> successful. LibO 3.3.3 does not crash as well
Sure, but maybe in that version LO used some memory allocation scheme that didn't raise the limits in that case, and that changed with later versions. "bad alloc" means not able to allocate more memory.
Comment 25 Björn Michaelsen 2014-01-17 00:43:24 UTC
(This is an automated message.)

LibreOffice development currently prioritizes bugs with the so called MAB (most annoying bugs) -- as this bug has not run through that process (including writing a short rationale for this bug being a candidate and other who are watching the tracker bug silently approving that rationale etc.) its priority is set to high. Note this is effectively no change in the urgency assigned to this bug, as we are currently not making a difference between high and highest and severity is untouched.

You can find out more about MABs and how the process works by contacting libreoffice qa on irc:

 http://webchat.freenode.net/?channels=libreoffice-qa

The QA wiki page also gives you hints on how to get in contact with the team (if IRC fails you, your next best choice is the mailing list):

 https://wiki.documentfoundation.org/QA
Comment 26 Michael Meeks 2015-06-08 14:40:09 UTC
This is rather an old bug; significant work has been done to improve memory management, and swapin/out lifecycle in LibreOffice 4.4 - it would be great to see if this problem  still reproducible in a modern LibreOffice version (also ideally if that file with the 200x image slides could be attached it'd be great. If the images are the same the ultimate file size should be small since the images should be de-duplicated to just 1 copy each).

Thanks!
Comment 27 Robinson Tryon (qubit) 2015-12-14 05:40:00 UTC
Migrating Whiteboard tags to Keywords: (preBibisect)
[NinjaEdit]
Comment 28 Julien Nabet 2015-12-29 11:25:59 UTC
http://www.sendspace.com/file/rrwok3 is obsolete so impossible to test.

Let's put this to RESOLVED/INSUFFICIENTDATA.
Vikram: don't hesitate to reopen this tracker if you still reproduce this with recent LO version (5.0.4 is last stable one).