Bug 73301 - UI: font not changes after font substitution
Summary: UI: font not changes after font substitution
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-05 13:12 UTC by jpka
Modified: 2014-03-02 19:18 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
LibO 4.1.4.2 shows all UI with unknown wrong font, while all other apps use system font Terminus (116.68 KB, image/png)
2014-01-06 21:18 UTC, jpka
Details
screenshot with working solution (117.17 KB, image/png)
2014-01-09 14:27 UTC, Maxim Monastirsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jpka 2014-01-05 13:12:12 UTC
Problem description: 
Changing UI (User interface) font via font substitution not work in version LibO 4.1.4.2, but known to work in LibO 3.5.7.2 and all versions before it, include OpenOffice 1.1.5.

Steps to reproduce:
1. Read how to change UI font https://wiki.openoffice.org/wiki/Font-FAQ#How_can_I_change_OpenOffice.org_2.27s_user_interface_font.3F
2. Select 'Andale sans UI' at left, and say 'Freemono' at right
3. Apply (add or update) rule
4. Reload 'libreoffice' and see nothing changes in UI font.
5. Try to check and uncheck 'Use system font for user UI' and see nothing changes again. Font used for UI always same, unknown, and wrong.
6. Try to do it with LibO 3.5.7.2 and see UI font changes.

Current behavior:
UI font not changes via font substitution.

Expected behavior:
UI font should be changeable.

Please note, i report about LTS version of Ubuntu ("Ubuntu 12.04.3 LTS").

Additional reading: http://ask.libreoffice.org/en/question/27630/how-to-fix-user-interface-font-in-ubuntu/

Thanks!              
Operating System: Ubuntu
Version: 4.1.4.2 release
Comment 1 Adolfo Jayme 2014-01-06 03:09:05 UTC
FWIW, LibreOffice has removed the use of the font "Andale Sans UI". The guide you've read at OpenOffice's wiki is super obsolete, and you should attach an screenshot of what you're seeing on screen, LibreOffice should match the font set for your OS's desktop environment.
Comment 2 jpka 2014-01-06 21:18:56 UTC
Created attachment 91564 [details]
LibO 4.1.4.2 shows all UI with unknown wrong font, while all other apps use system font Terminus

I attach screenshot.
I use stone-age manuals because i can't found more up-to-date guide how to change UI font for LibO or force it to really use system font (correspond checkbox not work). Thanks.
Comment 3 Adolfo Jayme 2014-01-07 11:33:35 UTC
Can you check if the version of the Terminus font you use is in a modern format, i.e. TTF or OTF? If you’re trying to use the old X bitmap font, I don’t think LibreOffice supports it.
Comment 4 jpka 2014-01-08 06:32:37 UTC
I use bitmap Terminus, and definetely need exactly bitmap font for all UI for all software, to get rid off of any hinting / antialiasing / smoothing / etc. because no any software can do it better than human. Terminus font shows exactly pixel-precisely as it was created by human. Furthermore, *any* other software use it (include for UI) just fine. It is a serious bug if LibO can't use bitmap font for UI, and immediately turn the software from professional tool to no more than (very good) toy.
Is somewhere oficially clearly stated that LibO can't use PCF fonts for UI?
BTW, this particularly bug is not exactly about Terminus font, this report is for TTF (freemono) font, please see 'steps to reproduce'. For Terminus, i file the bug #73303. 
Thank you so much!
Comment 5 Maxim Monastirsky 2014-01-08 07:43:35 UTC
(In reply to comment #0)
> 1. Read how to change UI font
> https://wiki.openoffice.org/wiki/Font-FAQ#How_can_I_change_OpenOffice.org_2.
> 27s_user_interface_font.3F

Hi,

Did you enable the 'Always' checkbox, as written in that link? That way it works for me for both 4.1.4 and master under Fedora (when 'Use system font for user UI' is also activated). The substitution in my case is Cantarell->FreeMono.
Comment 6 jpka 2014-01-08 08:11:16 UTC
Yes, i check 'Always' box. Then trying check and uncheck 'Use system font for user UI'.
BTW, as i discover today, the Apache OpenOffice has the exactly same bug added between versions "AOO401m5(Build:9714) Rev. 1524958 Apache OpenOffice 4.0.1" (this bug present) and "OpenOffice 3.2.1" (this bug not exist).
Unfortunately i can't find any info how to track errors (like --verbose key) for OOo/LibO.
Comment 7 Maxim Monastirsky 2014-01-08 08:38:37 UTC
So the problem is only when the system font set to a bitmap font (like 'Terminus'). Such font doesn't even appear in the font list, so LO can't use it or substitute it (or substitute another font with it). You can't even use this font in a document. So it turns like LO doesn't support bitmap fonts at all. So I'll mark this bug as a duplicate of Bug 73303, and turn the latter into a feature request to support bitmap fonts.

*** This bug has been marked as a duplicate of bug 73303 ***
Comment 8 Maxim Monastirsky 2014-01-08 08:42:11 UTC
Sorry, duplicate is not the appropriate status for this, see the wiki (How to handle clones).
Comment 9 jpka 2014-01-08 09:09:17 UTC
Dear Maxim, this bug is *not* about bitmap font. This particularly bug about the TTF fonts (say FreeMono) which appears at list well, but not work for me, in new 4.x tree (regression). Please see carefully 'Steps to reproduce'. Thanks.
Comment 10 Maxim Monastirsky 2014-01-08 15:45:18 UTC
Ah, now I understand what you mean, sorry.

As for 4.1.4 you can do the same with 'Segoe UI' font.

You can always find the correct font name at http://cgit.freedesktop.org/libreoffice/core/tree/officecfg/registry/data/org/openoffice/VCL.xcu. At the top right corner you have a combo-box, where you need to choose the needed version. You need to find your locale (like <node oor:name="en" oor:op="replace"> for English), and check the first font of "UI_SANS" category.
Comment 11 jpka 2014-01-09 10:32:35 UTC
It is very interesting information, but i still no have success.
Using name 'Segoe UI' directly (typing it manually, because i can't have that font, it's proprietary) not work as before.
I also found on local LibO installation that i have file very similar to mentioned file, it is '/usr/lib/libreoffice/share/registry/main.xcd' (1,4 MB), and it contains 'Segoe UI' as should. But editing or even removing that file not changes anything at all. Looks like LibO just can't find or do not use that file.
I think there is serious packaging trouble, so i will wait for Ubuntu bug 1261168 [1] will be solved officially, then i continue my research.
My locale always en_EN-UTF8.
Thanks!
[1] https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1261168
Comment 12 Maxim Monastirsky 2014-01-09 14:27:50 UTC
Created attachment 91753 [details]
screenshot with working solution

(In reply to comment #11)
> It is very interesting information, but i still no have success.
Strange, since it works for me! Take a look at the attached screenshot. It's Ubuntu 12.04.3 (64-bit) fully updated, with en_US locale and LibreOffice 4.1.4 from PPA. I even set the system font to 'Terminus'!
Comment 13 jpka 2014-01-10 18:36:04 UTC
I was able to reproduce this with clean install on Ubuntu 12.04. So this bug (if it even bug, not a local settings failure) should be closed.
If i then find something reproduceable for local settings/config, i will write here.
P.S. BTW, trying to find what's wrong with my local LibO settings, (and trying to clean settings), i'm stuck: on my working machine, when i completely delete '~/.config/libreoffice', then just start 'libreoffice', then i look where i wipe recently, and find partial configs at place, -- which, at least, contains my previous font substitutions! But where LibO get it?! I search through all my files with 'grep -R', try to catch with 'inotifywatch', but no success. Unbelieveable. Some people reports about same problem (can't delete user prefs) but for LibO 3.x, here http://askubuntu.com/questions/289962/how-do-i-reset-libreoffice-user-preference I have same problem now with LibO 4.1.4.2...
Comment 14 Maxim Monastirsky 2014-01-12 06:42:22 UTC
(In reply to comment #13)
> on my working machine, when i
> completely delete '~/.config/libreoffice', then just start 'libreoffice',
> then i look where i wipe recently, and find partial configs at place, --
> which, at least, contains my previous font substitutions! But where LibO get
> it?!
You might have ~/.libreoffice left from 3.5 days. LO also might try to import OOo\AOO setting (as I see from comment 6 that you installed those).
Comment 15 jpka 2014-01-12 20:31:01 UTC
Yes, i lave old ~/.libreoffice, and some configs from old .openoffice, but deleting it not helpful. I will try to search more, because it is interesting and strange.

Some more things.
1. I create new user, with clean home folder, and this bug not disappear: it still exist. So it may not depends on per-user configs, but on something in system.
2. So, i was trying to reproduce my own bug using fully clean install and apply software (and fonts, etc.) which i currently have. But i can't reproduce. I have now other system with all software as in buggy system, but not have the bug. Apply my old config also not discover the bug. So it looks like temporary minor problem.
3. When bug exist, it is also exist in Apache Openoffice, please see https://issues.apache.org/ooo/show_bug.cgi?id=123996 , but, as with LibO, not reproduceable by other users.
Thank you so much!
Comment 16 V Stuart Foote 2014-03-02 19:18:45 UTC
QA admin--removing Accessibility tag from title