Download it now!
Bug 73377 - FORMATTING Single quote to force text not hidden as expected
Summary: FORMATTING Single quote to force text not hidden as expected
Status: RESOLVED DUPLICATE of bug 99930
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 96158 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-01-07 23:31 UTC by James Murray
Modified: 2016-07-20 07:38 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
trivial spreadsheet with unexpected quote showing (7.38 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-01-07 23:31 UTC, James Murray
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James Murray 2014-01-07 23:31:13 UTC
Created attachment 91625 [details]
trivial spreadsheet with unexpected quote showing

In Excel and OpenOffice typing in a single quote "'" at the start of a field forces text.

In this version of LibreOffice (at least) the quote itself is shown unexpectedly.

e.g. start a new spreadsheet and type
'1
'test

Expected result, spreadsheet shows:
1
test

Actual result, spreadsheet shows:
1
'test
Comment 1 Dominique Boutry 2014-01-15 10:39:19 UTC
Reproduced with LibO 4.2.0.1 rc1 on Win7
Comment 2 Buovjaga 2015-12-01 09:06:37 UTC
*** Bug 96158 has been marked as a duplicate of this bug. ***
Comment 3 James Murray 2016-02-09 10:59:00 UTC
Still the same in 5.0.4.2, it is inconsistent annoying behaviour.
Comment 4 Laurie 2016-07-19 22:53:05 UTC
This one is annoying to me, not because it looks different but because it also behaves differently in lookups.
Below is what I wrote as we concluded checks for a different problem.

Using a single quote at the start of a number ('65635 because I want it treated as text) is treated differently in my LO 5.1.1.3 and in the 5.1.5.1 version I used just now. In 5.2.0.2 that worked properly again, as in 4.0.4.2 and earlier. In 5.1.x.x I have to copy another cell to where I want the new value then backspace out the unwanted number and type in the new one else my lookups do not work on the new (account) number. The difference is very visible in the cell. I did not ask about that earlier as I had changed computers and thought that might be the problem. But 5.2.0.2 worked so I doubt that it is the hardware.

They appear to be stored differently as can be seen in the examples copied below. The same key was used to commence those numbers but in different versions of LO.

 '27393  < should be  not > ‘29999

Hope that helps.
Comment 5 V Stuart Foote 2016-07-20 03:09:28 UTC
Any change if you on Tools -> AutoCorrect Options -> Localized Options tab uncheck the Single Quotes replace action?

The glitch is fixed for 5.2 and master builds.
Comment 6 Laurie 2016-07-20 07:13:44 UTC
Yes, Thanks.
That appears to work for me.
Comment 7 V Stuart Foote 2016-07-20 07:38:50 UTC
Eike R. took care of this at 5.2.0 with
http://cgit.freedesktop.org/libreoffice/core/commit/?id=48d0affa114d6838c0e99f3f3588dd611a4a2b72

Details in dupe bug 99930

*** This bug has been marked as a duplicate of bug 99930 ***