Bug 73573 - EDITING: Cannot update index (does not work at all) in LO, and 4.2 RC1 & RC 2
Summary: EDITING: Cannot update index (does not work at all) in LO, and 4.2 RC...
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected) release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
Whiteboard: BSA
Depends on:
Reported: 2014-01-13 21:57 UTC by Maarten
Modified: 2015-04-01 14:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:

document in which updating of index is not possible (278.83 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-01-13 21:57 UTC, Maarten
"assign styles" will bring it back again. (6.87 KB, image/png)
2014-07-11 01:59 UTC, Kevin Suo

Note You need to log in before you can comment on or make changes to this bug.
Description Maarten 2014-01-13 21:57:18 UTC
Created attachment 92003 [details]
document in which updating of index is not possible

I tried the latest release candidate of LO, LO 4.2 RC & and RC2, on both windows 7 and windows 8 machines. 

In Libreoffice 4.2 rc 1 & 2 the automatic generation of an index is not working properly. It also is not working properly on LO (the last stable version). 

What did I do? I am working with some other students on a paper. My fellow students all use Office, and have sent me contributions to a master paper (which I am creating in LO). All contributions form my fellow students were sent to me by mail (as attachment) and as .docx XML file. I opened these files (which did not give any problem) and saved the several contributions on my pc as .odt file. As I am creating the master file, I then inserted several .odt documents in the master file (which I always save as .odt file).

I was able to generate an index in the master file (in the standard way, using 'insert', then 'index an   d registers' and so on). At first, the index was created at the page of my choice. I added new segment and chapters to my file, and used the layout menu to give the supposed new chapter s (which had to be appear in the index) the head 'kop 1'. This is the way I always work and so far it worked nicely. 

Now, and there is no difference between LO 4.1 and the rc's of LO 4.2, if I want to update my register by right-clicking in the register itself and selecting update, nothing happens. The register is not updated at all.. 

Hope you got enough info from me, and are able to resolve the problem. I'll add a document, so you can see for yourself. If you have any questions, please feel free to ask me. 

Maarten van der Velden

Operating System: Windows 7
Version: release
Comment 1 Kevin Suo 2014-07-11 01:59:24 UTC
Created attachment 102586 [details]
"assign styles" will bring it back again.

Hi, Please try this:

Right-click the index -> edit index/table -> check "additional styles", then click the "..." next to it -> bring "Kop 1" to level one.

Is it OK to mark this as WORKSFORME?
Comment 2 QA Administrators 2015-02-19 04:40:03 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

Message generated on: 2015-02-18
Comment 3 QA Administrators 2015-04-01 14:52:17 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

-- The LibreOffice QA Team This NEEDINFO Message was generated on: 2015-04-01

Warm Regards,
QA Team