Bug 73611 - The formatting of the styles is lost from document created in LibreOffice 3.6
Summary: The formatting of the styles is lost from document created in LibreOffice 3.6
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: noRepro:4.2.0.2:OSX
Keywords: preBibisect, regression
Depends on:
Blocks: Writer-Styles
  Show dependency treegraph
 
Reported: 2014-01-14 15:50 UTC by Emerson
Modified: 2019-02-09 17:10 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
example odt problem e image format correct. (81.31 KB, application/zip)
2014-01-14 15:50 UTC, Emerson
Details
Print Screen of libre office 4 - format problem (61.55 KB, image/jpeg)
2014-01-17 10:40 UTC, Emerson
Details
Print Screen of libre office 3.6 - format OK (81.86 KB, image/jpeg)
2014-01-17 10:41 UTC, Emerson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Emerson 2014-01-14 15:50:19 UTC
Created attachment 92051 [details]
example odt problem e image format correct.

The ODTs documents that were created in LibreOffice 3.6 are losing the formatting styles when opened in libreoffice 4.x.

Attached an example of a document with an image problem and the correct format of the document.
Comment 1 Cor Nouws 2014-01-14 20:23:24 UTC
Hi Emerson,

Can you pls describe presicely the problem?

Which line, paragraph, style ...

thanks a lot,
Cor
Comment 2 Emerson 2014-01-15 11:18:24 UTC
Description of the problem:
When we open a document created in version 3.6 and contains numerators / markers follow the following formats are modified / added:

A 5pt border is added and the spacing between the letters is changed from 0.3 to 2.4 pt condensed in the following styles:

Title of document
text
Items markers
Comment 3 tommy27 2014-01-17 06:49:56 UTC
a comparative screenshot of the 3.6 look of the document and the 4.x look would help as well
Comment 4 Emerson 2014-01-17 10:40:33 UTC
Created attachment 92275 [details]
Print Screen of libre office 4 - format problem

Print Screen of libre office 4 - format problem
Comment 5 Emerson 2014-01-17 10:41:41 UTC
Created attachment 92276 [details]
Print Screen of libre office 3.6 - format OK

Print Screen of libre office 3.6 - format OK
Comment 6 Jean-Baptiste Faure 2014-01-19 21:43:02 UTC
I do not reproduce with versions 4.0.6 and 4.1.4 (release) or 4.2.1.0.0+ (development) on Ubuntu 13.10 x86-64.

Please, try to reinitialize your LibreOffice user profile : https://wiki.documentfoundation.org/Faq/General/110

Best regards. JBF
Comment 7 Jacques Guilleron 2014-01-19 22:31:40 UTC
I don't reproduce with LO 4.2.0.2 nor with LO 4.2.1.0.0+
Build ID: d77f6160afc213cd1cb8c658ece4e074f4e60bce
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-01-17_02:12:39
Windows 7 Home Premium

Kind regards,

Jacques
Comment 8 Emerson 2014-01-20 15:56:49 UTC
Today I tested it on several computers with windows xp and windows 7 and all PCs I could reproduce the problem.

The fact that the windows in Portuguese can be the problem?
Comment 9 Thomas van der Meulen 2014-01-21 10:18:13 UTC
I also can not reproduce this bug running 4.2.0.2 on mac osx 10.9.2
Comment 10 Pedro 2014-02-26 10:38:11 UTC
Bug confirmed under Windows XP x86 using LO 4.2.1.1 with Portuguese UI

The text with Tahoma font is indeed tighter than when the English UI is used. Please notice that the odd formatted text is set to Character Spacing: Very Tight

However selecting the text and clicking on Very Tight (i.e. reapplying the style) with the English UI produces the same result on the font.

However the black bars only show up with the Portuguese UI
Comment 11 Olivier Hallot 2014-02-26 11:16:33 UTC
The black bars also appears in pt-BR. The black bars are borders in Texto style, inherited from "Capa do título" style.
Comment 12 Pedro 2014-02-26 11:35:22 UTC
Just checked with LO 4.0.6.2 with Portuguese UI and the problem does not occur

Therefore this is a regression in branch 4.1

Emerson, I recommend that you install version 4.0.6.2 available from
http://downloadarchive.documentfoundation.org/libreoffice/old/4.0.6.2/
until this bug is fixed
Comment 13 tommy27 2014-02-26 11:39:57 UTC
should we label this as a mab4.1?
Comment 14 tommy27 2014-02-26 12:12:12 UTC
(In reply to comment #0)
> Created attachment 92051 [details]
> example odt problem e image format correct.
> 
> The ODTs documents that were created in LibreOffice 3.6 are losing the
> formatting styles when opened in libreoffice 4.x.
>

@Emerson
which 4.x did you use? 4.0.x branch or 4.1.x branch?
did you try 4.0.6 a s suggested by Pedro?
Comment 15 Emerson 2014-02-26 12:22:34 UTC
Hello, I just checked in version 4.0.6.2 and it worked perfectly.
Comment 16 Emerson 2014-02-26 12:23:33 UTC
We are currently using version 4.1.x
Comment 17 Michael Stahl (allotropia) 2014-03-11 13:44:52 UTC
on Linux, cannot reproduce any borders being drawn in any version i tried.

only difference i can see:

in 3.6.6 the "below paragraph" spacing on the list items is 0.3 cm,
but in 3.6.5 and older it is 0cm.

actually in OOo 3.3 and LO 3.4.6 it is also 0.3cm...
presumably change in 3.6.6 a bugfix?

ah indeed it is:

commit abb84c2cce54a903ef846cbfe297b2bbc62ff260
Author:     Caolán McNamara <caolanm@redhat.com>
AuthorDate: Thu Jan 17 12:41:11 2013 +0000

    Resolves: fdo#58730 workaround [UL|LR]Space 100% problem
Comment 18 Emerson 2014-03-11 13:50:28 UTC
Estou em férias, retorno dia 17/03.

Obrigado
Emerson Valdir Pellis
Comment 19 tommy27 2014-07-20 11:20:50 UTC
hi Emerson,
are you still reproducing the issue in LibO 4.2.5.2?
it looks fine to me using that version.
Comment 20 Xisco Faulí 2016-09-13 11:24:03 UTC
Adding keyword 'preBisect' as this regression was introduced before branch 4.4 and therefore it can't be bibisected as there's no bibisect repository for this branch.
Comment 21 Xisco Faulí 2017-09-29 08:51:47 UTC Comment hidden (obsolete)
Comment 22 Roman Kuznetsov 2019-02-09 17:10:59 UTC
example looks good in

Version: 6.3.0.0.alpha0+ (x64)
Build ID: eca59b6b8a0cf826ac59f77aec9acf045340c23f
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-01-16_03:48:12
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

Status->WFM