Bug 73794 - Some essential menu items always greyed out in ubuntu 13.10
Summary: Some essential menu items always greyed out in ubuntu 13.10
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-19 13:48 UTC by tim
Modified: 2014-01-20 13:10 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tim 2014-01-19 13:48:20 UTC
On ubuntu 13.10, 64 bit.

In Writer, Save and Undo are always greyed out in the Unity menu, even when changes have been made.  The toolbar buttons still work, but this is a serious nuisance, particular when one has a long-ingrained habit of using keyboard shortcuts to save documents.

Similar problems seem to exist in Calc and probably other parts of LO.
Comment 1 tim 2014-01-19 14:05:20 UTC
In an attempt to get keyboard shortcuts set up for things like Save, I went into Tools, Customise, Keyboard shortcuts and saw Ctrl Z was still set up for Undo.

So, open a document.  Type something. Ctrl Z to undo.  It does, but menu item is still greyed out.  Start typing again, and menu item is not greyed out any more.

After further tests, the problem seemed to be getter better, but in Calc I still have to insert, ctrl Z once, and then the menu works OK.

Baffling.

This installation is on a new PC, new ubuntu 13.10 (unity - common menu) and new LO 4.1.3 and then upgraded via the ppa to 1.4.4.
Comment 2 Jean-Baptiste Faure 2014-01-19 16:54:32 UTC
I do not reproduce with the generic Linux version LO 4.1.4.2 from http://www.libreoffice.org/download/ on Ubuntu 13.10 x86-64.
So seems to be an Ubuntu bug.

Please, report the bug to Ubuntu : https://wiki.documentfoundation.org/QA/BugReport/Ubuntu

That said, before doing that, you could try if cleaning your LO user profile do not fix the problem: https://wiki.documentfoundation.org/Faq/General/110

Closing as NotOurBug. Feel free to reopen if you can reproduce on another distribution. 

Best regards. JBF
Comment 3 tim 2014-01-19 17:27:11 UTC
Since the generic LO doesn't, I assume, use the unity menu bar, it's not too surprising that it behaves differently.

However, I am aware that LO has code specially written (appmenu?) to support unity, so I'm not convinced it must be an ubuntu problem.

There is, anyway, a fault raised on ubuntu, Bug #1263205 in launchpad, to which there has so far been no concrete reply.

I'm not sure what else I can test, since it is most likely related to the interaction between LO and unity.

Would it be possible for someone else to try and reproduce this using the ubuntu ppa?  It is a seriously irritating problem.
Comment 4 Jean-Baptiste Faure 2014-01-19 18:36:32 UTC
Unity menu bar is available if LO is built under Ubuntu. I have built LO 4.1.x on Ubuntu 13.10 x86-64 and I never had such a problem.

Best regards. JBF
Comment 5 tim 2014-01-19 19:42:41 UTC
I get the feeling I am being given the brush-off.  A shame, since I've raised quite a number of genuine faults on LO in the past and never been treated that way before.

Maybe it's just the language used.

To restate.  My system has a problem with LO menus.  I am not the only one (see the launchpad ref).

I can't prove it because there is no way I can think of to demonstrate such a problem with a test file. 

I have, as suggested, renamed the .config for LO and started again.  Calc still misbehaves at times.  Strangely this is not a wholly predictable and repeatable fault.  Sometimes I will edit a faile and the save is not enabled.  Sometimes it is.  I know it sounds crazy, but it is real.

Your system doesn't have this problem, but maybe others do.

In the past I ran ubuntu 12.04 and for reasons I don't quite understand LO always had an integrated menu bar, rather than unity bar, even when coming from the ubuntu ppa.  Frankly, if I could revert to that type of menu I would.
Comment 6 Jean-Baptiste Faure 2014-01-19 20:56:51 UTC
I do not say that there is no bug, but that the bug is in the build provided by Ubuntu. To check that you can install the generic Linux version, remove the Ubuntu version first to avoid interferences.

That said, if you do not use the standard theme from Ubuntu, perhaps you should try with a basic Ubuntu installation.

Best regards. JBF
Comment 7 tim 2014-01-19 21:25:47 UTC
OK, Thanks.

I'll try that when I get time, hopefully tomorrow.  Using the generic build gives other problems, such as no working Mysql(Native) build, but I'll see.

I am not sure what you mean by a 'basic ubuntu installation'.  I installed from the standard libreoffice ppa (not the pre-release one).
Comment 8 tim 2014-01-20 13:10:39 UTC
I have decided to disable the 'appmenu' in ubuntu (by uninstalling indicator-appmenu).  Save and undo don't work 1st time, but sometimes seem to work on a second attempt to display the menu.  In addition, there are no 'underlines' on the menu items, and I need that.

As you said, it appears to be an ubuntu/unity problem.

Apologies for being a bit frustrated with your response yesterday.

Thanks again for your help.