Bug 73841 - Slow performance with "walking ants" selection animation when copying large amounts of cells
Summary: Slow performance with "walking ants" selection animation when copying large a...
Status: RESOLVED DUPLICATE of bug 56613
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-20 18:24 UTC by Jean-François Fortin Tam
Modified: 2015-03-08 14:19 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-François Fortin Tam 2014-01-20 18:24:33 UTC
This is the same thing as bug #36283, but I can't "reopen" somebody else's bug report so filing a new one, with more relevant information.

First, Gnumeric is affected by the same problem, although it is affected much more strongly than LibreOffice - see https://bugzilla.gnome.org/show_bug.cgi?id=381011#c12

Second, this behavior may be more visible with unoptimized GPU drivers (ex: using the rather new radeonsi open-source driver, vs the mature and optimized intel drivers).

And finally, here's how I can trigger the bug with LOo Calc 4.1.4.2 on Fedora 20:

1. Zoom out to 25%. On a 1920x1080 screen this means a *lot* of visible cells
2. Select the biggest possible visible rectangle of cells (ex: A1 to CO214)
3. Ctrl+C

Result; watch Calc and Xorg eat the CPU alive. Also, try making rectangle selections (by dragging cells) in Calc and notice that the blue rectangle selection is sluggish. When you press Escape to dismiss the "walking ants" copy selection, performance goes back to normal (dragging a rectangle selection is fluid).

In the case of Gnumeric, the problem (from what we know so far) is that they are invalidating the whole rectangle bounding box (and thus redrawing that instead of only drawing the ant-cursor repeatedly).

See also the gnumeric bug report for more investigation information.
Comment 1 Cor Nouws 2014-06-25 10:57:46 UTC
Hi Jean-Fraincois,

Would be interesting to see if this improved in recent 4.2.5.2 and 4.3.0.1.
Could you pls try that?
thanks,
Cor
Comment 2 Tomaz Vajngerl 2015-03-08 14:19:59 UTC

*** This bug has been marked as a duplicate of bug 56613 ***