Bug Hunting Session
Bug 73865 - FILESAVE: Can't save ODS file after editing
Summary: FILESAVE: Can't save ODS file after editing
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: notBibisectable, regression
Depends on:
Blocks:
 
Reported: 2014-01-21 07:30 UTC by q12w
Modified: 2018-12-09 06:39 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
EditSaveBug (623.13 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-01-21 07:30 UTC, q12w
Details

Note You need to log in before you can comment on or make changes to this bug.
Description q12w 2014-01-21 07:30:42 UTC
Created attachment 92506 [details]
EditSaveBug

Hello

When we try to edit and save this file (see attachment) it fails with this error:

Error saving the document FILE: Write Error. The file could not be written.

Bug occurs on Windows XP and Windows Server 2008 (no matter x86 and amd64) platform with LibreOffice 4.1.3.2.
On Ubuntu 13.10 with LibreOffice 4.1.3.2 everything is fine
With LibreOffice 3.6.3.1 and LibreOffice 4.0.3.3 on Windows platform everything is fine.
Comment 1 tommy27 2014-01-31 22:55:15 UTC
tested under Win7 64bit

4.0.6 can save
4.1.0 can't save (same error dialog reported by user)

regression of the 4.0.x branch

I add Calc expert to CC list.
Comment 2 q12w 2014-02-03 05:23:42 UTC
New update:

Bug exists on:
 - Windows XP Pro SP3 (32bit). LibreOffice Version: 4.1.2.3 build ID: 40b2d7fde7e8d2d7bc5a449dc65df4d08a7dd38. 
 - Windows XP Pro SP3 (32bit). LibreOffice Version: 4.2.0.4 build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71 (latest release)

Bug does not exist on:
 - Windows XP Pro SP3 (32bit). LibreOffice Version: 3.6.3.1 build ID: f8fce0b
 - Ubuntu 13.10 (64 bit). LibreOffice Version: 4.2.0.4 build ID: 420m0(Build:4)
Comment 3 Robinson Tryon (qubit) 2015-03-05 18:44:39 UTC
(In reply to q12w from comment #2)
> Bug does not exist on:
>  - Windows XP Pro SP3 (32bit). LibreOffice Version: 3.6.3.1 build ID: f8fce0b
>  - Ubuntu 13.10 (64 bit). LibreOffice Version: 4.2.0.4 build ID:
> 420m0(Build:4)

Looks like there's only repro on Windows, so bibisecting won't work on GNU/Linux.

q12w: Have you tried testing this bug on our latest build of LibreOffice? It's possible that a fix has been introduced in the last year:
https://www.libreoffice.org/download/
Comment 4 Robinson Tryon (qubit) 2015-03-05 18:44:59 UTC
Whiteboard -> notBibisectable
Comment 5 Robinson Tryon (qubit) 2015-12-10 01:26:34 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2017-01-03 19:42:57 UTC Comment hidden (obsolete)
Comment 7 Aron Budea 2018-12-09 06:39:38 UTC
No save error in LO 6.2 beta1 / Windows 7.
I could reproduce it in 4.2.0.4, so let's assume it's fixed.