Bug 74021 - XLSX import: crash if loading documents with missing cell ref
Summary: XLSX import: crash if loading documents with missing cell ref
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.2.0.3 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-24 15:39 UTC by Sven-Jacobi
Modified: 2014-02-10 14:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
document that can't be loaded (9.00 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-01-24 15:39 UTC, Sven-Jacobi
Details
patch fixing the load problem (1.05 KB, patch)
2014-01-24 15:45 UTC, Sven-Jacobi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sven-Jacobi 2014-01-24 15:39:17 UTC
Created attachment 92734 [details]
document that can't be loaded

If you load the attached document LO will crash. The reason for this is that an uninitialised row address of -1 was used.

My attached patch is fixing the problem.
Comment 1 Sven-Jacobi 2014-01-24 15:45:26 UTC
Created attachment 92735 [details]
patch fixing the load problem
Comment 2 Julien Nabet 2014-01-24 21:29:50 UTC
On pc Debian x86-64 with 4.2 sources updated some days ago, I don't reproduce this.
If you provided a patch, I suppose you built sources, do you confirm?
If yes, which branch did you use?
Comment 3 m.a.riosv 2014-01-25 03:12:26 UTC
Hi Sven,
not reproducible with:
Win7x64Ultimate.
Version: 4.1.6.0.0+ Build ID: 873be8f3ff28fd06b531b17d2c7cc41cbc1385
Version: 4.2.0.3 Build ID: c63c03decdf780d8fb80823950665b782ec9ecd0
Version: 4.2.1.0.0+ Build ID: 23221e48495262d0384c9169a0d8a01db8a5dab5
         TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-01-21_13:02:45
Comment 4 Julien Nabet 2014-01-25 07:50:40 UTC
Sven-Jacobi: did you install any LO extensions?
Could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile) and give it a new try?
Comment 5 Sven-Jacobi 2014-01-27 10:44:19 UTC
I was building v 4.2.0.1.0+ on MacOSX 10.8 with latest XCode 5.02. 

Maybe the problem has already been fixed then I am fine that this issue is closed.
Comment 6 Julien Nabet 2014-01-31 12:19:12 UTC
Sven: to be sure, could you give a try to the brand new stable LO version 4.2.0.4?
Comment 7 Sven-Jacobi 2014-02-10 14:14:16 UTC
Indeed, in the latest version 4.2 the crash does not happen anymore -> I close this issue.