Bug 74052 - EDITING: PIVOT TABLE, creating a group in one PT also change the same field in all PT from same data source.
Summary: EDITING: PIVOT TABLE, creating a group in one PT also change the same field i...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 91165 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-01-25 16:11 UTC by m.a.riosv
Modified: 2015-05-08 19:47 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample file with 4 PT, 3 from the same data, 1 from a second data. (28.61 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-01-25 16:11 UTC, m.a.riosv
Details
Sample file with several named ranges on the same source range. (46.52 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-10-15 09:17 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description m.a.riosv 2014-01-25 16:11:25 UTC
Created attachment 92772 [details]
Sample file with 4 PT, 3 from the same data, 1 from a second data.

Steps to reproduce:

Open attached file.
3 PTs in:
Sheet1.D1
Sheet1.D16
Pivot Table_Sheet1_1.A1
have the same data source in Sheet1.A1:B7
the PT in:
Sheet1.K1
have their data source in Sheet1.H1:I7

Go to Sheet1.D4
F12 or Menu/Data/Group/Group.
Select Month for group and Ok.
grouping is applied to the three first PTs, not for the fourth.
Ctrl+F12 to ungroup.
ungrouping is applied to the three first PTs.

Go to Sheet1.K4
F12.
Select Month for group and Ok.
grouping is applied only to this PT, not for the rest.
Ctrl+F12 to ungroup.
Ungrouping is applied only to this PTs.

The bug:
The group is applied to all PTs with the same data source in the same field even if the field name have been changed, or the PT is in other sheet.

Win7x64Ultimate.
Versión: 3.6.7.2 (ID de compilación: e183d5b)
Version: 4.0.6.2 (Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24)
Version: 4.1.6.0.0+ Build ID: 873be8f3ff28fd06b531b17d2c7cc41cbc1385e
Version: 4.2.0.3 Build ID: c63c03decdf780d8fb80823950665b782ec9ecd0
Version: 4.2.1.0.0+ Build ID: 23221e48495262d0384c9169a0d8a01db8a5dab5
Version: 4.3.0.0.alpha0+ Build ID: 77637324abc193d831bb4a0fa6f9a91ef3601960
         TinderBox: Win-x86@39, Branch:master, Time: 2014-01-22_16:19:04

regression from:
LibreOffice 3.5.7.2  Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b
Comment 1 Cor Nouws 2014-01-25 21:11:48 UTC
I confirm the behavior in 4.2.0.3 on Ubuntu
Comment 2 m.a.riosv 2014-03-18 22:04:10 UTC
Still reproducible.
Version: 4.3.0.0.alpha0+ Build ID: 12ae7672f285da1d4c730315e8db23b3396b71cc
   TinderBox: Win-x86@39, Branch:master, Time: 2014-03-14_00:18:00
Comment 3 Andras Timar 2014-03-28 08:23:29 UTC
3.6.0.1 has the bug, changing version field accordingly.
Comment 4 Kohei Yoshida 2014-10-15 01:57:03 UTC
BTW, the group data is stored in the pivot cache itself, so if multiple pivot tables share the same data source i.e. linked to the same pivot cache backend, they do share the group fields.  So this is by design.

Previous versions didn't do it, which was incorrect and caused all sorts of issues because the pivot tables were out of sync with the cache.
Comment 5 m.a.riosv 2014-10-15 09:17:01 UTC
Created attachment 107859 [details]
Sample file with several named ranges on the same source range.

I don't hesitate it must be so, but changes of behavior are always a source of confusion.
 
In any way, an easy workaround/solution seems to be, that there is no problem using named ranges (different named ranges on the same source range) for every PT.

Please @Kohei could you confirm that using named ranges, is a right solution?

Maybe would not hurt, add a comment in the help.
Comment 6 Kohei Yoshida 2014-10-15 12:40:13 UTC
Using named ranges and assign different names to the same source will work, for now.  Though unfortunately I cannot give you a guarantee that it will continue to work in the future.  I would have to check on how Excel's file format handles pivot cache data for different named ranges referencing the same source.
Comment 7 Kohei Yoshida 2014-10-15 13:08:10 UTC
Ah, good news.  Excel stores different pivot caches for different named ranges even when they share the same source.  So, we can expect that to work for Calc too.
Comment 8 Kohei Yoshida 2014-10-15 13:11:26 UTC
So, let me close this as a not-a-bug, because it is not a bug. :-)
Comment 9 GerardF 2015-05-08 19:44:08 UTC
*** Bug 91173 has been marked as a duplicate of this bug. ***
Comment 10 GerardF 2015-05-08 19:47:28 UTC
*** Bug 91165 has been marked as a duplicate of this bug. ***