Bug 74120 - Segfault in libmergedlo.so causing kernel crash
Summary: Segfault in libmergedlo.so causing kernel crash
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-27 17:46 UTC by HJ
Modified: 2015-07-18 17:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
kernel.log except + software versions (9.61 KB, text/plain)
2014-01-27 17:46 UTC, HJ
Details
another kernel.log trace (10.24 KB, text/x-log)
2014-01-28 09:28 UTC, HJ
Details

Note You need to log in before you can comment on or make changes to this bug.
Description HJ 2014-01-27 17:46:20 UTC
Created attachment 92870 [details]
kernel.log except + software versions

I just experienced a disappointing laptop freeze during a meeting.
Hard drive seemed to become inaccessible.

I was using LO to view a .docx document (among other things) and compare it with another .docx document (same one, previous version). Suddenly, my computer stopped responding. I was able to launch a terminal with a keyboard shortcut, but no shell was loaded.
I suspect soffice and friends to be the culprit due to kernel.log indications (please see attachment). However, I may be wrong in the identification of the cause.

For some reason, the kernel said at some point "Fixing recursive fault but reboot is needed!" which is a new one for my collection…

During the past few days, I used the "compare" feature a lot, and experienced a lot of sudden crashes from LO (but not to this extent).

I run Xubuntu 13.10, and the up-to-date kernel in the repositories (3.11.0-15-generic) on a x86_64 processor.

Precise software versions can be found in the attachment.

I can provide more information about my system upon request.

Hoping this could help improving LO…
Best regards,

HJ
Comment 1 Björn Michaelsen 2014-01-27 18:59:01 UTC
Hi HJ,

Im not a kernel guy at all, but the kernel stack trace suggests file-io happening (and failing?) at this point. As such the LibreOffice crash might be a result of something going wrong in the kernel, rather than the other way around. 

To debug the possible LibreOffice issue, it would be great to have a stacktrace with debug symbols (package libreoffice-dbg) or even better a reproduction scenario.
Comment 2 Julien Nabet 2014-01-27 20:02:19 UTC
HJ: perhaps you already how to do retrieve a stacktrace but to complete what Björn indicated, here is a link which may help: https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace
Comment 3 HJ 2014-01-28 09:28:00 UTC
Björn and Julien,

Thank you for your prompt reaction and your kind remarks.

I will try to provide a detailed log later this week (very little time available at the moment). However, while I knew a full log would be better, I was reluctant to fully crash my system another time… But it just reproduced (new kernel.log excerpt attached) so I feel it may be of some interest.

Concerning the kernel issue, I agree that a LO crash should not freeze the OS (thus exhibiting a kernel issue), but as the kernel bug seems to be triggered by LO, I though that:
- investigating the LO issue may be beneficial for a more precise assessment by kernel developers;
- consequences of this issue on the kernel may increase its importance for LO developers.

Finally, this issue seems to be related to (and possible duplicate of):
- https://bugs.freedesktop.org/show_bug.cgi?id=70937
- https://bugs.freedesktop.org/show_bug.cgi?id=63517
- http://comments.gmane.org/gmane.comp.documentfoundation.libreoffice.bugs/131062
- https://bugs.mageia.org/show_bug.cgi?id=10812
- http://markmail.org/message/gcpicl3qcp2x3x3s

Regarding reproduction scenario, it seem to be related to a particular document which is unfortunately confidential. When I have time for a detailed report, I will also try to get a "minimal crashing example"…
Comment 4 HJ 2014-01-28 09:28:38 UTC
Created attachment 92910 [details]
another kernel.log trace
Comment 5 Julien Nabet 2014-01-29 19:34:44 UTC
Matúš: I noticed "libmerged" in both stacktraces, any idea how to dig here? (what about this "soffice.bin Tainted" too)

I put it at NEW since there are stacktraces.
Comment 6 Edward M. Grant 2014-06-26 04:37:41 UTC
The kernel crash is due to a bug where an application trying to core-dump on an ecryptfs mount on an ext4 partition with aes-ni enabled causes the kernel to explode. I found this out myself last week. The only solution I'm aware of at the moment is to blacklist the aesni_intel module and live with software encryption until it's fixed.

However, LibreOffice is the only program I run which core-dumps on a regular basis, and for no apparent reason; usually it's just after I cut a bunch of text out of a document. Mine's crashing in libmerdlo.so as well, but I think that's just some huge shared library that contains most of the code?

It's getting to the point where I'm going to have to find a new word processor, because lately I've spent almost as much time restarting LibreOffice as I do writing.
Comment 7 Matúš Kukan 2014-06-26 07:11:00 UTC
I don't understand this bug.
Yes, libmerged is just a huge shared library. It should fail the same way if you split it into many smaller.

So - is LO crashing? Can you provide any backtrace?
Or any way to reproduce this problem?
Comment 8 Julien Nabet 2014-06-26 17:25:45 UTC
You're right Matus, I put it at NEW but we need a backtrace/a file to reproduce the problem.

HJ/Edward: please try this:
- uninstall any LO version (Help package and related)
- rename you LO directory profile
- install a recent LO version (last one is 4.2.5)
Comment 9 Edward M. Grant 2014-12-03 02:52:35 UTC
This was probably fixed in or before 4.2.7. I have a document which crashes every time I cut certain lines of text on one machine that's running SL6, but works fine on this one running Mint 17.
Comment 10 QA Administrators 2015-06-08 14:28:27 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INVALID
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/NEEDINFO

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
 
Thank you for helping us make LibreOffice even better for everyone!

This NEEDINFO Message was generated on: 2015-06-08

Warm Regards,
QA Team
Comment 11 QA Administrators 2015-07-18 17:27:07 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and a lack of information which is needed in order to accurately reproduce and confirm the problem. We encourage you to retest your bug against the latest release. If the issue is still present in the latest stable release, we need the following information (please ignore any that you've already provided):

a) Provide details of your system including your operating system and the latest version of LibreOffice that you have confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED and we will attempt to reproduce the issue. 
Please do not:
a) respond via email 
b) update the version field in the bug or any of the other details on the top section of FDO

Message generated on: 2015-07-18