Bug 74163 - Trendline equation should be shown ONLY for XY charts
Summary: Trendline equation should be shown ONLY for XY charts
Status: RESOLVED DUPLICATE of bug 73450
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-28 21:35 UTC by Laurent BP
Modified: 2014-04-21 20:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Article about nonsense trendlines for chart with caterogical X-variables (§3 p194) (403.81 KB, application/pdf)
2014-01-29 20:17 UTC, Laurent BP
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent BP 2014-01-28 21:35:31 UTC
Showing equation (and R^2) on diagram with a type different from XY (scatter) is a non sense as X-values in equation do not correspond to axis.

- Trendline UI should disable checkboxes of equation and R^2 if type is different from scatter diagram
- When changing type, equations should be removed if new type is different from scatter diagram
Comment 1 m.a.riosv 2014-01-28 23:46:57 UTC
Hi Laurent, I'm not so sure about it, maybe in some situations can be useful, if people want to have the formula visible while hidden the line selecting an invisible line style.
Comment 2 Laurent BP 2014-01-29 20:08:32 UTC
@mariosv: May I try to be a little bit clearer. 

Trendline equation is non-sense for no "XY (scatter)" chart. 
I mean for "Column", "Bar", "Area", "Line" and "Column and Line" charts (trendline is not available for "Pie", "Bubble", "Net" and "Stock") the equation does not consider the value of the "x" values because they are read as Categories. The equation consider that first categories has a value of 1, second a value of 2, and so on, whatever its "real" value is, because Categories can also be simple text. So the equation is not significant with these types.

Lets take an example which corresponds to a common error of beginner:
1. Enter Data such as X=1, 10, 100 and Y=11, 12, 13
2. Create a *XY* (scatter) chart
3. Insert trendline and show equation
=> f(x) = 0.0165165165x + 11.3888888889
With same data:
4. Create a *Line* chart with  "First column as label" selected on 2nd step
5. Insert linear trendline and show equation
=> f(x) = 1x + 10

User may think that the equation in the Line chart is valid which is obviously wrong.
Comment 3 Laurent BP 2014-01-29 20:17:03 UTC
Created attachment 93013 [details]
Article about nonsense trendlines for chart with caterogical X-variables (§3 p194)

In this article, with hard criticism against Excel trend lines, authors underline the nonsense of trend line equation with chart having categorical X-variables: chapter 3 on page 194.

Authors ask to remove "Add trendline" command for such charts. However, it may be useful to show the trend line, but the equation itself is not significant.
Comment 4 m.a.riosv 2014-01-29 22:31:03 UTC
Are you so sure that no one will be affected?
Then please forget my comment.
Comment 5 Laurent BP 2014-01-30 21:21:12 UTC
I am sure that the equation is nonsense in case of categorical X-variables. So I do not see how a user can be interested with such equation. He would only have a bad representation of his data and a bad opinion of the software when he will realize that the equation is totally foolish.

I opened discussion on mailing list (qa and ux) to get more advise about this.
Comment 6 m.a.riosv 2014-01-31 00:27:01 UTC
Thanks for the choice Laurent. Always good have a broad opinion.
Comment 7 Laurent BP 2014-01-31 19:26:20 UTC
Found one case: X-categories can be considered as date with Column, Bar, Area, Line, Column and Line. In this case, equation is significant.

Then test would be on whether the X axis is text or not.
Comment 8 Laurent BP 2014-04-21 20:08:47 UTC

*** This bug has been marked as a duplicate of bug 73450 ***