Bug 74173 - RTF: images shown as empty misaligned frames on re-open of document
Summary: RTF: images shown as empty misaligned frames on re-open of document
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-29 10:14 UTC by marshals
Modified: 2016-10-09 22:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
RTF with images shown as empty misaligned frames (35.66 KB, application/rtf)
2014-01-29 10:14 UTC, marshals
Details
PDF from export of RTF (97.06 KB, application/pdf)
2014-01-29 10:14 UTC, marshals
Details

Note You need to log in before you can comment on or make changes to this bug.
Description marshals 2014-01-29 10:14:10 UTC
Created attachment 92983 [details]
RTF with images shown as empty misaligned frames

i created an RTF document with images and captions with my daughter with 4.1.3.  everything was displayed correctly.  (i don't know if it's relevant, but i had to use the paste/bitmap workaround mentioned in https://bugs.freedesktop.org/show_bug.cgi?id=55735#c5 to paste some of the images in, to avoid making writer slow and unusable.)
however, on re-opening the document several days later, the images were shown as empty frames and without some of their alignment/positioning/etc.  
exporting the document as PDF resulted in a PDF that looked exactly like the RTF.

i tried upgrading to 4.1.4 to see if that version would open the RTF ok, but it did not.

to see the problem: open the attached RTF.  
- images are shown as empty frames
- one frame on p1 spans onto p2
- all frames have lost their alignment (which was to the left or right of the paragraph in which they were inserted)

i've also attached the PDF.

when i originally came across the problem, i saved the document as an ODT to see if that would solve it.  with 4.1.3, i was then unable to open the ODT (Writer gave an error).  however, i can open the ODT with 4.1.4, although the images are shown as for the RTF.
Comment 1 marshals 2014-01-29 10:14:49 UTC
Created attachment 92984 [details]
PDF from export of RTF
Comment 2 Thomas van der Meulen 2014-01-30 18:19:13 UTC
Thank you for your bug report,
I can reproduce that wenn I open the RTF that they the pictures aren't shown. they are just white frames. 

Test details: 
Version: 4.2.0.4
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71
os: mac osx 10.9.1
Comment 3 QA Administrators 2016-02-21 08:37:45 UTC Comment hidden (obsolete)
Comment 4 Xisco Faulí 2016-10-09 22:32:10 UTC
White frames are also seen in Microsoft Word 2010, thus this is not a bug.