Download it now!
Bug 74237 - zoom slider disappear
Summary: zoom slider disappear
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: x86 (IA32) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-30 17:20 UTC by Pierre-Alain Dorange
Modified: 2017-10-20 22:21 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
screen capture of the problem (267.85 KB, image/png)
2014-01-30 17:20 UTC, Pierre-Alain Dorange
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre-Alain Dorange 2014-01-30 17:20:51 UTC
Created attachment 93070 [details]
screen capture of the problem

Problem description: 
Sometime the zoom slider disappear, the only way to make him back to to close the document and reopen it.

Steps to reproduce:
I found no way to reproduce it, but it happen quite often.
I suppose it's related to window resizing (i do a lot, because i deal with multiples documents for copy-paste)

Current behavior:
no zoom slider

Expected behavior:
zoom slider always displayed
Comment 1 Dominique Boutry 2014-02-01 10:21:50 UTC
Hi,

When resizing the draw window fast enought, one can see the rightmost part of status bar (zoom %) updated a fraction of second after stopping resizing the window.

I tried to resize the DRAW window at a very hight rate/speed, whilst I had a high workload for my computer (my antivirus doing a complete check) :
- after some seconds, the zoom % freezes (was no longer updated),
- after some more seconds, DRAW crashes.

Not exactly the misbehaviour reported, but clearly a bug somewhere in the place.
Comment 2 Dominique Boutry 2014-02-01 10:22:51 UTC
Sorry, I forgot the version : LibO 4.2.0.4 on Win7.
Comment 3 Stefan Knorr (astron) 2014-02-03 20:03:14 UTC
Re comment 1: This sounds a little like a duplicate of bug 33848 . Pierre-Alain, can you check if that is why it happened? (Never mind that the bug is for Impress -- the code is the same. That would be fixed in 4.2.0. But since you originally used 4.1.4.2 for the version field, I thought it wouldn't hurt to ask.)

Re comment 2: Yes, this is updated, because zoom size is set to optimal (i.e. fit the entire page). So, this is a feature.
Comment 4 Stefan Knorr (astron) 2014-02-03 20:04:30 UTC
Sorry... there were some mistakes:

(In reply to comment #3)
> Re comment 1:

Should be: Re description.

> Re comment 2: Yes, this is updated, because zoom size is set to optimal
> (i.e. fit the entire page). So, this is a feature.

Should be: Re comment 1.
Comment 5 Pierre-Alain Dorange 2014-02-03 21:32:59 UTC
(In reply to comment #3)
> Re comment 1: This sounds a little like a duplicate of bug 33848 .
> Pierre-Alain, can you check if that is why it happened? (Never mind that the
> bug is for Impress -- the code is the same. That would be fixed in 4.2.0.
> But since you originally used 4.1.4.2 for the version field, I thought it
> wouldn't hurt to ask.)

Yes, you're right it sounds like it was the same bug.
And same as 33848 i could found a way to reproduce it. i work a lot with Draw ands suddenly a notice zoom slider was not here (of course when a want to use it).
The only clue i have is that a use a lot windows resize during my work (i deal with many windows).
Comment 6 Joel Madero 2015-05-02 15:42:36 UTC Comment hidden (obsolete)
Comment 7 Olav Dahlum 2015-06-03 19:08:16 UTC
Confirmed in 4.4.3 on Windows 7 x64 by a user who upgraded from 4.2.x.
Comment 8 QA Administrators 2016-09-20 09:46:24 UTC Comment hidden (obsolete)
Comment 9 eisa01 2017-10-20 22:21:32 UTC
I have not managed to get zoom slider to disappear during my testing

Version: 6.0.0.0.alpha1+
Build ID: 15dce20e8b97dbd0179f01910ca4d0027e80ff4e
CPU threads: 2; OS: Mac OS X 10.12.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2017-10-20_06:46:46
Locale: en-US (en_US.UTF-8); Calc: group