Bug Hunting Session
Bug 74247 - EDITING: Request ability to configure text export used when pasting plain text
Summary: EDITING: Request ability to configure text export used when pasting plain text
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: Other Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Save-Text
  Show dependency treegraph
 
Reported: 2014-01-30 21:51 UTC by Andy Goth
Modified: 2017-06-17 19:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andy Goth 2014-01-30 21:51:35 UTC
Problem description: When saving to CSV, I have the option to specify the character set, the field delimiter, and the text delimiter, plus a few other things.  I don't have any of these options when copying cells and pasting to plain text (e.g. to PuTTY); it always uses tabs to separate cells.  For my application, tabs are forbidden, and I must use spaces.  My workaround is to paste to Vim, convert tabs to spaces, then copy and paste again to where I need it.

Steps to reproduce:
1. Copy cells
2. Paste to an application expecting plain text, e.g. PuTTY
3. Cells are separated by tabs, no matter what you may have wanted

Current behavior:
Pasting to plain text always separates cells with tabs

Expected behavior:
Configuration dialog accessible somewhere in menus to change the delimiters in the same manner as when saving to CSV.
Operating System: Windows 7
Version: 4.1.4.2 release
Comment 1 Jean-Baptiste Faure 2014-02-02 07:53:45 UTC
As it exposed, it is not a bug description but an enhancement request.

Please, could you check if you can't do what you want with current new version 4.2 ?

Best regards. JBF
Comment 2 Andy Goth 2014-02-03 00:15:26 UTC
Will download 4.2 momentarily.  First let me thank you for changing this to a feature request.  I tried to report it as such by using "Help > Send Feedback... > File An Enhancement Request", but it still came up as a bug.  Guess we need a meta bug report on that. :^P
Comment 3 Andy Goth 2014-02-03 00:37:38 UTC
Okay, installed.  Nope, I can't find any such option.  I'm not sure where it would be, but I looked throughout Edit and Tools > Options.
Comment 4 Tomaz Vajngerl 2014-02-13 20:44:07 UTC
Valid enhancement request I think.