Bug Hunting Session
Bug 74314 - [UI] Impress: no sound listed in gallery for animation or transition if you add language pack
Summary: [UI] Impress: no sound listed in gallery for animation or transition if you a...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.0.3 rc
Hardware: x86-64 (AMD64) All
: highest major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: mab4.2
  Show dependency treegraph
 
Reported: 2014-02-01 11:25 UTC by vulcain
Modified: 2014-07-13 15:39 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
No sound listed (43.89 KB, image/png)
2014-02-01 11:25 UTC, vulcain
Details
Sound selection with LibreOffice 3.5.7 (159.18 KB, image/png)
2014-02-01 11:26 UTC, vulcain
Details
no sounds in 4.3b1 on win7 x64 (321.78 KB, image/png)
2014-05-23 15:26 UTC, Dominik
Details
no sounds in 4.3b1 in German while 4.2.4.2 in English has some (win 7 x64) (333.63 KB, image/png)
2014-05-23 15:49 UTC, Dominik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vulcain 2014-02-01 11:25:23 UTC
Created attachment 93161 [details]
No sound listed

On Ubuntu 12.04.4 x86_64, LibreOffice 4.2.0.4 Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71 

1) Open a new presentation document
2) Add a Smiley face from the Symbol Shape set
3) Select the Smiley face and click on the Animation icon on the side pane
4) Click on the + on the Animation tab to add an animation
5) Select the Circle animation on the tab
6) Clik OK
7) Click on the Options [...] button
8) Choose the sound you like

Result no sound are found (see attachment)

Expected:  Have the list of sound (see second attachment)

The same problem affect sound selection in animation or in transition
Comment 1 vulcain 2014-02-01 11:26:43 UTC
Created attachment 93162 [details]
Sound selection with LibreOffice 3.5.7
Comment 2 vulcain 2014-02-01 12:03:38 UTC
A workforme is to choose a sound's file in /opt/libreoffice4.2/share/gallery/sounds or /usr/lib/libreoffice/share/gallery/sounds

After that, all sounds are listed
Comment 3 pierre-yves samyn 2014-02-01 12:36:09 UTC
Hello

I reproduce on windows 7/64 with Version: 4.2.0.4
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71

Also reproduce with 4.1.4

I change platform to "All"

Was ok with Version 4.0.2.1 (Build ID: 7e5467ff8f30d821f4fbf69cb2769163eb64c2c)


Regards
Pierre-Yves
Comment 4 Pierre C 2014-02-01 17:23:52 UTC
I reproduce on LO 4.1.5.2 Seven x64
Comment 5 Julien Nabet 2014-02-01 23:18:44 UTC
On pc Debian x86-64 with 4.2 sources updated some days ago (commit 5ced55668d729c49c154f9d2d81907f3d44e3593) or with 4.1 sources updated about 1 week ago (commit b99a2691484e9b0533530ad4f02e15ad4031b74b), I don't reproduce this.
Comment 6 vulcain 2014-02-02 08:20:35 UTC
(In reply to comment #5)
> On pc Debian x86-64 with 4.2 sources updated some days ago (commit
> 5ced55668d729c49c154f9d2d81907f3d44e3593) or with 4.1 sources updated about
> 1 week ago (commit b99a2691484e9b0533530ad4f02e15ad4031b74b), I don't
> reproduce this.
@ Julien Nabet :

If you delet or rename your profil (~/.config/libreoffice/4) my workforme (see comment #2) lost. 

Could see if it's change something for you ??
Comment 7 Julien Nabet 2014-02-02 10:22:34 UTC
vulcain: I don't understand your last comment.
Most of the time, I've got a clean LO profile since I build from sources and run almost each time a "make clean".
Comment 8 vulcain 2014-02-02 12:11:26 UTC
(In reply to comment #7)
> vulcain: I don't understand your last comment.

Sorry, English is not my native language.

> Most of the time, I've got a clean LO profile since I build from sources and
> run almost each time a "make clean".

However, you give me the answer: so this bug could be fixed in LibreOffice 4.2.1.0 or in 4.1.6.0
I will wait.
Comment 9 Michael Stahl (CIB) 2014-02-05 11:46:22 UTC
just for the record i can't reproduce this with the versions given here
Comment 10 retired 2014-02-05 19:58:06 UTC
While I can't seem to find any sounds in 4.2.0.4 I can find them in the latest nightly of 4.3.0.0a0+.

So I think we can set this to WORKSFORME and 4.2.1 should bring a fix for this.

Please re-open if I'm missing something and you disagree.
Comment 11 vulcain 2014-02-16 20:14:48 UTC
I still reproduce this bug in LibreOffice 4.2.1.1 Build ID: d7dbbd7842e6a58b0f521599204e827654e1fb8b on Ubuntu 12.04.4 x86_64
( i clean LO profile before install RC2 )

Strangely, my workforme in comment 2 don't work
Comment 12 pierre-yves samyn 2014-02-17 09:06:02 UTC
Hello

(In reply to comment #11)
> I still reproduce this bug in LibreOffice 4.2.1.1 Build ID:
> d7dbbd7842e6a58b0f521599204e827654e1fb8b on Ubuntu 12.04.4 x86_64
> ( i clean LO profile before install RC2 )
> 

I still reproduce on windows 7/64 with Version: 4.2.1.1
Build ID: d7dbbd7842e6a58b0f521599204e827654e1fb8b

But I do *not* reproduce the bug with Version: 4.3.0.0.alpha0+
Build ID: e076b5290e706b8a69abd397a9f255eba6a0cd1a
TinderBox: Win-x86@39, Branch:master, Time: 2014-02-13_23:23:34

(In reply to comment #11)
> Strangely, my workforme in comment 2 don't work

It has never worked on my platform.

Regards
Pierre-Yves
Comment 13 vulcain 2014-03-10 09:50:06 UTC
Bug still here in LibreOffice  4.2.2.1 (Build ID: 3be8cda0bddd8e430d8cda1ebfd581265cca5a0f )
Comment 14 vulcain 2014-05-23 12:50:10 UTC
In LibreOffice 4.3.0.0.beta1 Build ID: 2e39c7e59c8fc8b16a54c3d981dceef27fb0c07f

We have a list of sound but no sound when we launch the animation in the slideshow via F5
Comment 15 Dominik 2014-05-23 15:26:34 UTC
Created attachment 99653 [details]
no sounds in 4.3b1 on win7 x64

on 4.3.0b1 on a windows 7 x64 i don't have sounds to select.

further (when the options on the right side are hidden) a right click on the foil and in the menu selecting transition, doesn't do anything.
Comment 16 Dominik 2014-05-23 15:49:45 UTC
Created attachment 99658 [details]
no sounds in 4.3b1 in German while 4.2.4.2 in English has some (win 7 x64)
Comment 17 vulcain 2014-05-24 10:15:08 UTC
(In reply to comment #14)
> In LibreOffice 4.3.0.0.beta1 Build ID:
> 2e39c7e59c8fc8b16a54c3d981dceef27fb0c07f
> 
> We have a list of sound but no sound when we launch the animation in the
> slideshow via F5

Mistake: We have a list of sound if we don't
Comment 18 vulcain 2014-05-24 10:20:19 UTC
(In reply to comment #14)
> In LibreOffice 4.3.0.0.beta1 Build ID:
> 2e39c7e59c8fc8b16a54c3d981dceef27fb0c07f
> 
> We have a list of sound but no sound when we launch the animation in the
> slideshow via F5

Mistake: We have a list of sound if we don't install french language pack.

Same behavior with LibreOffice 4.2.4.2 Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8

@ Dominik: Your screenshot show 4.2 in English with list of sound and 4.3 in German with no list of sound.
Comment 19 vulcain 2014-05-24 10:26:44 UTC
New step by step:
1) Install LibreOffice 
2) Install language pack (for me french language pack, like yhis one: LibreOfficeDev_4.3.0.0.beta1_Linux_x86-64_deb_langpack_fr.tar.gz)
3) Open a new presentation document
4) Add a Smiley face from the Symbol Shape set
5) Select the Smiley face and click on the Animation icon on the side pane
6) Click on the + on the Animation tab to add an animation
7) Select the Circle animation on the tab
8) Clik OK
9) Click on the Options [...] button
10) Choose the sound you like

No list of sound

Expected: have the list of sound as like EN_US version.
Comment 20 vulcain 2014-05-24 10:26:56 UTC
@ Sophie: I should change composent =Presentation for another. But UI or localization, linguistic ??
Comment 21 vulcain 2014-06-02 22:20:17 UTC
With 4.2.5.1 Build ID: 881bb88abfe2992c6cede97c23e64a9885de87de => no bug without language pack, reproduce if you add French language

Same behavior 4.1.0.3 Build ID: 0f08a823567f802c29cbaf2b327db19aaf72016

Work fine or without language pack in 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)
Comment 22 Joel Madero 2014-06-02 22:31:50 UTC
In the future please don't nominate your own bug reports as MAB - we tend to not do that because bias can get involved :) That being said - for this to be a MAB it should be marked as Highest and a comment should be put on the meta tracker explaining why this one was added.

Lastly - a bibisect would be useful (and should have been done before adding to the MAB but that's okay). Please attempt a bibisect if possible
https://wiki.documentfoundation.org/QA/HowToBibisect
Comment 23 vulcain 2014-06-03 10:37:18 UTC
(In reply to comment #22)
> In the future please don't nominate your own bug reports as MAB - we tend to
> not do that because bias can get involved :) That being said - for this to
> be a MAB it should be marked as Highest and a comment should be put on the
> meta tracker explaining why this one was added.

Ok, i try to remember it.

> Lastly - a bibisect would be useful (and should have been done before adding
> to the MAB but that's okay). Please attempt a bibisect if possible
> https://wiki.documentfoundation.org/QA/HowToBibisect

Sorry i don't have the time to learn it.
Comment 24 Joel Madero 2014-06-18 04:40:59 UTC
After reading all of this I'm relatively sure this is not bibisectable because it deals with language packs which I don't think are installable for bibisect package.

Removing bibisectrequest - moving to highest to correspond with Most Annoying Bug list.
Comment 25 vulcain 2014-06-24 07:46:28 UTC
I think this bug must be in LibreOffice 4.3 most annoying bugs (bug 75025)
Comment 26 Julien Nabet 2014-06-24 08:00:51 UTC
Sorry, I had forgot this one.
There's a fix on master and 4.3, waiting for review in 4.2

*** This bug has been marked as a duplicate of bug 80327 ***
Comment 27 vulcain 2014-07-02 12:28:48 UTC
I confirm that is the same bug.

I am happy to know that LibreOffice 4.2.6 fixed it :-)
Comment 28 vulcain 2014-07-13 07:03:05 UTC
\o/

I confirm this bug is fixed in LibreOffice 4.2.6.1 Build ID: 5fdddf655fba363e34f755715238d0943a44857e

Tested on Ubuntu 12.04.4 x86_64

Thanks for your works
https://bugs.freedesktop.org/show_bug.cgi?id=80327
Comment 29 retired 2014-07-13 15:39:06 UTC
Thanks for the update vulcain. And glad this bug was tackled. It indeed was annoying.