Bug Hunting Session
Bug 74387 - UI: When row(s) selected, make context menu consistent between row & individual cells
Summary: UI: When row(s) selected, make context menu consistent between row & individu...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Context-Menu Cell-Selection
  Show dependency treegraph
 
Reported: 2014-02-02 16:21 UTC by dg1727
Modified: 2019-01-30 13:32 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dg1727 2014-02-02 16:21:37 UTC
1.  Create a new document in Calc.  
2.  Click a row label to select the row.  
3.  Right-click the row label.  In the resulting context menu, notice that there are row-specific options such as Insert Rows Above.  
4.  Right-click a cell within the selected row.  In this context menu, the row-specific options are gone.  For example, there is now Insert... instead of Insert Rows Above, although in this case it does the same thing as Insert Rows Above.  

Preferably, when whole row(s) are selected, the context menu should be similar between (a) being invoked on a row label or (b) being invoked on a cell within the selected row.  

If there are programmatic ways to access, e.g., "Insert...", so that removing Insert... from the cell context menu would break those user scripts, then maybe there is a way to leave the cell-oriented menu entries but make them invisible, so they can be accessed only programmatically.  (I think that, when whole row[s] are selected, the cell context menu should give the row-specific entry names rather than the row-label context menu giving the generic cell-oriented entry names.)  

I'm using LibreOffice 4.1.4.2 on Ubuntu 13.04.
Comment 1 A (Andy) 2014-11-08 22:29:48 UTC
Reproducible with LO 4.3.3.2, Win 8.1.

I currently don't see obstacles which could prevent this.  For me it seems to be ok and good, that if the row (and only then) is selected that the context menu should show the row-specific options.
Comment 2 andreas_k 2019-01-28 22:24:16 UTC
for me this is a WFM cause this is the intention of context menues.
Comment 3 Heiko Tietze 2019-01-30 13:32:09 UTC
(In reply to andreas_k from comment #2)
> for me this is a WFM cause this is the intention of context menues.

Agreed. We cannot "Insert Rows Above", for example, when a single cell is selected. Could also be the column, the cell, the sheet etc.