Download it now!
Bug 74400 - Problem with "show table" in "form view"
Summary: Problem with "show table" in "form view"
Status: RESOLVED DUPLICATE of bug 67615
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-02 18:00 UTC by Olrg Murawicki
Modified: 2015-01-22 21:43 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshots (593.10 KB, application/vnd.oasis.opendocument.text)
2014-02-02 18:00 UTC, Olrg Murawicki
Details
patients_therapy-2014.01.30.odb (504.66 KB, application/vnd.oasis.opendocument.database)
2014-02-02 20:49 UTC, Olrg Murawicki
Details
Same database - all '0' have gone (504.62 KB, application/vnd.sun.xml.base)
2014-02-03 19:45 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olrg Murawicki 2014-02-02 18:00:11 UTC
Created attachment 93241 [details]
screenshots

After upgrade 4.1.4.2 >> 4.2.0.4 I saw a problem in Base (screenshots added). 
I use ukrainian in my databases. The same situation was in Slackware, Debian, PCLinuxOS, Kubuntu & Hackintosh.
Comment 1 Robert Großkopf 2014-02-02 18:51:25 UTC
Have a look at Bug67615 . Seems to be a duplicate.
Seems it has something to do with the language you installed.
See https://bugs.freedesktop.org/show_bug.cgi?id=67615#c8 and try to solve the problem in this way for you - but it doesn't solve the buggy behavior. 

If you could solve it that way please mark this bug as a duplicate of Bug67615.
Comment 2 Olrg Murawicki 2014-02-02 20:18:49 UTC
I have ukrainian language-pack installed in Libreoffice 4.1.4 and 4.2.0. Other additional packages are the same. The bug disappeared immediately after downgrade to 4.1.4. And more: in Slackware, Debian, PCLinuxOS, Kubuntu and Hackintosh the bug exists only in 4.2.0 and disappearing after downgrade to 4.1.4. So, the problem is somewhere in 4.2.0 


On Sun, 02 Feb 2014 18:51:25 +0000
bugzilla-daemon@freedesktop.org wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=74400
> 
> robert@familiegrosskopf.de changed:
> 
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                  CC|                            |robert@familiegrosskopf.de
>            See Also|                            |https://bugs.freedesktop.or
>                    |                            |g/show_bug.cgi?id=67615
> 
> --- Comment #1 from robert@familiegrosskopf.de ---
> Have a look at Bug67615 . Seems to be a duplicate.
> Seems it has something to do with the language you installed.
> See https://bugs.freedesktop.org/show_bug.cgi?id=67615#c8 and try to solve the
> problem in this way for you - but it doesn't solve the buggy behavior. 
> 
> If you could solve it that way please mark this bug as a duplicate of Bug67615.
> 
> -- 
> You are receiving this mail because:
> You reported the bug.
Comment 3 Robert Großkopf 2014-02-02 20:37:16 UTC
(In reply to comment #2)
Could you add a database as attachment here, which shows the bug? Must only have some rows content and a tablecontrol, where '0' appears.
Comment 4 Olrg Murawicki 2014-02-02 20:49:31 UTC
Created attachment 93253 [details]
patients_therapy-2014.01.30.odb

Sending a database...


On Sun, 02 Feb 2014 20:37:16 +0000
bugzilla-daemon@freedesktop.org wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=74400
> 
> --- Comment #3 from robert@familiegrosskopf.de ---
> (In reply to comment #2)
> Could you add a database as attachment here, which shows the bug? Must only
> have some rows content and a tablecontrol, where '0' appears.
> 
> -- 
> You are receiving this mail because:
> You reported the bug.
Comment 5 Robert Großkopf 2014-02-03 19:45:52 UTC
Created attachment 93312 [details]
Same database - all '0' have gone

It's the same bug. I have opened the table for editing, saw many Char-fields which show '0' or were empty instead of '@' as the default format. I changed the language and changed it back. The text appears in the table.

Now I can see the text in LO 4.2.0.4 and LO 4.1.4.2 with OpenSUSE 12.3 64bit rpm.

Could you please mark this bug as duplicate, if you could see the text also with this attachment?
Comment 6 Olrg Murawicki 2014-02-04 16:43:27 UTC
It's not the same bug. I've changed languages in Debian, Slackware & Hackintosh. Zeros're still in place.

On Mon, 03 Feb 2014 19:45:52 +0000
bugzilla-daemon@freedesktop.org wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=74400
> 
> --- Comment #5 from robert@familiegrosskopf.de ---
> Created attachment 93312 [details]
>   --> https://bugs.freedesktop.org/attachment.cgi?id=93312&action=edit
> Same database - all '0' have gone
> 
> It's the same bug. I have opened the table for editing, saw many Char-fields
> which show '0' or were empty instead of '@' as the default format. I changed
> the language and changed it back. The text appears in the table.
> 
> Now I can see the text in LO 4.2.0.4 and LO 4.1.4.2 with OpenSUSE 12.3 64bit
> rpm.
> 
> Could you please mark this bug as duplicate, if you could see the text also
> with this attachment?
> 
> -- 
> You are receiving this mail because:
> You reported the bug.
Comment 7 Robert Großkopf 2014-02-04 18:28:53 UTC
Do you really see the same buggy behavior in https://bugs.freedesktop.org/attachment.cgi?id=93312 ?

I couldn't confirm this bug, because I have seen the same behavior as in Bug67615 . 
Could be you have changed the language anywhere else. I have changed it the following way:
Opened Table "patients_all" for editing, not for data-input
Go to fieldname "name".
See (at the bottom) Format Example.
There has been a '0'.
Press the button with the three points and chose another language.
The Format Example changes to '@' (or, in other cases, to something I couldn't declare, because I couldn't read it).
Do the same for all varchar-fieldtypes.


I have done this and couldn't see any '0' in the table-view, which I saw before. And this I have attached. So someone other must have a look if he/she could confirm, that this is another bug, not the same as Bug67615. I can't.
Comment 8 Olrg Murawicki 2014-02-05 18:18:38 UTC
I've changed the language & all my information appeared. But the bug, unfortunately, is more complex: now I can't add new patients & after my attemps LibreOffice crashed.


On Tue, 04 Feb 2014 18:28:53 +0000
bugzilla-daemon@freedesktop.org wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=74400
> 
> --- Comment #7 from robert@familiegrosskopf.de ---
> Do you really see the same buggy behavior in
> https://bugs.freedesktop.org/attachment.cgi?id=93312 ?
> 
> I couldn't confirm this bug, because I have seen the same behavior as in
> Bug67615 . 
> Could be you have changed the language anywhere else. I have changed it the
> following way:
> Opened Table "patients_all" for editing, not for data-input
> Go to fieldname "name".
> See (at the bottom) Format Example.
> There has been a '0'.
> Press the button with the three points and chose another language.
> The Format Example changes to '@' (or, in other cases, to something I couldn't
> declare, because I couldn't read it).
> Do the same for all varchar-fieldtypes.
> 
> 
> I have done this and couldn't see any '0' in the table-view, which I saw
> before. And this I have attached. So someone other must have a look if he/she
> could confirm, that this is another bug, not the same as Bug67615. I can't.
> 
> -- 
> You are receiving this mail because:
> You reported the bug.
Comment 9 Robert Großkopf 2014-02-05 19:17:08 UTC
(In reply to comment #8)
> I've changed the language & all my information appeared. But the bug,
> unfortunately, is more complex: now I can't add new patients & after my
> attemps LibreOffice crashed.

You have changed the language. I have done the following: Changed, pressed OK, the "@" appeared and changed back to the default of my language, pressed OK and the "@" was still there - also the content.

I have tested the input in the form - works here. Could see also the content of the fields in the table. All tested with LO 4.2.0.4.
Comment 10 gagrilli 2014-02-12 12:34:54 UTC
Could NOT reproduce the behaviour of the OP.

Both databases (zeros, corrected zeros) react in the same way. Content appears in form, in datasource (F4), in viewing the table, in editing the table. This happens in LO 4.1.4.2 (distro version) and 4.2.0.4 (website version). 

Following the discussion, I changed the language in the field properties. (Default and greek languages installed). In the first .odb from OP, the field showed 0 indeed. Changed it back to @, by cycling the language choice. Saved. Content appears correctly. Closed the database.

However! After closing and upon re-opening, LO complains that the file has been created by a newer version, and thus cannot open it at all! Closed LO completely. Confirmed no version was left open, tried again. Same result, as if HSQLDB had changed the internal database version to 2.3 (FYI: I use HSQLDB 2.3.1 as external backend for my own work).

Thinking something is wrong with my setup, I removed the reference from my classpath (LO settings, in the java tab). No change. I re-added it. No change. I tried with a clean profile. No change.  

Re-downloaded both .odb files. Success! the database opens, both in 4.1.4.2 and 4.2.0.4. Opened th form (NOT changing-editing), closed the form. Closed the database (NOT saving anything), closed LO. Back to being unable to open the database.

Unzipped the odb files, checked database folder, database properties, sure enough "changed by 2.3 version" was written. The freshly downloaded .odb files show the "1.8" inside. Could be my own setup.

I cannot produce a working or not version of the .odb files because of this. 

In light of 
1)the table fields being defined as they are,
2)at least the date field having apparently wrong definition Text[VARCHAR]),
3)the existence of Bug67615 and alleged non-relation to this one,
4)The data appearing in full before my eyes,
4)my own mysterious observations,

I think it seems as a configuration issue. Your configuration and setup could lead us to the answer and resolution . In particular, could you go through the rouble to re-create an empty database file with its tables and forms(i.e. without populating it) and attach that? We can try and "fill it up" later. 

Tested on: generic Core-i5, Opensuse 12.2 x64, 
java version "1.7.0_45" OpenJDK Runtime Environment (IcedTea 2.4.3) 
LibreOffice version: 4.1.4.2 Build ID: 410m0(Build:2) and 
                     4.2.0.4 Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71
Comment 11 Robert Großkopf 2014-03-11 17:02:53 UTC
(In reply to comment #10)
> However! After closing and upon re-opening, LO complains that the file has
> been created by a newer version, and thus cannot open it at all! Closed LO
> completely. Confirmed no version was left open, tried again. Same result, as
> if HSQLDB had changed the internal database version to 2.3 (FYI: I use
> HSQLDB 2.3.1 as external backend for my own work).

> Unzipped the odb files, checked database folder, database properties, sure
> enough "changed by 2.3 version" was written. The freshly downloaded .odb
> files show the "1.8" inside. Could be my own setup.

You couldn't test any internal HSQLDB-file, when you have installed another version of HSQLDB, see BUG34411.
Comment 12 Lionel Elie Mamane 2014-09-03 12:31:43 UTC

*** This bug has been marked as a duplicate of bug 67615 ***